summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libgit2/libgit2_0.27.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libgit2/libgit2_0.27.9.bb')
-rw-r--r--meta-oe/recipes-support/libgit2/libgit2_0.27.9.bb24
1 files changed, 24 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libgit2/libgit2_0.27.9.bb b/meta-oe/recipes-support/libgit2/libgit2_0.27.9.bb
new file mode 100644
index 000000000..3ef7bee43
--- /dev/null
+++ b/meta-oe/recipes-support/libgit2/libgit2_0.27.9.bb
@@ -0,0 +1,24 @@
1SUMMARY = "the Git linkable library"
2HOMEPAGE = "http://libgit2.github.com/"
3LICENSE = "GPL-2.0-with-GCC-exception & MIT"
4LIC_FILES_CHKSUM = "file://COPYING;md5=3f2cd5d3cccd71d62066ba619614592b"
5
6DEPENDS = "curl openssl zlib libssh2 libgcrypt"
7
8SRC_URI = "git://github.com/libgit2/libgit2.git;branch=maint/v0.27"
9SRCREV = "3828d7afdd08b595584048e8e4dab6ddd4506ed1"
10
11S = "${WORKDIR}/git"
12
13inherit cmake
14
15EXTRA_OECMAKE = "\
16 -DTHREADSAFE=ON \
17 -DBUILD_CLAR=OFF \
18 -DSHA1_TYPE="builtin" \
19 -DCMAKE_BUILD_TYPE=RelWithDebInfo \
20 -DBUILD_EXAMPLES=OFF \
21 -DLIB_INSTALL_DIR=${libdir} \
22"
23
24BBCLASSEXTEND = "native"