diff options
Diffstat (limited to 'meta-oe/recipes-support/libeigen')
-rw-r--r-- | meta-oe/recipes-support/libeigen/libeigen/eigen-disable-tests.patch | 75 | ||||
-rw-r--r-- | meta-oe/recipes-support/libeigen/libeigen_3.2.0.bb | 25 |
2 files changed, 100 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libeigen/libeigen/eigen-disable-tests.patch b/meta-oe/recipes-support/libeigen/libeigen/eigen-disable-tests.patch new file mode 100644 index 000000000..b3dddbeaf --- /dev/null +++ b/meta-oe/recipes-support/libeigen/libeigen/eigen-disable-tests.patch | |||
@@ -0,0 +1,75 @@ | |||
1 | libeigen: don't try building tests | ||
2 | |||
3 | While configuring, if the tests are enabled, it checks some machine-specific | ||
4 | settings which we don't want to do while cross-compiling. | ||
5 | |||
6 | Upstream-Status: Inappropriate [configuration] | ||
7 | |||
8 | Signed-off-by: Lukas Bulwahn <lukas.bulwahn@oss.bmw-carit.de> | ||
9 | |||
10 | --- a/CMakeLists.txt~ 2013-07-29 16:59:48.403504947 -0400 | ||
11 | +++ b/CMakeLists.txt 2013-07-29 17:00:19.868020948 -0400 | ||
12 | @@ -346,25 +346,25 @@ | ||
13 | |||
14 | add_subdirectory(doc EXCLUDE_FROM_ALL) | ||
15 | |||
16 | -include(EigenConfigureTesting) | ||
17 | +#include(EigenConfigureTesting) | ||
18 | |||
19 | # fixme, not sure this line is still needed: | ||
20 | -enable_testing() # must be called from the root CMakeLists, see man page | ||
21 | +#enable_testing() # must be called from the root CMakeLists, see man page | ||
22 | |||
23 | |||
24 | -if(EIGEN_LEAVE_TEST_IN_ALL_TARGET) | ||
25 | - add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest | ||
26 | -else() | ||
27 | - add_subdirectory(test EXCLUDE_FROM_ALL) | ||
28 | -endif() | ||
29 | +#if(EIGEN_LEAVE_TEST_IN_ALL_TARGET) | ||
30 | +# add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest | ||
31 | +#else() | ||
32 | +# add_subdirectory(test EXCLUDE_FROM_ALL) | ||
33 | +#endif() | ||
34 | |||
35 | -if(EIGEN_LEAVE_TEST_IN_ALL_TARGET) | ||
36 | - add_subdirectory(blas) | ||
37 | - add_subdirectory(lapack) | ||
38 | -else() | ||
39 | - add_subdirectory(blas EXCLUDE_FROM_ALL) | ||
40 | - add_subdirectory(lapack EXCLUDE_FROM_ALL) | ||
41 | -endif() | ||
42 | +#if(EIGEN_LEAVE_TEST_IN_ALL_TARGET) | ||
43 | +# add_subdirectory(blas) | ||
44 | +# add_subdirectory(lapack) | ||
45 | +#else() | ||
46 | +# add_subdirectory(blas EXCLUDE_FROM_ALL) | ||
47 | +# add_subdirectory(lapack EXCLUDE_FROM_ALL) | ||
48 | +#endif() | ||
49 | |||
50 | add_subdirectory(unsupported) | ||
51 | |||
52 | @@ -384,7 +384,7 @@ | ||
53 | |||
54 | configure_file(scripts/cdashtesting.cmake.in cdashtesting.cmake @ONLY) | ||
55 | |||
56 | -ei_testing_print_summary() | ||
57 | +#ei_testing_print_summary() | ||
58 | |||
59 | message(STATUS "") | ||
60 | message(STATUS "Configured Eigen ${EIGEN_VERSION_NUMBER}") | ||
61 | --- a/unsupported/CMakeLists.txt~ 2013-07-29 16:59:54.091598607 -0400 | ||
62 | +++ b/unsupported/CMakeLists.txt 2013-07-29 17:00:27.052139300 -0400 | ||
63 | @@ -1,7 +1,7 @@ | ||
64 | add_subdirectory(Eigen) | ||
65 | add_subdirectory(doc EXCLUDE_FROM_ALL) | ||
66 | -if(EIGEN_LEAVE_TEST_IN_ALL_TARGET) | ||
67 | - add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest | ||
68 | -else() | ||
69 | - add_subdirectory(test EXCLUDE_FROM_ALL) | ||
70 | -endif() | ||
71 | +#if(EIGEN_LEAVE_TEST_IN_ALL_TARGET) | ||
72 | +# add_subdirectory(test) # can't do EXCLUDE_FROM_ALL here, breaks CTest | ||
73 | +#else() | ||
74 | +# add_subdirectory(test EXCLUDE_FROM_ALL) | ||
75 | +#endif() | ||
diff --git a/meta-oe/recipes-support/libeigen/libeigen_3.2.0.bb b/meta-oe/recipes-support/libeigen/libeigen_3.2.0.bb new file mode 100644 index 000000000..4183f0521 --- /dev/null +++ b/meta-oe/recipes-support/libeigen/libeigen_3.2.0.bb | |||
@@ -0,0 +1,25 @@ | |||
1 | DESCRIPTION = "Eigen is a C++ template library for linear algebra: matrices, vectors, numerical solvers, and related algorithms." | ||
2 | AUTHOR = "Benoît Jacob and Gaël Guennebaud and others" | ||
3 | HOMEPAGE = "http://eigen.tuxfamily.org/" | ||
4 | LICENSE = "MPL-2.0" | ||
5 | LIC_FILES_CHKSUM = "file://COPYING.MPL2;md5=815ca599c9df247a0c7f619bab123dad" | ||
6 | |||
7 | SRC_URI = "http://bitbucket.org/eigen/eigen/get/${PV}.tar.bz2 \ | ||
8 | file://eigen-disable-tests.patch" | ||
9 | SRC_URI[md5sum] = "894381be5be65bb7099c6fd91d61b357" | ||
10 | SRC_URI[sha256sum] = "011f78960d939227f9276173d0c4cc0053bb9e0a7356539a9a6c7c89d984fab6" | ||
11 | |||
12 | S = "${WORKDIR}/eigen-eigen-ffa86ffb5570" | ||
13 | |||
14 | inherit cmake | ||
15 | |||
16 | OECMAKE_SOURCEPATH = ".." | ||
17 | OECMAKE_BUILDPATH = "build" | ||
18 | |||
19 | EXTRA_OECMAKE += "-Dpkg_config_libdir=${libdir}" | ||
20 | |||
21 | FILES_${PN} = "${includedir} ${libdir}" | ||
22 | |||
23 | # ${PN} is empty so we need to tweak -dev and -dbg package dependencies | ||
24 | RDEPENDS_${PN}-dev = "" | ||
25 | RRECOMMENDS_${PN}-dbg = "${PN}-dev (= ${EXTENDPKGV})" | ||