summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/libee/libee/libee-parallel-make.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/libee/libee/libee-parallel-make.patch')
-rw-r--r--meta-oe/recipes-support/libee/libee/libee-parallel-make.patch20
1 files changed, 20 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libee/libee/libee-parallel-make.patch b/meta-oe/recipes-support/libee/libee/libee-parallel-make.patch
new file mode 100644
index 000000000..25e5c6ae0
--- /dev/null
+++ b/meta-oe/recipes-support/libee/libee/libee-parallel-make.patch
@@ -0,0 +1,20 @@
1fix parallel compiling problem
2
3without specifying libee_convert_DEPENDENCIES = libee.la, libee_convert
4can't find libee.la when linking as libee is not generated yet.
5
6Upstream-Status: pending
7
8Signed-off-by: Yao Zhao <yao.zhao@windriver.com>
9---
10diff --git a/src/Makefile.am b/src/Makefile.am
11index 08aaa9e..f0c78f7 100644
12--- a/src/Makefile.am
13+++ b/src/Makefile.am
14@@ -46,5 +46,6 @@ libee_la_LDFLAGS = -version-info 0:0:0
15 libee_convert_SOURCES = convert.c
16 libee_convert_CPPFLAGS = -I$(top_srcdir) $(LIBEE_CFLAGS) $(LIBESTR_CFLAGS) $(LIBXML2_CFLAGS)
17 libee_convert_LDADD = $(LIBEE_LIBS) $(LIBXML2_LIBS) $(LIBESTR_LIBS)
18+libee_convert_DEPENDENCIES = libee.la
19
20 include_HEADERS =