diff options
Diffstat (limited to 'meta-oe/recipes-support/libdbi')
-rw-r--r-- | meta-oe/recipes-support/libdbi/libdbi-drivers.inc | 51 | ||||
-rw-r--r-- | meta-oe/recipes-support/libdbi/libdbi-drivers_0.8.3-1.bb | 6 | ||||
-rw-r--r-- | meta-oe/recipes-support/libdbi/libdbi.inc | 17 | ||||
-rw-r--r-- | meta-oe/recipes-support/libdbi/libdbi_0.8.4.bb | 6 |
4 files changed, 80 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/libdbi/libdbi-drivers.inc b/meta-oe/recipes-support/libdbi/libdbi-drivers.inc new file mode 100644 index 000000000..b509532e4 --- /dev/null +++ b/meta-oe/recipes-support/libdbi/libdbi-drivers.inc | |||
@@ -0,0 +1,51 @@ | |||
1 | # libdbi-drivers OE build file | ||
2 | # Copyright (C) 2005, Koninklijke Philips Electronics NV. All Rights Reserved | ||
3 | # Released under the MIT license (see packages/COPYING) | ||
4 | |||
5 | DESCRIPTION = "Database Drivers for libdbi" | ||
6 | HOMEPAGE = "http://libdbi-drivers.sourceforge.net/" | ||
7 | LICENSE = "LGPLv2.1" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=d8045f3b8f929c1cb29a1e3fd737b499" | ||
9 | SECTION = "libs" | ||
10 | |||
11 | PROVIDES = "libdbd-sqlite" | ||
12 | DEPENDS = "libdbi sqlite sqlite3 mysql5 postgresql" | ||
13 | |||
14 | SRC_URI = "${SOURCEFORGE_MIRROR}/libdbi-drivers/libdbi-drivers-${PV}.tar.gz" | ||
15 | |||
16 | inherit autotools | ||
17 | |||
18 | PACKAGES += "libdbd-sqlite3 libdbd-sqlite libdbd-pgsql libdbd-mysql" | ||
19 | |||
20 | EXTRA_OECONF = "--with-dbi-incdir=${STAGING_INCDIR} \ | ||
21 | --with-dbi-libdir=${STAGING_LIBDIR} \ | ||
22 | --with-sqlite \ | ||
23 | --with-sqlite3 \ | ||
24 | --with-pgsql \ | ||
25 | --with-mysql \ | ||
26 | --with-sqlite-libdir=${STAGING_LIBDIR} \ | ||
27 | --with-sqlite-incdir=${STAGING_INCDIR} \ | ||
28 | --with-sqlite3-incdir=${STAGING_INCDIR} \ | ||
29 | --with-sqlite3-libdir=${STAGING_LIBDIR} \ | ||
30 | --with-mysql-incdir=${STAGING_INCDIR} \ | ||
31 | --with-mysql-libdir=${STAGING_LIBDIR} \ | ||
32 | --with-pgsql-incdir=${STAGING_INCDIR} \ | ||
33 | --with-pgsql-libdir=${STAGING_LIBDIR} \ | ||
34 | --disable-docs" | ||
35 | |||
36 | FILES_${PN}-dbg += " ${libdir}/dbd/.debug/*.so" | ||
37 | FILES_${PN}-dev += " ${libdir}/dbd/*.la" | ||
38 | FILES_${PN}-staticdev += " ${libdir}/dbd/*.a" | ||
39 | |||
40 | DESCRIPTION_libdbd-sqlite = "SQLite database driver for libdbi" | ||
41 | FILES_libdbd-sqlite = "${libdir}/dbd/libdbdsqlite.so" | ||
42 | |||
43 | DESCRIPTION_libdbd-sqlite3 = "SQLite3 database driver for libdbi" | ||
44 | FILES_libdbd-sqlite3 = "${libdir}/dbd/libdbdsqlite3.so" | ||
45 | |||
46 | DESCRIPTION_libdbd-mysql = "MySQL4 database driver for libdbi" | ||
47 | FILES_libdbd-mysql = "${libdir}/dbd/libdbdmysql.so" | ||
48 | |||
49 | DESCRIPTION_libdbd-psql = "Postgres SQL database driver for libdbi" | ||
50 | FILES_libdbd-pgsql = "${libdir}/dbd/libdbdpgsql.so" | ||
51 | |||
diff --git a/meta-oe/recipes-support/libdbi/libdbi-drivers_0.8.3-1.bb b/meta-oe/recipes-support/libdbi/libdbi-drivers_0.8.3-1.bb new file mode 100644 index 000000000..97bc3ea78 --- /dev/null +++ b/meta-oe/recipes-support/libdbi/libdbi-drivers_0.8.3-1.bb | |||
@@ -0,0 +1,6 @@ | |||
1 | require ${PN}.inc | ||
2 | |||
3 | PR = "r0" | ||
4 | |||
5 | SRC_URI[md5sum] = "4de79b323162a5a7652b65b608eca6cd" | ||
6 | SRC_URI[sha256sum] = "4ab9944398ce769c0deeb64d2f73555c67bc25ccd2ade1ccf552226c7b2acf72" | ||
diff --git a/meta-oe/recipes-support/libdbi/libdbi.inc b/meta-oe/recipes-support/libdbi/libdbi.inc new file mode 100644 index 000000000..cea2838e3 --- /dev/null +++ b/meta-oe/recipes-support/libdbi/libdbi.inc | |||
@@ -0,0 +1,17 @@ | |||
1 | # libdbi OE build file | ||
2 | # Copyright (C) 2005, Koninklijke Philips Electronics NV. All Rights Reserved | ||
3 | # Released under the MIT license (see packages/COPYING) | ||
4 | |||
5 | DESCRIPTION = "Database Independent Abstraction Layer for C" | ||
6 | HOMEPAGE = "http://libdbi.sourceforge.net/" | ||
7 | LICENSE = "LGPLv2.1" | ||
8 | LIC_FILES_CHKSUM = "file://COPYING;md5=d8045f3b8f929c1cb29a1e3fd737b499" | ||
9 | SECTION = "libs" | ||
10 | |||
11 | INC_PR = "r0" | ||
12 | |||
13 | SRC_URI = "${SOURCEFORGE_MIRROR}/libdbi/libdbi-${PV}.tar.gz" | ||
14 | |||
15 | inherit autotools | ||
16 | |||
17 | EXTRA_OECONF = "--disable-docs" | ||
diff --git a/meta-oe/recipes-support/libdbi/libdbi_0.8.4.bb b/meta-oe/recipes-support/libdbi/libdbi_0.8.4.bb new file mode 100644 index 000000000..aee00996e --- /dev/null +++ b/meta-oe/recipes-support/libdbi/libdbi_0.8.4.bb | |||
@@ -0,0 +1,6 @@ | |||
1 | require ${PN}.inc | ||
2 | |||
3 | PR = "${INC_PR}.0" | ||
4 | |||
5 | SRC_URI[md5sum] = "c5f15407ef7b07ba854cd8c9b15b88ff" | ||
6 | SRC_URI[sha256sum] = "ef38db616f0752ccb09b8ba2eac471722369b8ded50b153c25e238cac2c8de99" | ||