diff options
Diffstat (limited to 'meta-oe/recipes-support/i2c-tools/i2c-tools-3.1.0/Module.mk')
-rw-r--r-- | meta-oe/recipes-support/i2c-tools/i2c-tools-3.1.0/Module.mk | 72 |
1 files changed, 0 insertions, 72 deletions
diff --git a/meta-oe/recipes-support/i2c-tools/i2c-tools-3.1.0/Module.mk b/meta-oe/recipes-support/i2c-tools/i2c-tools-3.1.0/Module.mk deleted file mode 100644 index fcaf72f22..000000000 --- a/meta-oe/recipes-support/i2c-tools/i2c-tools-3.1.0/Module.mk +++ /dev/null | |||
@@ -1,72 +0,0 @@ | |||
1 | # EEPROMER | ||
2 | # | ||
3 | # Licensed under the GNU General Public License. | ||
4 | |||
5 | EEPROMER_DIR := eepromer | ||
6 | |||
7 | EEPROMER_CFLAGS := -Wstrict-prototypes -Wshadow -Wpointer-arith -Wcast-qual \ | ||
8 | -Wcast-align -Wwrite-strings -Wnested-externs -Winline \ | ||
9 | -W -Wundef -Wmissing-prototypes -Iinclude | ||
10 | |||
11 | EEPROMER_TARGETS := eepromer eeprom eeprog | ||
12 | |||
13 | # | ||
14 | # Programs | ||
15 | # | ||
16 | |||
17 | $(EEPROMER_DIR)/eepromer: $(EEPROMER_DIR)/eepromer.o | ||
18 | $(CC) $(LDFLAGS) -o $@ $^ | ||
19 | |||
20 | $(EEPROMER_DIR)/eeprom: $(EEPROMER_DIR)/eeprom.o | ||
21 | $(CC) $(LDFLAGS) -o $@ $^ | ||
22 | |||
23 | $(EEPROMER_DIR)/eeprog: $(EEPROMER_DIR)/eeprog.o $(EEPROMER_DIR)/24cXX.o | ||
24 | $(CC) $(LDFLAGS) -o $@ $^ | ||
25 | |||
26 | # | ||
27 | # Objects | ||
28 | # | ||
29 | |||
30 | $(EEPROMER_DIR)/eepromer.o: $(EEPROMER_DIR)/eepromer.c | ||
31 | $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@ | ||
32 | |||
33 | $(EEPROMER_DIR)/eeprom.o: $(EEPROMER_DIR)/eeprom.c | ||
34 | $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@ | ||
35 | |||
36 | $(EEPROMER_DIR)/eeprog.o: $(EEPROMER_DIR)/eeprog.c | ||
37 | $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@ | ||
38 | |||
39 | $(EEPROMER_DIR)/24cXX.o: $(EEPROMER_DIR)/24cXX.c | ||
40 | $(CC) $(CFLAGS) $(EEPROMER_CFLAGS) -c $< -o $@ | ||
41 | |||
42 | # | ||
43 | # Commands | ||
44 | # | ||
45 | |||
46 | all-eepromer: $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS)) | ||
47 | |||
48 | strip-eepromer: $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS)) | ||
49 | strip $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS)) | ||
50 | |||
51 | clean-eepromer: | ||
52 | $(RM) $(addprefix $(EEPROMER_DIR)/,*.o $(EEPROMER_TARGETS)) | ||
53 | |||
54 | install-eepromer: $(addprefix $(EEPROMER_DIR)/,$(EEPROMER_TARGETS)) | ||
55 | $(INSTALL_DIR) $(DESTDIR)$(sbindir) $(DESTDIR)$(man8dir) | ||
56 | for program in $(EEPROMER_TARGETS) ; do \ | ||
57 | $(INSTALL_PROGRAM) $(EEPROMER_DIR)/$$program $(DESTDIR)$(sbindir) ; done | ||
58 | |||
59 | uninstall-eepromer: | ||
60 | for program in $(EEPROMER_TARGETS) ; do \ | ||
61 | $(RM) $(DESTDIR)$(sbindir)/$$program ; \ | ||
62 | $(RM) $(DESTDIR)$(man8dir)/$$program.8 ; done | ||
63 | |||
64 | all: all-eepromer | ||
65 | |||
66 | strip: strip-eepromer | ||
67 | |||
68 | clean: clean-eepromer | ||
69 | |||
70 | install: install-eepromer | ||
71 | |||
72 | uninstall: uninstall-eepromer | ||