summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/htop/htop_3.2.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/htop/htop_3.2.1.bb')
-rw-r--r--meta-oe/recipes-support/htop/htop_3.2.1.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/htop/htop_3.2.1.bb b/meta-oe/recipes-support/htop/htop_3.2.1.bb
new file mode 100644
index 000000000..233a1eeb5
--- /dev/null
+++ b/meta-oe/recipes-support/htop/htop_3.2.1.bb
@@ -0,0 +1,36 @@
1SUMMARY = "Interactive process viewer"
2HOMEPAGE = "https://htop.dev"
3SECTION = "console/utils"
4LICENSE = "GPL-2.0-only"
5LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
6
7DEPENDS = "ncurses"
8
9SRC_URI = "git://github.com/htop-dev/htop.git;branch=main;protocol=https \
10 file://0001-Use-pkg-config.patch \
11"
12SRCREV = "4e6ec4a0873c56ca9de63eadf730c5bd677bd8da"
13
14S = "${WORKDIR}/git"
15
16inherit autotools pkgconfig
17
18PACKAGECONFIG ??= " \
19 unicode \
20 affinity \
21 delayacct \
22"
23PACKAGECONFIG[unicode] = "--enable-unicode,--disable-unicode"
24PACKAGECONFIG[affinity] = "--enable-affinity,--disable-affinity,,,,hwloc"
25PACKAGECONFIG[unwind] = "--enable-unwind,--disable-unwind,libunwind"
26PACKAGECONFIG[hwloc] = "--enable-hwloc,--disable-hwloc,hwloc,,,affinity"
27PACKAGECONFIG[openvz] = "--enable-openvz,--disable-openvz"
28PACKAGECONFIG[vserver] = "--enable-vserver,--disable-vserver"
29PACKAGECONFIG[ancient-vserver] = "--enable-ancient-vserver,--disable-ancient-vserver"
30PACKAGECONFIG[capabilities] = "--enable-capabilities,--disable-capabilities,libcap"
31PACKAGECONFIG[delayacct] = "--enable-delayacct,--disable-delayacct,libnl"
32PACKAGECONFIG[sensors] = "--enable-sensors,--disable-sensors,lmsensors,lmsensors-libsensors"
33
34FILES:${PN} += "${datadir}/icons/hicolor/scalable/apps/htop.svg"
35
36RDEPENDS:${PN} += "ncurses-terminfo-base"