summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gpm/gpm-1.99.7
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/gpm/gpm-1.99.7')
-rw-r--r--meta-oe/recipes-support/gpm/gpm-1.99.7/eglibc-2.17.patch12
-rw-r--r--meta-oe/recipes-support/gpm/gpm-1.99.7/init32
-rw-r--r--meta-oe/recipes-support/gpm/gpm-1.99.7/no-docs.patch18
-rw-r--r--meta-oe/recipes-support/gpm/gpm-1.99.7/processcreds.patch12
4 files changed, 74 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gpm/gpm-1.99.7/eglibc-2.17.patch b/meta-oe/recipes-support/gpm/gpm-1.99.7/eglibc-2.17.patch
new file mode 100644
index 000000000..e43bdcb22
--- /dev/null
+++ b/meta-oe/recipes-support/gpm/gpm-1.99.7/eglibc-2.17.patch
@@ -0,0 +1,12 @@
1Upstream-Status: pending
2
3--- gpm-1.99.7.orig/src/daemon/open_console.c 2008-07-24 12:33:05.000000000 +0200
4+++ gpm-1.99.7/src/daemon/open_console.c 2013-01-10 12:39:47.975461947 +0100
5@@ -23,6 +23,7 @@
6 #include <fcntl.h> /* open and co. */
7 #include <sys/stat.h> /* stat() */
8 #include <sys/ioctl.h> /* ioctl() */
9+#include <sys/types.h> /* major() */
10
11 /* Linux specific (to be outsourced in gpm2 */
12 #include <linux/serial.h> /* for serial console check */
diff --git a/meta-oe/recipes-support/gpm/gpm-1.99.7/init b/meta-oe/recipes-support/gpm/gpm-1.99.7/init
new file mode 100644
index 000000000..2dcf9ab04
--- /dev/null
+++ b/meta-oe/recipes-support/gpm/gpm-1.99.7/init
@@ -0,0 +1,32 @@
1#! /bin/sh
2
3# Grab the common functions
4#. /etc/init.d/functions
5
6# FIXME:
7# Add a configuration file for GPM here
8
9test -x /usr/sbin/gpm || exit 0
10
11case "$1" in
12 start)
13 if [ ! -p /dev/gpmdata ]; then
14 mkfifo /dev/gpmdata
15 fi
16
17 echo "Starting GPM:"
18 start-stop-daemon -S -x /usr/sbin/gpm -- -R -m /dev/psaux -t ps2
19 ;;
20 stop)
21 echo "Stopping GPM:"
22 start-stop-daemon -K -x /usr/sbin/gpm
23 ;;
24 restart|force-reload)
25 $0 stop
26 $0 start
27 ;;
28 *)
29 usage /etc/init.d/gpm
30esac
31
32exit 0
diff --git a/meta-oe/recipes-support/gpm/gpm-1.99.7/no-docs.patch b/meta-oe/recipes-support/gpm/gpm-1.99.7/no-docs.patch
new file mode 100644
index 000000000..f10217a94
--- /dev/null
+++ b/meta-oe/recipes-support/gpm/gpm-1.99.7/no-docs.patch
@@ -0,0 +1,18 @@
1
2#
3# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
4#
5
6Index: gpm-1.99.7/Makefile.in
7===================================================================
8--- gpm-1.99.7.orig/Makefile.in 2008-07-24 03:36:35.000000000 -0700
9+++ gpm-1.99.7/Makefile.in 2010-06-22 18:28:45.269507001 -0700
10@@ -19,7 +19,7 @@
11 # user-overridable flags, but it's also all the implicit rule looks at.
12 # missing ?
13
14-SUBDIRS = src doc contrib gpm2
15+SUBDIRS = src
16
17
18 ### simple, but effective rules
diff --git a/meta-oe/recipes-support/gpm/gpm-1.99.7/processcreds.patch b/meta-oe/recipes-support/gpm/gpm-1.99.7/processcreds.patch
new file mode 100644
index 000000000..d647eca0a
--- /dev/null
+++ b/meta-oe/recipes-support/gpm/gpm-1.99.7/processcreds.patch
@@ -0,0 +1,12 @@
1Index: gpm-1.99.7/src/daemon/processconn.c
2===================================================================
3--- gpm-1.99.7.orig/src/daemon/processconn.c 2010-09-29 17:36:18.571782951 +0400
4+++ gpm-1.99.7/src/daemon/processconn.c 2010-09-29 17:42:44.659991758 +0400
5@@ -20,6 +20,7 @@
6 *
7 ********/
8
9+#define _GNU_SOURCE
10 #include <sys/socket.h> /* accept */
11 #include <stdlib.h> /* malloc */
12 #include <unistd.h> /* close */