summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb')
-rw-r--r--meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb b/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb
new file mode 100644
index 000000000..146747eee
--- /dev/null
+++ b/meta-oe/recipes-support/gnulib/gnulib_2018-03-07.03.bb
@@ -0,0 +1,40 @@
1SUMMARY = "The GNU portability library"
2DESCRIPTION = "A collection of software subroutines which are designed to \
3be usable on many operating systems. The goal of the project \
4is to make it easy for free software authors to make their \
5software run on many operating systems. Since source is designed \
6to be copied from gnulib, it is not a library per-se, as much \
7as a collection of portable idioms to be used in other projects."
8
9HOMEPAGE = "http://www.gnu.org/software/gnulib/"
10SECTION = "devel"
11LICENSE = "LGPLv2+"
12
13LIC_FILES_CHKSUM = "file://COPYING;md5=56a22a6e5bcce45e2c8ac184f81412b5"
14SRCREV = "0d6e3307bbdb8df4d56043d5f373eeeffe4cbef3"
15
16SRC_URI = "git://git.sv.gnu.org/gnulib.git \
17"
18
19S = "${WORKDIR}/git"
20
21inherit utils
22
23do_install () {
24 cd ${S}
25 check_git_config
26 git checkout master
27 git clone ${S} ${D}/${datadir}/gnulib
28}
29
30do_patch[noexec] = "1"
31do_configure[noexec] = "1"
32do_compile[noexec] = "1"
33do_package[noexec] = "1"
34do_packagedata[noexec] = "1"
35deltask package_write_ipk
36deltask package_write_deb
37deltask package_write_rpm
38deltask do_deploy_archives
39
40BBCLASSEXTEND = "native"