summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch')
-rw-r--r--meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch30
1 files changed, 0 insertions, 30 deletions
diff --git a/meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch b/meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch
deleted file mode 100644
index 33dc9d38a..000000000
--- a/meta-oe/recipes-support/glog/glog/0001-find-libunwind-during-configure.patch
+++ /dev/null
@@ -1,30 +0,0 @@
1diff -ur git/CMakeLists.txt ../0.3.5-r0.unwind/git/CMakeLists.txt
2--- git/CMakeLists.txt 2018-10-08 08:54:15.118989400 +0200
3+++ ../0.3.5-r0.unwind/git/CMakeLists.txt 2018-10-05 16:26:59.745922318 +0200
4@@ -384,7 +384,9 @@
5 set_target_properties (glog PROPERTIES POSITION_INDEPENDENT_CODE ON)
6
7 if (UNWIND_LIBRARY)
8- target_link_libraries (glog PUBLIC ${UNWIND_LIBRARY})
9+ add_library(unwind SHARED IMPORTED)
10+ set_target_properties(unwind PROPERTIES IMPORTED_LOCATION ${UNWIND_LIBRARY})
11+ target_link_libraries (glog PUBLIC unwind)
12 endif (UNWIND_LIBRARY)
13
14 if (HAVE_PTHREAD)
15diff -ur git/glog-config.cmake.in ../0.3.5-r0.unwind/git/glog-config.cmake.in
16--- git/glog-config.cmake.in 2018-10-08 08:54:15.122989699 +0200
17+++ ../0.3.5-r0.unwind/git/glog-config.cmake.in 2018-10-08 08:14:48.550745810 +0200
18@@ -4,4 +4,12 @@
19
20 @gflags_DEPENDENCY@
21
22+find_library (UNWIND_LIBRARY NAMES unwind DOC "unwind library")
23+mark_as_advanced (UNWIND_LIBRARY)
24+
25+if (UNWIND_LIBRARY)
26+ add_library(unwind SHARED IMPORTED)
27+ set_target_properties(unwind PROPERTIES IMPORTED_LOCATION ${UNWIND_LIBRARY})
28+endif (UNWIND_LIBRARY)
29+
30 include ("${CMAKE_CURRENT_LIST_DIR}/glog-targets.cmake")