summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/fbset/fbset-modes.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/fbset/fbset-modes.bb')
-rw-r--r--meta-oe/recipes-support/fbset/fbset-modes.bb21
1 files changed, 21 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/fbset/fbset-modes.bb b/meta-oe/recipes-support/fbset/fbset-modes.bb
new file mode 100644
index 000000000..1310e6f7b
--- /dev/null
+++ b/meta-oe/recipes-support/fbset/fbset-modes.bb
@@ -0,0 +1,21 @@
1SUMMARY = "Default display timings and resolutions for fbset"
2LICENSE = "MIT"
3LIC_FILES_CHKSUM = "file://${COREBASE}/meta/COPYING.MIT;md5=3da9cfbcb788c80a0384361b4de20420"
4
5PV = "0.1.0"
6PR = "r6"
7
8SRC_URI = "file://fb.modes"
9
10do_install() {
11 install -d ${D}${sysconfdir}
12 install -m 0644 ${WORKDIR}/fb.modes ${D}${sysconfdir}
13}
14
15inherit allarch
16
17# fb.modes file is MACHINE_ARCH, base.bbclass correctly changes it to MACHINE_ARCH, but too late for allarch.bbclass
18# to disable "all" behavior (found when comparing qemuarm and qemux86 signatures)
19PACKAGE_ARCH = "${MACHINE_ARCH}"
20
21CONFFILES_${PN} = "${sysconfdir}/fb.modes"