diff options
Diffstat (limited to 'meta-oe/recipes-support/espeak')
-rw-r--r-- | meta-oe/recipes-support/espeak/espeak-data_1.37.bb | 18 | ||||
-rw-r--r-- | meta-oe/recipes-support/espeak/espeak_1.37.bb | 40 |
2 files changed, 29 insertions, 29 deletions
diff --git a/meta-oe/recipes-support/espeak/espeak-data_1.37.bb b/meta-oe/recipes-support/espeak/espeak-data_1.37.bb index d15d49690..914bf3601 100644 --- a/meta-oe/recipes-support/espeak/espeak-data_1.37.bb +++ b/meta-oe/recipes-support/espeak/espeak-data_1.37.bb | |||
@@ -9,18 +9,18 @@ PACKAGE_ARCH = "${MACHINE_ARCH}" | |||
9 | TARGET_ARCH = "${MACHINE_ARCH}" | 9 | TARGET_ARCH = "${MACHINE_ARCH}" |
10 | 10 | ||
11 | do_compile() { | 11 | do_compile() { |
12 | # Fixing byte order of phoneme data files | 12 | # Fixing byte order of phoneme data files |
13 | cd "${S}/platforms/big_endian" | 13 | cd "${S}/platforms/big_endian" |
14 | sed -i '/^ *CC *=/d' Makefile | 14 | sed -i '/^ *CC *=/d' Makefile |
15 | sed -i 's/\(.*BYTE_ORDER\)/#undef BYTE_ORDER\n#define BYTE_ORDER BIG_ENDIAN\n\1/' espeak-phoneme-data.c | 15 | sed -i 's/\(.*BYTE_ORDER\)/#undef BYTE_ORDER\n#define BYTE_ORDER BIG_ENDIAN\n\1/' espeak-phoneme-data.c |
16 | oe_runmake | 16 | oe_runmake |
17 | ./espeak-phoneme-data "${S}/espeak-data" | 17 | ./espeak-phoneme-data "${S}/espeak-data" |
18 | cp -f phondata phonindex phontab "${S}/espeak-data" | 18 | cp -f phondata phonindex phontab "${S}/espeak-data" |
19 | } | 19 | } |
20 | 20 | ||
21 | do_install() { | 21 | do_install() { |
22 | install -d ${D}${layout_datadir}/espeak-data | 22 | install -d ${D}${layout_datadir}/espeak-data |
23 | install -m 0644 ${S}/espeak-data/phon* ${D}${layout_datadir}/espeak-data | 23 | install -m 0644 ${S}/espeak-data/phon* ${D}${layout_datadir}/espeak-data |
24 | } | 24 | } |
25 | 25 | ||
26 | SRC_URI[md5sum] = "5c7b292d0537232868b4ac1317d76c02" | 26 | SRC_URI[md5sum] = "5c7b292d0537232868b4ac1317d76c02" |
diff --git a/meta-oe/recipes-support/espeak/espeak_1.37.bb b/meta-oe/recipes-support/espeak/espeak_1.37.bb index 6cc4cd410..c7f4b521c 100644 --- a/meta-oe/recipes-support/espeak/espeak_1.37.bb +++ b/meta-oe/recipes-support/espeak/espeak_1.37.bb | |||
@@ -13,30 +13,30 @@ TARGET_CC_ARCH += "${LDFLAGS}" | |||
13 | FILES_${PN} += "${datadir}/espeak-data" | 13 | FILES_${PN} += "${datadir}/espeak-data" |
14 | 14 | ||
15 | do_configure() { | 15 | do_configure() { |
16 | # "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19, use V19 | 16 | # "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19, use V19 |
17 | cp "${S}/src/portaudio19.h" "${S}/src/portaudio.h" | 17 | cp "${S}/src/portaudio19.h" "${S}/src/portaudio.h" |
18 | } | 18 | } |
19 | 19 | ||
20 | do_compile() { | 20 | do_compile() { |
21 | cd src | 21 | cd src |
22 | oe_runmake | 22 | oe_runmake |
23 | } | 23 | } |
24 | 24 | ||
25 | do_install() { | 25 | do_install() { |
26 | install -d ${D}${bindir} | 26 | install -d ${D}${bindir} |
27 | install -d ${D}${libdir} | 27 | install -d ${D}${libdir} |
28 | install -d ${D}${includedir} | 28 | install -d ${D}${includedir} |
29 | install -d ${D}${datadir}/espeak-data | 29 | install -d ${D}${datadir}/espeak-data |
30 | 30 | ||
31 | # we do not ship "speak" binary though. | 31 | # we do not ship "speak" binary though. |
32 | install -m 0755 ${S}/src/espeak ${D}${bindir} | 32 | install -m 0755 ${S}/src/espeak ${D}${bindir} |
33 | install -m 0644 ${S}/src/speak_lib.h ${D}${includedir} | 33 | install -m 0644 ${S}/src/speak_lib.h ${D}${includedir} |
34 | oe_libinstall -so -C src libespeak ${D}${libdir} | 34 | oe_libinstall -so -C src libespeak ${D}${libdir} |
35 | 35 | ||
36 | if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then | 36 | if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then |
37 | # the big-endian phon* files are provided by the package espeak-data | 37 | # the big-endian phon* files are provided by the package espeak-data |
38 | rm -f ${S}/espeak-data/phon* | 38 | rm -f ${S}/espeak-data/phon* |
39 | fi | 39 | fi |
40 | 40 | ||
41 | cp -prf ${S}/espeak-data/* ${D}${datadir}/espeak-data | 41 | cp -prf ${S}/espeak-data/* ${D}${datadir}/espeak-data |
42 | } | 42 | } |