summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/espeak/files/0001-Fix-build-of-shared-library-on-architectures-needing.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/espeak/files/0001-Fix-build-of-shared-library-on-architectures-needing.patch')
-rw-r--r--meta-oe/recipes-support/espeak/files/0001-Fix-build-of-shared-library-on-architectures-needing.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/espeak/files/0001-Fix-build-of-shared-library-on-architectures-needing.patch b/meta-oe/recipes-support/espeak/files/0001-Fix-build-of-shared-library-on-architectures-needing.patch
new file mode 100644
index 000000000..2590e1584
--- /dev/null
+++ b/meta-oe/recipes-support/espeak/files/0001-Fix-build-of-shared-library-on-architectures-needing.patch
@@ -0,0 +1,31 @@
1From 08a464e2b6bd31bb2bf4e258ebfa9b9d65805abf Mon Sep 17 00:00:00 2001
2From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
3Date: Fri, 27 Nov 2015 15:17:02 +0100
4Subject: [PATCH] Fix build of shared library on architectures needing -fPIC
5
6Certain architectures, like Sparc and Sparc64 require objects to be
7built with -fPIC (and not just -fpic) to be usable in shared
8libraries. On other architectures, -fPIC is the same as -fpic so this
9patch doesn't affect such architectures.
10
11Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
12---
13 src/Makefile | 2 +-
14 1 file changed, 1 insertion(+), 1 deletion(-)
15
16diff --git a/src/Makefile b/src/Makefile
17index 95fe549..c293611 100755
18--- a/src/Makefile
19+++ b/src/Makefile
20@@ -110,7 +110,7 @@ $(BIN2_NAME): $(OBJS3) $(LIB_NAME)
21
22
23 x_%.o: %.cpp
24- $(CXX) $(CXXFLAGS) $(USE_AUDIO) -D PATH_ESPEAK_DATA=\"$(DATADIR)\" -Wall -fpic -fvisibility=hidden -pedantic \
25+ $(CXX) $(CXXFLAGS) $(USE_AUDIO) -D PATH_ESPEAK_DATA=\"$(DATADIR)\" -Wall -fPIC -fvisibility=hidden -pedantic \
26 -I. -D LIBRARY -c -fno-exceptions $< -o x_$*.o
27
28 $(LIB_NAME): $(OBJS2)
29--
302.6.3
31