summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/espeak/espeak_1.37.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/espeak/espeak_1.37.bb')
-rw-r--r--meta-oe/recipes-support/espeak/espeak_1.37.bb40
1 files changed, 20 insertions, 20 deletions
diff --git a/meta-oe/recipes-support/espeak/espeak_1.37.bb b/meta-oe/recipes-support/espeak/espeak_1.37.bb
index 6cc4cd410..c7f4b521c 100644
--- a/meta-oe/recipes-support/espeak/espeak_1.37.bb
+++ b/meta-oe/recipes-support/espeak/espeak_1.37.bb
@@ -13,30 +13,30 @@ TARGET_CC_ARCH += "${LDFLAGS}"
13FILES_${PN} += "${datadir}/espeak-data" 13FILES_${PN} += "${datadir}/espeak-data"
14 14
15do_configure() { 15do_configure() {
16 # "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19, use V19 16 # "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19, use V19
17 cp "${S}/src/portaudio19.h" "${S}/src/portaudio.h" 17 cp "${S}/src/portaudio19.h" "${S}/src/portaudio.h"
18} 18}
19 19
20do_compile() { 20do_compile() {
21 cd src 21 cd src
22 oe_runmake 22 oe_runmake
23} 23}
24 24
25do_install() { 25do_install() {
26 install -d ${D}${bindir} 26 install -d ${D}${bindir}
27 install -d ${D}${libdir} 27 install -d ${D}${libdir}
28 install -d ${D}${includedir} 28 install -d ${D}${includedir}
29 install -d ${D}${datadir}/espeak-data 29 install -d ${D}${datadir}/espeak-data
30 30
31 # we do not ship "speak" binary though. 31 # we do not ship "speak" binary though.
32 install -m 0755 ${S}/src/espeak ${D}${bindir} 32 install -m 0755 ${S}/src/espeak ${D}${bindir}
33 install -m 0644 ${S}/src/speak_lib.h ${D}${includedir} 33 install -m 0644 ${S}/src/speak_lib.h ${D}${includedir}
34 oe_libinstall -so -C src libespeak ${D}${libdir} 34 oe_libinstall -so -C src libespeak ${D}${libdir}
35 35
36 if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then 36 if [ "${SITEINFO_ENDIANNESS}" = "be" ] ; then
37 # the big-endian phon* files are provided by the package espeak-data 37 # the big-endian phon* files are provided by the package espeak-data
38 rm -f ${S}/espeak-data/phon* 38 rm -f ${S}/espeak-data/phon*
39 fi 39 fi
40 40
41 cp -prf ${S}/espeak-data/* ${D}${datadir}/espeak-data 41 cp -prf ${S}/espeak-data/* ${D}${datadir}/espeak-data
42} 42}