diff options
Diffstat (limited to 'meta-oe/recipes-support/emacs/emacs-23.4/use-qemu.patch')
-rw-r--r-- | meta-oe/recipes-support/emacs/emacs-23.4/use-qemu.patch | 104 |
1 files changed, 0 insertions, 104 deletions
diff --git a/meta-oe/recipes-support/emacs/emacs-23.4/use-qemu.patch b/meta-oe/recipes-support/emacs/emacs-23.4/use-qemu.patch deleted file mode 100644 index c15207a43..000000000 --- a/meta-oe/recipes-support/emacs/emacs-23.4/use-qemu.patch +++ /dev/null | |||
@@ -1,104 +0,0 @@ | |||
1 | Upstream-Status: Inappropriate [embedded specific] | ||
2 | |||
3 | diff -uNr emacs-23.4/Makefile.in emacs-23.4.new/Makefile.in | ||
4 | --- emacs-23.4/Makefile.in 2012-01-11 13:35:01.000000000 +0100 | ||
5 | +++ emacs-23.4.new/Makefile.in 2012-07-31 00:54:07.223590866 +0200 | ||
6 | @@ -336,7 +336,7 @@ | ||
7 | # all preloaded elisp files, and only then dump the actual src/emacs, which | ||
8 | # is not wrong, but is overkill in 99.99% of the cases. | ||
9 | src: Makefile FRC | ||
10 | - boot=bootstrap-emacs$(EXEEXT); \ | ||
11 | + boot=${QEMU} bootstrap-emacs$(EXEEXT); \ | ||
12 | if [ ! -x "src/$$boot" ]; then \ | ||
13 | cd $@; $(MAKE) all $(MFLAGS) \ | ||
14 | CC='${CC}' CFLAGS='${CFLAGS}' CPPFLAGS='${CPPFLAGS}' \ | ||
15 | diff -uNr emacs-23.4/leim/Makefile.in emacs-23.4.new/leim/Makefile.in | ||
16 | --- emacs-23.4/leim/Makefile.in 2012-01-11 13:35:01.000000000 +0100 | ||
17 | +++ emacs-23.4.new/leim/Makefile.in 2012-07-31 00:54:07.179590866 +0200 | ||
18 | @@ -51,7 +51,7 @@ | ||
19 | |||
20 | # How to run Emacs. | ||
21 | RUN-EMACS = EMACSLOADPATH=$(buildlisppath) LC_ALL=C \ | ||
22 | - ${BUILT-EMACS} -batch --no-init-file --no-site-file --multibyte | ||
23 | + ${QEMU} ${BUILT-EMACS} -batch --no-init-file --no-site-file --multibyte | ||
24 | |||
25 | # Subdirectories to be made if ${srcdir} is different from the current | ||
26 | # directory. | ||
27 | diff -uNr emacs-23.4/lib-src/Makefile.in emacs-23.4.new/lib-src/Makefile.in | ||
28 | --- emacs-23.4/lib-src/Makefile.in 2012-01-11 13:35:01.000000000 +0100 | ||
29 | +++ emacs-23.4.new/lib-src/Makefile.in 2012-07-31 00:54:07.180590866 +0200 | ||
30 | @@ -23,7 +23,7 @@ | ||
31 | SHELL = /bin/sh | ||
32 | |||
33 | # Following ../lisp/Makefile.in. | ||
34 | -EMACS = ../src/emacs | ||
35 | +EMACS = ${QEMU} ../src/emacs | ||
36 | EMACSOPT = -batch --no-site-file --multibyte | ||
37 | |||
38 | # ==================== Things `configure' will edit ==================== | ||
39 | @@ -372,7 +372,7 @@ | ||
40 | clobbered too. */ | ||
41 | test-distrib${EXEEXT}: ${srcdir}/test-distrib.c | ||
42 | $(CC) ${ALL_CFLAGS} -o test-distrib ${srcdir}/test-distrib.c | ||
43 | - ./test-distrib ${srcdir}/testfile | ||
44 | + ${QEMU} ./test-distrib ${srcdir}/testfile | ||
45 | |||
46 | /* We need the following in order to create a <getopt.h> when the system | ||
47 | does not have one that works with the given compiler. */ | ||
48 | diff -uNr emacs-23.4/lisp/Makefile.in emacs-23.4.new/lisp/Makefile.in | ||
49 | --- emacs-23.4/lisp/Makefile.in 2012-01-11 13:35:01.000000000 +0100 | ||
50 | +++ emacs-23.4.new/lisp/Makefile.in 2012-07-31 00:54:07.195590866 +0200 | ||
51 | @@ -26,8 +26,7 @@ | ||
52 | # You can specify a different executable on the make command line, | ||
53 | # e.g. "make EMACS=../src/emacs ...". | ||
54 | |||
55 | -EMACS = ../src/emacs | ||
56 | - | ||
57 | +EMACS = "${QEMU} ../src/emacs" | ||
58 | # Command line flags for Emacs. This must include --multibyte, | ||
59 | # otherwise some files will not compile. | ||
60 | |||
61 | diff -uNr emacs-23.4/src/Makefile.in emacs-23.4.new/src/Makefile.in | ||
62 | --- emacs-23.4/src/Makefile.in 2012-01-12 11:27:54.000000000 +0100 | ||
63 | +++ emacs-23.4.new/src/Makefile.in 2012-07-31 00:55:30.344593847 +0200 | ||
64 | @@ -482,7 +482,7 @@ | ||
65 | this with the shell''s ``for'' construct. | ||
66 | Note that some people do not have '.' in their paths, so we must | ||
67 | use ./prefix-args. */ | ||
68 | -#define YMF_PASS_LDFLAGS(flags) `./prefix-args -Xlinker flags` | ||
69 | +#define YMF_PASS_LDFLAGS(flags) `${QEMU} ./prefix-args -Xlinker flags` | ||
70 | #else | ||
71 | #define YMF_PASS_LDFLAGS(flags) flags | ||
72 | #endif | ||
73 | @@ -919,9 +919,9 @@ | ||
74 | $(GNULIB_VAR) LIB_MATH LIB_STANDARD $(GNULIB_VAR) | ||
75 | |||
76 | #ifdef HAVE_SHM | ||
77 | -RUN_TEMACS = `/bin/pwd`/temacs -nl | ||
78 | +RUN_TEMACS = ${QEMU} temacs -nl | ||
79 | #else | ||
80 | -RUN_TEMACS = `/bin/pwd`/temacs | ||
81 | +RUN_TEMACS = ${QEMU} temacs | ||
82 | #endif | ||
83 | |||
84 | all: emacs${EXEEXT} $(OTHER_FILES) | ||
85 | @@ -936,7 +936,7 @@ | ||
86 | @: This new Emacs is as functional and more efficient then | ||
87 | @: bootstrap-emacs, so let us replace it. | ||
88 | -ln -f emacs${EXEEXT} bootstrap-emacs${EXEEXT} | ||
89 | - -./emacs -q -batch -f list-load-path-shadows | ||
90 | + -${QEMU} ./emacs -q -batch -f list-load-path-shadows | ||
91 | #endif /* ! defined (CANNOT_DUMP) */ | ||
92 | |||
93 | /* We run make-docfile twice because the command line may get too long | ||
94 | @@ -954,8 +954,8 @@ | ||
95 | only in order to reduce the command line length. --Stef */ | ||
96 | ${etc}DOC: ${libsrc}make-docfile${EXEEXT} ${obj} ${lisp} ${SOME_MACHINE_LISP} | ||
97 | -rm -f ${etc}DOC | ||
98 | - ${libsrc}make-docfile -d ${srcdir} ${SOME_MACHINE_OBJECTS} ${obj} > ${etc}DOC | ||
99 | - ${libsrc}make-docfile -a ${etc}DOC -d ${srcdir} ${SOME_MACHINE_LISP} ${shortlisp} | ||
100 | + ${QEMU}${libsrc}make-docfile -d ${srcdir} ${SOME_MACHINE_OBJECTS} ${obj} > ${etc}DOC | ||
101 | + ${QEMU} ${libsrc}make-docfile -a ${etc}DOC -d ${srcdir} ${SOME_MACHINE_LISP} ${shortlisp} | ||
102 | |||
103 | ${libsrc}make-docfile${EXEEXT}: | ||
104 | cd ${libsrc}; ${MAKE} ${MFLAGS} make-docfile${EXEEXT} | ||