summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb')
-rw-r--r--meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb b/meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb
new file mode 100644
index 000000000..2582820e6
--- /dev/null
+++ b/meta-oe/recipes-support/digitemp/digitemp_3.6.0.bb
@@ -0,0 +1,27 @@
1SUMMARY = "read temperature sensors in a 1-Wire net"
2SECTION = "util"
3DEPENDS = "libusb1"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://COPYING;md5=44fee82a1d2ed0676cf35478283e0aa0"
6
7PR = "r2"
8
9SRC_URI = "http://www.digitemp.com/software/linux/digitemp-${PV}.tar.gz \
10 file://makefile-fix.patch"
11SRC_URI[md5sum] = "9be2e48db37920f21925ae6e88f83b84"
12SRC_URI[sha256sum] = "14cfc584cd3714fe8c9a2cdc8388be49e08b5e395d95e6bcd11d4410e2505ca2"
13
14EXTRA_OEMAKE = "ds9097 ds9097u \
15 SYSTYPE='Linux' \
16"
17# Fix GNU_HASH QA errors
18TARGET_CC_ARCH += "${CFLAGS} ${LDFLAGS}"
19
20do_configure() {
21 rm -f digitemp_*
22}
23
24do_install() {
25 install -d ${D}${sbindir}
26 install digitemp_* ${D}${sbindir}
27}