summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/cpufrequtils/cpufrequtils/0001-dont-unset-cflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/cpufrequtils/cpufrequtils/0001-dont-unset-cflags.patch')
-rw-r--r--meta-oe/recipes-support/cpufrequtils/cpufrequtils/0001-dont-unset-cflags.patch30
1 files changed, 30 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/cpufrequtils/cpufrequtils/0001-dont-unset-cflags.patch b/meta-oe/recipes-support/cpufrequtils/cpufrequtils/0001-dont-unset-cflags.patch
new file mode 100644
index 000000000..fb2f07f07
--- /dev/null
+++ b/meta-oe/recipes-support/cpufrequtils/cpufrequtils/0001-dont-unset-cflags.patch
@@ -0,0 +1,30 @@
1--- git.old/Makefile 2012-04-17 13:29:46.280435340 +0200
2+++ git/Makefile 2012-04-17 13:31:13.664433470 +0200
3@@ -77,17 +77,7 @@ INSTALL_PROGRAM = ${INSTALL}
4 INSTALL_DATA = ${INSTALL} -m 644
5 INSTALL_SCRIPT = ${INSTALL_PROGRAM}
6
7-# If you are running a cross compiler, you may want to set this
8-# to something more interesting, like "arm-linux-". If you want
9-# to compile vs uClibc, that can be done here as well.
10-CROSS = #/usr/i386-linux-uclibc/usr/bin/i386-uclibc-
11-CC = $(CROSS)gcc
12-LD = $(CROSS)gcc
13-AR = $(CROSS)ar
14-STRIP = $(CROSS)strip
15-RANLIB = $(CROSS)ranlib
16-HOSTCC = gcc
17-
18+HOSTCC = $(BUILD_CC)
19
20 # Now we set up the build system
21 #
22@@ -95,7 +85,7 @@ HOSTCC = gcc
23 # set up PWD so that older versions of make will work with our build.
24 PWD = $(shell pwd)
25
26-export CROSS CC AR STRIP RANLIB CFLAGS LDFLAGS LIB_OBJS
27+export CFLAGS LDFLAGS LIB_OBJS
28
29 # check if compiler option is supported
30 cc-supports = ${shell if $(CC) ${1} -S -o /dev/null -xc /dev/null > /dev/null 2>&1; then echo "$(1)"; fi;}