summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-support/ckermit/ckermit_301.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-support/ckermit/ckermit_301.bb')
-rw-r--r--meta-oe/recipes-support/ckermit/ckermit_301.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/meta-oe/recipes-support/ckermit/ckermit_301.bb b/meta-oe/recipes-support/ckermit/ckermit_301.bb
new file mode 100644
index 000000000..c789ea5b1
--- /dev/null
+++ b/meta-oe/recipes-support/ckermit/ckermit_301.bb
@@ -0,0 +1,58 @@
1DESCRIPTION = "C-Kermit is a combined serial and network communication \
2software package offering a consistent, medium-independent, \
3cross-platform approach to connection establishment, terminal \
4sessions, file transfer, character-set translation, and automation \
5of communication tasks."
6HOMEPAGE = "http://www.columbia.edu/kermit/"
7SECTION = "console/network"
8LICENSE = "BSD-3-Clause"
9LIC_FILES_CHKSUM = "file://COPYING.TXT;md5=932ca542d6c6cb8a59a0bcd76ab67cc3"
10SRC_URI = "ftp://www.columbia.edu/kermit/archives/cku${PV}.tar.gz;subdir=${BPN}-${PV}"
11PR = "r0"
12
13export CC2 = "${CC}"
14export BINDIR = "${bindir}"
15export MANDIR = "${mandir}/man1"
16export INFODIR = "${infodir}"
17
18# Additional flags. For uclibc we add -DNOARROWKEYS which stops ckermit
19# trying to look inside the stdio headers.
20CKERMIT_ADDITIONAL = ""
21CKERMIT_ADDITIONAL_libc-uclibc = "-DNOARROWKEYS"
22
23TARGET_CC_ARCH += "${LDFLAGS}"
24
25do_compile () {
26 # The original makefile doesn't differentiate between CC and CC_FOR_BUILD,
27 # so we build wart manually. Note that you need a ckwart.o with the proper
28 # timestamp to make this hack work:
29 ${BUILD_CC} -c ckwart.c
30 ${BUILD_CC} -o wart ckwart.o
31 ./wart ckcpro.w ckcpro.c
32
33 # read ${S}/ckccfg.txt to understand this :-)
34 oe_runmake wermit CFLAGS="${CFLAGS} -DLINUX -DCK_POSIX_SIG \
35 -DNOTCPOPTS -DLINUXFSSTND -DNOCOTFMC -DPOSIX -DUSE_STRERROR \
36 -DNOSYSLOG -DHAVE_PTMX -DNO_DNS_SRV -DNOGFTIMER \
37 -DNOB_50 -DNOB_75 -DNOB_134 -DNOB_150 -DNOB_200 \
38 -DNOB_1800 -DNOB_3600 -DNOB_7200 -DNOB_76K -DNOB_230K \
39 -DNOB_460K -DNOB_921K \
40 -DNOCSETS -DNONET -DNOUNICODE -DNOHELP -DNODEBUG \
41 -DNOFRILLS -DNOFTP -DNODIAL -DNOPUSH -DNOIKSD -DNOHTTP -DNOFLOAT \
42 -DNOSERVER -DNOSEXP -DNORLOGIN -DNOOLDMODEMS -DNOSSH -DNOLISTEN \
43 -DNORESEND -DNOAUTODL -DNOSTREAMING -DNOHINTS -DNOCKXYZ -DNOLEARN \
44 -DNOMKDIR -DNOPERMS -DNOCKTIMERS -DNOCKREGEX -DNOREALPATH \
45 -DCK_SMALL -DNOLOGDIAL -DNORENAME -DNOWHATAMI \
46 ${CKERMIT_ADDITIONAL}"
47}
48
49do_install () {
50 install -d ${D}${BINDIR} ${D}${MANDIR} ${D}${INFODIR}
51 oe_runmake 'DESTDIR=${D}' install
52 # Fix up dangling symlink
53 rm ${D}${BINDIR}/kermit-sshsub
54 (cd ${D}${BINDIR} && ln -s ${BINDIR}/kermit kermit-sshusb)
55}
56
57SRC_URI[md5sum] = "59e80f909edf305933af8e0348dcc5d7"
58SRC_URI[sha256sum] = "9793eb125f8936b079c6d7e5c3d2ff885cfedc07f9d2dd1e7db928e3029a211a"