summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-shells/zsh/zsh_5.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-shells/zsh/zsh_5.9.bb')
-rw-r--r--meta-oe/recipes-shells/zsh/zsh_5.9.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta-oe/recipes-shells/zsh/zsh_5.9.bb b/meta-oe/recipes-shells/zsh/zsh_5.9.bb
new file mode 100644
index 000000000..7940970e4
--- /dev/null
+++ b/meta-oe/recipes-shells/zsh/zsh_5.9.bb
@@ -0,0 +1,62 @@
1SUMMARY = "UNIX Shell similar to the Korn shell"
2DESCRIPTION = "Zsh is a shell designed for interactive use, although it is also a \
3 powerful scripting language. Many of the useful features of bash, \
4 ksh, and tcsh were incorporated into zsh; many original features were added."
5HOMEPAGE = "http://www.zsh.org"
6SECTION = "base/shell"
7
8LICENSE = "zsh"
9LIC_FILES_CHKSUM = "file://LICENCE;md5=1a4c4cda3e8096d2fd483ff2f4514fec"
10
11DEPENDS = "ncurses bison-native libcap libpcre gdbm groff-native"
12
13SRC_URI = "${SOURCEFORGE_MIRROR}/project/${BPN}/${BPN}/${PV}/${BP}.tar.xz"
14SRC_URI[sha256sum] = "9b8d1ecedd5b5e81fbf1918e876752a7dd948e05c1a0dba10ab863842d45acd5"
15
16inherit autotools-brokensep gettext update-alternatives manpages
17
18EXTRA_OECONF = " \
19 --bindir=${base_bindir} \
20 --enable-etcdir=${sysconfdir} \
21 --enable-fndir=${datadir}/${BPN}/${PV}/functions \
22 --enable-site-fndir=${datadir}/${BPN}/site-functions \
23 --with-term-lib='ncursesw ncurses' \
24 --with-tcsetpgrp \
25 --enable-cap \
26 --enable-multibyte \
27 --disable-gdbm \
28 --disable-dynamic \
29 zsh_cv_shared_environ=yes \
30"
31
32# Configure respects --bindir from EXTRA_OECONF, but then Src/Makefile will read bindir from environment
33export bindir="${base_bindir}"
34
35EXTRA_OEMAKE = "-e MAKEFLAGS="
36
37ALTERNATIVE:${PN} = "sh"
38ALTERNATIVE_LINK_NAME[sh] = "${base_bindir}/sh"
39ALTERNATIVE_TARGET[sh] = "${base_bindir}/${BPN}"
40ALTERNATIVE_PRIORITY = "90"
41
42export AUTOHEADER = "true"
43
44do_configure () {
45 gnu-configize --force ${S}
46 oe_runconf
47}
48
49do_install:append() {
50 sed -i -e '1!b; s:^#!.*[ /]zsh:#!${bindir}/zsh:; s#/usr/local/bin#${bindir}#;' \
51 `find ${D}/usr/share/zsh/${PV}/functions -type f`
52}
53
54pkg_postinst:${PN} () {
55 touch $D${sysconfdir}/shells
56 for i in zsh sh
57 do
58 grep -q "bin/$i" $D${sysconfdir}/shells || \
59 printf >> $D${sysconfdir}/shells \
60 "${bindir}/$i\n${@bb.utils.contains('DISTRO_FEATURES', 'usrmerge', '/bin/$i\n', '', d)}"
61 done
62}