diff options
Diffstat (limited to 'meta-oe/recipes-security/passwdqc/passwdqc_1.3.1.bb')
-rw-r--r-- | meta-oe/recipes-security/passwdqc/passwdqc_1.3.1.bb | 63 |
1 files changed, 63 insertions, 0 deletions
diff --git a/meta-oe/recipes-security/passwdqc/passwdqc_1.3.1.bb b/meta-oe/recipes-security/passwdqc/passwdqc_1.3.1.bb new file mode 100644 index 000000000..198db3ce7 --- /dev/null +++ b/meta-oe/recipes-security/passwdqc/passwdqc_1.3.1.bb | |||
@@ -0,0 +1,63 @@ | |||
1 | SUMMARY = "A password/passphrase strength checking and enforcement toolset" | ||
2 | DESCRIPTION = "\ | ||
3 | passwdqc is a password/passphrase strength checking and policy enforcement \ | ||
4 | toolset, including an optional PAM module (pam_passwdqc), command-line \ | ||
5 | programs (pwqcheck and pwqgen), and a library (libpasswdqc). \ | ||
6 | pam_passwdqc is normally invoked on password changes by programs such as \ | ||
7 | passwd(1). It is capable of checking password or passphrase strength, \ | ||
8 | enforcing a policy, and offering randomly-generated passphrases, with \ | ||
9 | all of these features being optional and easily (re-)configurable. \ | ||
10 | \ | ||
11 | pwqcheck and pwqgen are standalone password/passphrase strength checking \ | ||
12 | and random passphrase generator programs, respectively, which are usable \ | ||
13 | from scripts. \ | ||
14 | \ | ||
15 | libpasswdqc is the underlying library, which may also be used from \ | ||
16 | third-party programs. \ | ||
17 | " | ||
18 | |||
19 | HOMEPAGE = "http://www.openwall.com/passwdqc" | ||
20 | SECTION = "System Environment/Base" | ||
21 | |||
22 | DEPENDS += "libpam" | ||
23 | |||
24 | LICENSE = "BSD" | ||
25 | LIC_FILES_CHKSUM = "file://LICENSE;md5=1b4af6f3d4ee079a38107366e93b334d" | ||
26 | |||
27 | SRC_URI = "http://www.openwall.com/${BPN}/${BP}.tar.gz \ | ||
28 | file://makefile-add-ldflags.patch \ | ||
29 | " | ||
30 | SRC_URI[md5sum] = "3878b57bcd3fdbcf3d4b362dbc6228b9" | ||
31 | SRC_URI[sha256sum] = "d1fedeaf759e8a0f32d28b5811ef11b5a5365154849190f4b7fab670a70ffb14" | ||
32 | |||
33 | # explicitly define LINUX_PAM in case DISTRO_FEATURES no pam | ||
34 | # this package's pam_passwdqc.so needs pam | ||
35 | CFLAGS_append += "-Wall -fPIC -DHAVE_SHADOW -DLINUX_PAM" | ||
36 | |||
37 | # -e is no longer default setting in bitbake.conf | ||
38 | EXTRA_OEMAKE = "-e" | ||
39 | |||
40 | do_compile() { | ||
41 | # make sure sub make use environment to override variables in Makefile | ||
42 | # Linux) $(MAKE), there is a tab between | ||
43 | sed -i -e 's/Linux) $(MAKE) CFLAGS_lib/Linux) $(MAKE) -e CFLAGS_lib/' ${S}/Makefile | ||
44 | |||
45 | # LD_lib and LD must be CC because of Makefile | ||
46 | oe_runmake LD="${CC}" | ||
47 | } | ||
48 | |||
49 | do_install() { | ||
50 | oe_runmake install DESTDIR=${D} SHARED_LIBDIR=${base_libdir} \ | ||
51 | DEVEL_LIBDIR=${libdir} SECUREDIR=${base_libdir}/security \ | ||
52 | INSTALL="install -p" | ||
53 | } | ||
54 | |||
55 | PROVIDES += "pam-${BPN}" | ||
56 | PACKAGES =+ "lib${BPN} pam-${BPN}" | ||
57 | |||
58 | FILES_lib${BPN} = "${base_libdir}/libpasswdqc.so.0" | ||
59 | FILES_pam-${BPN} = "${base_libdir}/security/pam_passwdqc.so" | ||
60 | FILES_${PN}-dbg += "${base_libdir}/security/.debug" | ||
61 | |||
62 | RDEPENDS_${PN} = "lib${BPN} pam-${BPN}" | ||
63 | RDEPENDS_pam-${BPN} = "lib${BPN}" | ||