summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-sato/claws-mail/claws-mail_3.6.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-sato/claws-mail/claws-mail_3.6.1.bb')
-rw-r--r--meta-oe/recipes-sato/claws-mail/claws-mail_3.6.1.bb62
1 files changed, 62 insertions, 0 deletions
diff --git a/meta-oe/recipes-sato/claws-mail/claws-mail_3.6.1.bb b/meta-oe/recipes-sato/claws-mail/claws-mail_3.6.1.bb
new file mode 100644
index 000000000..3c858d083
--- /dev/null
+++ b/meta-oe/recipes-sato/claws-mail/claws-mail_3.6.1.bb
@@ -0,0 +1,62 @@
1SECTION = "x11/network"
2DESCRIPTION = "Mail user agent"
3DEPENDS = "gtk+ libetpan openssl aspell"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=e059bde2972c1790af786f3e86bac22e"
6
7PR = "r1"
8
9inherit autotools pkgconfig gettext
10
11# translation patch: http://www.thewildbeast.co.uk/claws-mail/bugzilla/show_bug.cgi?id=1774
12SRC_URI = "\
13 ${SOURCEFORGE_MIRROR}/sylpheed-claws/claws-mail-${PV}.tar.bz2;name=archive \
14 http://www.penguin.cz/~utx/ftp/claws-mail/claws-mail-${PV}-po-update.patch;name=patch \
15 file://desktop.patch \
16 file://claws-mail-g_strcmp0.patch \
17 file://duplicate-header.patch \
18 file://glib-2.32.patch \
19 "
20SRC_URI[archive.md5sum] = "761b8ae2d574588460a0fb1ea4931ccb"
21SRC_URI[archive.sha256sum] = "67337a4a1a5a5ce09f2a38422b7a6fc481e4747f74d4ddedd130d4fb06fc3907"
22SRC_URI[patch.md5sum] = "e8ff3fabf1ed47f3b11a9cdc36b026bd"
23SRC_URI[patch.sha256sum] = "767258dd7c966e14ed519affe4c0da93e8fff66ee5fe9158413c8d163af72db8"
24
25do_configure_append() {
26 cd po ; for PO in *.po ; do MO=`echo $PO | sed s/\\.po//`.gmo ; if ! test -f $MO ; then msgfmt $PO -o $MO ; fi ; done
27}
28
29# FIXME: maemo builds may want --enable-maemo
30# FIXME: some platforms may want --enable-generic-umpc
31EXTRA_OECONF = " \
32 --disable-aspell-test \
33 --enable-aspell \
34 --disable-manual \
35 --disable-crash-dialog \
36 --disable-jpilot \
37 --disable-trayicon-plugin \
38 --disable-spamassassin-plugin \
39 --disable-bogofilter-plugin \
40 --disable-pgpcore-plugin \
41 --disable-pgpmime-plugin \
42 --disable-pgpinline-plugin \
43 --disable-dillo-viewer-plugin \
44 --disable-clamav-plugin \
45 --disable-gnomeprint \
46 --disable-valgrind \
47 "
48
49# Remove enchant references:
50do_install_prepend() {
51 sed -i -e 's:${STAGING_INCDIR}:${includedir}:g;s:${STAGING_LIBDIR}:${libdir}:g' claws-mail.pc
52}
53
54# Work-around broken GPE icon lookup:
55do_install_append() {
56 rm -r ${D}${datadir}/icons
57 install -d ${D}${datadir}/pixmaps
58 install -m 0644 claws-mail.png ${D}${datadir}/pixmaps/
59 sed -i 's/Icon=[^.]*$/&.png/' ${D}${datadir}/applications/claws-mail.desktop
60}
61
62RSUGGESTS_${PN} = "claws-plugin-gtkhtml2-viewer claws-plugin-mailmbox claws-plugin-rssyl"