diff options
Diffstat (limited to 'meta-oe/recipes-qt/qwt')
-rw-r--r-- | meta-oe/recipes-qt/qwt/qwt-e_5.2.1.bb | 8 | ||||
-rw-r--r-- | meta-oe/recipes-qt/qwt/qwt.inc | 33 | ||||
-rw-r--r-- | meta-oe/recipes-qt/qwt/qwt_5.2.1.bb | 8 |
3 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-qt/qwt/qwt-e_5.2.1.bb b/meta-oe/recipes-qt/qwt/qwt-e_5.2.1.bb new file mode 100644 index 000000000..2f5506106 --- /dev/null +++ b/meta-oe/recipes-qt/qwt/qwt-e_5.2.1.bb | |||
@@ -0,0 +1,8 @@ | |||
1 | inherit qt4e | ||
2 | |||
3 | require qwt.inc | ||
4 | |||
5 | SRC_URI[qwt.md5sum] = "4a595b8db0ec3856b117836c1d60cb27" | ||
6 | SRC_URI[qwt.sha256sum] = "e2b8bb755404cb3dc99e61f3e2d7262152193488f5fbe88524eb698e11ac569f" | ||
7 | |||
8 | RPROVIDES_${PN}-dev = "libqwt-dev" \ No newline at end of file | ||
diff --git a/meta-oe/recipes-qt/qwt/qwt.inc b/meta-oe/recipes-qt/qwt/qwt.inc new file mode 100644 index 000000000..da1ed11d1 --- /dev/null +++ b/meta-oe/recipes-qt/qwt/qwt.inc | |||
@@ -0,0 +1,33 @@ | |||
1 | DESCRIPTION = "Qt Widget Extension for Technical Applications" | ||
2 | SECTION = "libs" | ||
3 | PRIORITY = "optional" | ||
4 | |||
5 | # LGPLv2.1 + some exceptions | ||
6 | LICENSE = "QWTv1.0" | ||
7 | LIC_FILES_CHKSUM = "file://COPYING;md5=dac2743472b0462ff3cfb4af42051c88" | ||
8 | |||
9 | SRC_URI = "${SOURCEFORGE_MIRROR}/qwt/qwt-${PV}.tar.bz2;name=qwt" | ||
10 | |||
11 | S = "${WORKDIR}/qwt-${PV}" | ||
12 | |||
13 | do_configure_prepend() { | ||
14 | sed -i -e 's:RELEASE_SUFFIX = :RELEASE_SUFFIX = ${QT_LIBINFIX}:' *.pri | ||
15 | sed -i -e s:lqwt:lqwt${QT_LIBINFIX}:g -e s:/usr/local/qwt-$\${QwtVersion}:${prefix}:g *.prf | ||
16 | sed -e 's/#CONFIG += QwtExamples/CONFIG += QwtExamples/g' -i qwtconfig.pri | ||
17 | sed -i -e s:/usr/local/qwt-${PV}:${D}${prefix}:g ${S}/*.pri | ||
18 | } | ||
19 | |||
20 | do_install() { | ||
21 | oe_runmake -e install | ||
22 | install -d ${D}${datadir}/doc/${PN} | ||
23 | mv ${D}${prefix}/doc/* ${D}${datadir}/doc/${PN}/ | ||
24 | cd ${S}/examples | ||
25 | install -d ${D}/${bindir} | ||
26 | cd bin${QT_LIBINFIX}/ | ||
27 | for i in * ; do | ||
28 | cp -pPR ${i} ${D}/${bindir}/${i}${QT_LIBINFIX} | ||
29 | done | ||
30 | } | ||
31 | |||
32 | PACKAGES_prepend = "${PN}-examples " | ||
33 | FILES_${PN}-examples = "${bindir}/*" | ||
diff --git a/meta-oe/recipes-qt/qwt/qwt_5.2.1.bb b/meta-oe/recipes-qt/qwt/qwt_5.2.1.bb new file mode 100644 index 000000000..ea7b3d7d1 --- /dev/null +++ b/meta-oe/recipes-qt/qwt/qwt_5.2.1.bb | |||
@@ -0,0 +1,8 @@ | |||
1 | inherit qt4x11 | ||
2 | |||
3 | require qwt.inc | ||
4 | |||
5 | SRC_URI[qwt.md5sum] = "4a595b8db0ec3856b117836c1d60cb27" | ||
6 | SRC_URI[qwt.sha256sum] = "e2b8bb755404cb3dc99e61f3e2d7262152193488f5fbe88524eb698e11ac569f" | ||
7 | |||
8 | RPROVIDES_${PN}-dev = "libqwt-dev" | ||