diff options
Diffstat (limited to 'meta-oe/recipes-navigation/geos/files/fix-gcc6-isnan.patch')
-rw-r--r-- | meta-oe/recipes-navigation/geos/files/fix-gcc6-isnan.patch | 22 |
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-oe/recipes-navigation/geos/files/fix-gcc6-isnan.patch b/meta-oe/recipes-navigation/geos/files/fix-gcc6-isnan.patch new file mode 100644 index 000000000..5c5fbd1d9 --- /dev/null +++ b/meta-oe/recipes-navigation/geos/files/fix-gcc6-isnan.patch | |||
@@ -0,0 +1,22 @@ | |||
1 | --- geos-3.4.2/configure.in.orig 2016-06-08 17:46:43.002250304 +0000 | ||
2 | +++ geos-3.4.2/configure.in 2016-06-08 17:57:36.342241606 +0000 | ||
3 | @@ -197,7 +197,7 @@ | ||
4 | AC_LANG_PUSH([C++]) | ||
5 | AC_CACHE_CHECK([for isnan], ac_cv_isnan, | ||
6 | [AC_TRY_LINK([#include <cmath>], | ||
7 | - [double x; int y; y = isnan(x);], | ||
8 | + [double x; int y; y = std::isnan(x);], | ||
9 | ac_cv_isnan=yes, | ||
10 | ac_cv_isnan=no | ||
11 | )]) | ||
12 | --- geos-3.4.2/include/geos/platform.h.in.orig 2016-06-08 14:06:53.910234182 -0400 | ||
13 | +++ geos-3.4.2/include/geos/platform.h.in 2016-06-08 14:07:19.298233844 -0400 | ||
14 | @@ -84,7 +84,7 @@ | ||
15 | #endif | ||
16 | |||
17 | #if defined(HAVE_ISNAN) | ||
18 | -# define ISNAN(x) (isnan(x)) | ||
19 | +# define ISNAN(x) (std::isnan(x)) | ||
20 | #else | ||
21 | # if defined(_MSC_VER) | ||
22 | # define ISNAN(x) _isnan(x) | ||