diff options
Diffstat (limited to 'meta-oe/recipes-multimedia/alsa/alsa-oss-1.0.17/libio.patch')
-rw-r--r-- | meta-oe/recipes-multimedia/alsa/alsa-oss-1.0.17/libio.patch | 43 |
1 files changed, 43 insertions, 0 deletions
diff --git a/meta-oe/recipes-multimedia/alsa/alsa-oss-1.0.17/libio.patch b/meta-oe/recipes-multimedia/alsa/alsa-oss-1.0.17/libio.patch new file mode 100644 index 000000000..a053e4c60 --- /dev/null +++ b/meta-oe/recipes-multimedia/alsa/alsa-oss-1.0.17/libio.patch | |||
@@ -0,0 +1,43 @@ | |||
1 | Index: alsa-oss-1.0.15/alsa/stdioemu.c | ||
2 | =================================================================== | ||
3 | --- alsa-oss-1.0.15.orig/alsa/stdioemu.c 2007-10-15 10:50:40.000000000 +0200 | ||
4 | +++ alsa-oss-1.0.15/alsa/stdioemu.c 2008-07-21 22:17:06.303161438 +0200 | ||
5 | @@ -37,7 +37,9 @@ | ||
6 | #endif | ||
7 | |||
8 | #include <stdio.h> | ||
9 | +#ifdef HAVE_LIBIO_H | ||
10 | #include <libio.h> | ||
11 | +#endif | ||
12 | |||
13 | struct fd_cookie { | ||
14 | int fd; | ||
15 | @@ -99,7 +101,11 @@ | ||
16 | |||
17 | if (open_mode && fdc->fd > 0) { | ||
18 | result = fopencookie (fdc,"w", fns); | ||
19 | +#ifdef HAVE_FILENO | ||
20 | result->_fileno = fdc->fd; /* ugly patchy slimy kludgy hack */ | ||
21 | +#else | ||
22 | + result->__filedes = fdc->fd; | ||
23 | +#endif | ||
24 | } | ||
25 | return result; | ||
26 | } | ||
27 | Index: alsa-oss-1.0.15/configure.in | ||
28 | =================================================================== | ||
29 | --- alsa-oss-1.0.15.orig/configure.in 2007-10-15 10:50:40.000000000 +0200 | ||
30 | +++ alsa-oss-1.0.15/configure.in 2008-07-21 22:16:11.719837298 +0200 | ||
31 | @@ -33,6 +33,12 @@ | ||
32 | LIBS="$OLD_LIBS" | ||
33 | fi | ||
34 | |||
35 | +AC_CHECK_HEADERS_ONCE([libio.h]) | ||
36 | + | ||
37 | +AC_CHECK_MEMBER([struct _IO_FILE._fileno], | ||
38 | + [AC_DEFINE([HAVE_FILENO], [1],[Define if _fileno exists.])], | ||
39 | + [],[]) | ||
40 | + | ||
41 | AC_OUTPUT(Makefile alsa/Makefile alsa/aoss alsa/aoss.old \ | ||
42 | oss-redir/Makefile test/Makefile \ | ||
43 | alsa/testaoss test/testaoss) | ||