summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/ktap
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-kernel/ktap')
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap-module_0.3.bb19
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap.inc11
-rw-r--r--meta-oe/recipes-kernel/ktap/ktap_0.3.bb17
3 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/ktap/ktap-module_0.3.bb b/meta-oe/recipes-kernel/ktap/ktap-module_0.3.bb
new file mode 100644
index 000000000..12167ea16
--- /dev/null
+++ b/meta-oe/recipes-kernel/ktap/ktap-module_0.3.bb
@@ -0,0 +1,19 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2
3require ktap.inc
4
5DESCRIPTION = "KTAP is a scripting dynamic tracing tool for Linux"
6
7inherit module
8
9# Only build the module
10MAKE_TARGETS = "mod"
11
12# Kernel module packages MUST begin with 'kernel-module-', otherwise
13# multilib image generation can fail.
14#
15# The following line is only necessary if the recipe name does not begin
16# with kernel-module-.
17#
18PKG_${PN} = "kernel-module-${PN}"
19
diff --git a/meta-oe/recipes-kernel/ktap/ktap.inc b/meta-oe/recipes-kernel/ktap/ktap.inc
new file mode 100644
index 000000000..7fde165ad
--- /dev/null
+++ b/meta-oe/recipes-kernel/ktap/ktap.inc
@@ -0,0 +1,11 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2
3HOMEPAGE = "http://www.ktap.org"
4LICENSE = "GPLv2"
5LIC_FILES_CHKSUM = "file://LICENSE-GPL;md5=eb723b61539feef013de476e68b5c50a"
6
7SRCREV = "6a5100b77321ce5792dfea34fa500ea537b1858c"
8SRC_URI = "git://github.com/ktap/ktap.git"
9
10S = "${WORKDIR}/git"
11
diff --git a/meta-oe/recipes-kernel/ktap/ktap_0.3.bb b/meta-oe/recipes-kernel/ktap/ktap_0.3.bb
new file mode 100644
index 000000000..f5dd62f84
--- /dev/null
+++ b/meta-oe/recipes-kernel/ktap/ktap_0.3.bb
@@ -0,0 +1,17 @@
1# Released under the MIT license (see COPYING.MIT for the terms)
2
3require ktap.inc
4
5SUMMARY = "KTAP is a scripting dynamic tracing tool for Linux"
6DEPENDS = "ktap-module"
7
8# Only build the userspace app
9EXTRA_OEMAKE = "ktap"
10
11do_install() {
12 install -d ${D}${bindir}
13 install -m 0755 ${S}/ktap ${D}${bindir}/
14}
15
16RDEPENDS_${PN} = "kernel-module-ktapvm"
17