summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/other.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/other.patch')
-rw-r--r--meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/other.patch97
1 files changed, 97 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/other.patch b/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/other.patch
new file mode 100644
index 000000000..f6efaebc4
--- /dev/null
+++ b/meta-oe/recipes-kernel/kexec/kexec-tools-klibc-2.0.2/other.patch
@@ -0,0 +1,97 @@
1Index: kexec-tools-2.0.2/kexec/crashdump-elf.c
2===================================================================
3--- kexec-tools-2.0.2.orig/kexec/crashdump-elf.c 2008-10-31 03:00:38.000000000 +0100
4+++ kexec-tools-2.0.2/kexec/crashdump-elf.c 2009-09-26 11:17:57.000000000 +0200
5@@ -47,7 +47,8 @@
6 if (xen_present())
7 nr_cpus = xen_get_nr_phys_cpus();
8 else
9- nr_cpus = sysconf(_SC_NPROCESSORS_CONF);
10+ /*nr_cpus = sysconf(_SC_NPROCESSORS_CONF);*/
11+ nr_cpus = 1;
12
13 if (nr_cpus < 0) {
14 return -1;
15
16Index: kexec-tools-2.0.2/kexec/arch/arm/kexec-zImage-arm.c
17===================================================================
18--- kexec-tools-2.0.2.orig/kexec/arch/arm/kexec-zImage-arm.c 2009-04-24 14:15:46.982825391 +0100
19+++ kexec-tools-2.0.2/kexec/arch/arm/kexec-zImage-arm.c 2009-09-26 01:58:20.838624318 +0200
20@@ -2,6 +2,10 @@
21 * - 08/21/2007 ATAG support added by Uli Luckas <u.luckas@road.de>
22 *
23 */
24+
25+/* work around for linux header files */
26+#define __deprecated
27+
28 #define _GNU_SOURCE
29 #define _XOPEN_SOURCE
30 #include <stdio.h>
31
32Index: kexec-tools-2.0.2/kexec/kexec.h
33===================================================================
34--- kexec-tools-2.0.2.orig/kexec/kexec.h 2008-05-16 13:28:19.000000000 +0200
35+++ kexec-tools-2.0.2/kexec/kexec.h 2009-09-16 17:32:15.000000000 +0200
36@@ -204,7 +204,7 @@
37 extern char *slurp_file(const char *filename, off_t *r_size);
38 extern char *slurp_file_len(const char *filename, off_t size);
39 extern char *slurp_decompress_file(const char *filename, off_t *r_size);
40-extern unsigned long virt_to_phys(unsigned long addr);
41+/* extern unsigned long virt_to_phys(unsigned long addr); */
42 extern void add_segment(struct kexec_info *info,
43 const void *buf, size_t bufsz, unsigned long base, size_t memsz);
44 extern void add_segment_phys_virt(struct kexec_info *info,
45
46Index: kexec-tools-2.0.2/Makefile.in
47===================================================================
48--- kexec-tools-2.0.2.orig/Makefile.in 2009-09-29 23:49:47.000000000 +0200
49+++ kexec-tools-2.0.2/Makefile.in 2009-09-29 23:49:09.000000000 +0200
50@@ -46,7 +46,7 @@
51 # where necessary.
52 CPPFLAGS = @CPPFLAGS@ -I$(srcdir)/include -I$(srcdir)/util_lib/include \
53 -Iinclude/
54-CFLAGS = @CFLAGS@ -fno-strict-aliasing -Wall -Wstrict-prototypes
55+CFLAGS = @CFLAGS@ -static -fno-strict-aliasing -Wall -Wstrict-prototypes
56 PURGATORY_EXTRA_CFLAGS = @PURGATORY_EXTRA_CFLAGS@
57 ASFLAGS = @ASFLAGS@
58 LDFLAGS = @LDFLAGS@
59
60Index: kexec-tools-2.0.2/util_lib/include/sha256.h
61===================================================================
62--- kexec-tools-2.0.2.orig/util_lib/include/sha256.h 2008-07-15 02:46:43.000000000 +0200
63+++ kexec-tools-2.0.2/util_lib/include/sha256.h 2009-10-02 18:28:45.000000000 +0200
64@@ -1,7 +1,8 @@
65 #ifndef SHA256_H
66 #define SHA256_H
67
68-#include <sys/types.h>
69+//#include <sys/types.h>
70+#include <stddef.h>
71 #include <stdint.h>
72
73 typedef struct
74
75Index: kexec-tools-2.0.2/purgatory/Makefile
76===================================================================
77--- kexec-tools-2.0.2.orig/purgatory/Makefile 2008-10-09 00:32:14.000000000 +0200
78+++ kexec-tools-2.0.2.orig/purgatory/Makefile 2009-10-03 00:28:45.000000000 +0200
79@@ -47,7 +47,7 @@
80 $(PURGATORY): CC=$(TARGET_CC)
81 $(PURGATORY): CFLAGS+=$(PURGATORY_EXTRA_CFLAGS) \
82 $($(ARCH)_PURGATORY_EXTRA_CFLAGS) \
83- -Os -fno-builtin -ffreestanding
84+ -Os -fno-builtin -ffreestanding -nostdinc
85
86 $(PURGATORY): CPPFLAGS=$($(ARCH)_PURGATORY_EXTRA_CFLAGS) \
87 -I$(srcdir)/purgatory/include \
88@@ -61,7 +61,8 @@
89
90 $(PURGATORY): $(PURGATORY_OBJS)
91 $(MKDIR) -p $(@D)
92- $(CC) $(LDFLAGS) -o $@ $^
93+# $(CC) $(LDFLAGS) -o $@ $^
94+ $(LD) $(LDFLAGS) -o $@ $^
95
96 # $(LD) $(LDFLAGS) $(EXTRA_LDFLAGS) --no-undefined -e purgatory_start -r -o $@ $(PURGATORY_OBJS) $(UTIL_LIB)
97