summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/crash/crash_7.2.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-kernel/crash/crash_7.2.9.bb')
-rw-r--r--meta-oe/recipes-kernel/crash/crash_7.2.9.bb34
1 files changed, 17 insertions, 17 deletions
diff --git a/meta-oe/recipes-kernel/crash/crash_7.2.9.bb b/meta-oe/recipes-kernel/crash/crash_7.2.9.bb
index 0b6883a49..c2d83cb4f 100644
--- a/meta-oe/recipes-kernel/crash/crash_7.2.9.bb
+++ b/meta-oe/recipes-kernel/crash/crash_7.2.9.bb
@@ -38,13 +38,13 @@ UPSTREAM_CHECK_URI = "https://github.com/crash-utility/crash/releases"
38inherit gettext 38inherit gettext
39 39
40BBCLASSEXTEND = "native cross" 40BBCLASSEXTEND = "native cross"
41TARGET_CC_ARCH_append = " ${SELECTED_OPTIMIZATION}" 41TARGET_CC_ARCH:append = " ${SELECTED_OPTIMIZATION}"
42 42
43# crash 7.1.3 and before don't support mips64/riscv64 43# crash 7.1.3 and before don't support mips64/riscv64
44COMPATIBLE_HOST_riscv64 = "null" 44COMPATIBLE_HOST:riscv64 = "null"
45COMPATIBLE_HOST_riscv32 = "null" 45COMPATIBLE_HOST:riscv32 = "null"
46COMPATIBLE_HOST_mipsarchn64 = "null" 46COMPATIBLE_HOST:mipsarchn64 = "null"
47COMPATIBLE_HOST_mipsarchn32 = "null" 47COMPATIBLE_HOST:mipsarchn32 = "null"
48 48
49 49
50EXTRA_OEMAKE = 'RPMPKG="${PV}" \ 50EXTRA_OEMAKE = 'RPMPKG="${PV}" \
@@ -54,20 +54,20 @@ EXTRA_OEMAKE = 'RPMPKG="${PV}" \
54 LDFLAGS="${LDFLAGS}" \ 54 LDFLAGS="${LDFLAGS}" \
55 ' 55 '
56 56
57EXTRA_OEMAKE_class-cross = 'RPMPKG="${PV}" \ 57EXTRA_OEMAKE:class-cross = 'RPMPKG="${PV}" \
58 GDB_TARGET="${BUILD_SYS} --target=${TARGET_SYS}" \ 58 GDB_TARGET="${BUILD_SYS} --target=${TARGET_SYS}" \
59 GDB_HOST="${BUILD_SYS}" \ 59 GDB_HOST="${BUILD_SYS}" \
60 GDB_MAKE_JOBS="${PARALLEL_MAKE}" \ 60 GDB_MAKE_JOBS="${PARALLEL_MAKE}" \
61 ' 61 '
62 62
63EXTRA_OEMAKE_append_class-native = " LDFLAGS='${BUILD_LDFLAGS}'" 63EXTRA_OEMAKE:append:class-native = " LDFLAGS='${BUILD_LDFLAGS}'"
64EXTRA_OEMAKE_append_class-cross = " LDFLAGS='${BUILD_LDFLAGS}'" 64EXTRA_OEMAKE:append:class-cross = " LDFLAGS='${BUILD_LDFLAGS}'"
65 65
66do_configure() { 66do_configure() {
67 : 67 :
68} 68}
69 69
70do_compile_prepend() { 70do_compile:prepend() {
71 case ${TARGET_ARCH} in 71 case ${TARGET_ARCH} in
72 aarch64*) ARCH=ARM64 ;; 72 aarch64*) ARCH=ARM64 ;;
73 arm*) ARCH=ARM ;; 73 arm*) ARCH=ARM ;;
@@ -87,7 +87,7 @@ do_compile() {
87 oe_runmake ${EXTRA_OEMAKE} RECIPE_SYSROOT=${RECIPE_SYSROOT} 87 oe_runmake ${EXTRA_OEMAKE} RECIPE_SYSROOT=${RECIPE_SYSROOT}
88} 88}
89 89
90do_install_prepend () { 90do_install:prepend () {
91 install -d ${D}${bindir} 91 install -d ${D}${bindir}
92 install -d ${D}/${mandir}/man8 92 install -d ${D}/${mandir}/man8
93 install -d ${D}${includedir}/crash 93 install -d ${D}${includedir}/crash
@@ -96,25 +96,25 @@ do_install_prepend () {
96 install -m 0644 ${S}/defs.h ${D}${includedir}/crash 96 install -m 0644 ${S}/defs.h ${D}${includedir}/crash
97} 97}
98 98
99do_install_class-target () { 99do_install:class-target () {
100 oe_runmake DESTDIR=${D} install 100 oe_runmake DESTDIR=${D} install
101} 101}
102 102
103do_install_class-native () { 103do_install:class-native () {
104 oe_runmake DESTDIR=${D}${STAGING_DIR_NATIVE} install 104 oe_runmake DESTDIR=${D}${STAGING_DIR_NATIVE} install
105} 105}
106 106
107do_install_class-cross () { 107do_install:class-cross () {
108 install -m 0755 ${S}/crash ${D}/${bindir} 108 install -m 0755 ${S}/crash ${D}/${bindir}
109} 109}
110 110
111RDEPENDS_${PN} += "liblzma" 111RDEPENDS:${PN} += "liblzma"
112RDEPENDS_${PN}_class-native = "" 112RDEPENDS:${PN}:class-native = ""
113RDEPENDS_${PN}_class-cross = "" 113RDEPENDS:${PN}:class-cross = ""
114 114
115# Causes gcc to get stuck and eat all available memory in qemuarm builds 115# Causes gcc to get stuck and eat all available memory in qemuarm builds
116# jenkins 15161 100 12.5 10389596 10321284 ? R 11:40 28:17 /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.2/cc1 -quiet -I . -I . -I ./common -I ./config -I ./../include/opcode -I ./../opcodes/.. -I ./../readline/.. -I ../bfd -I ./../bfd -I ./../include -I ../libdecnumber -I ./../libdecnumber -I ./gnulib/import -I build-gnulib/import -isysroot /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm -MMD eval.d -MF .deps/eval.Tpo -MP -MT eval.o -D LOCALEDIR="/usr/local/share/locale" -D CRASH_MERGE -D HAVE_CONFIG_H -D TUI=1 eval.c -quiet -dumpbase eval.c -march=armv5te -mthumb -mthumb-interwork -mtls-dialect=gnu -auxbase-strip eval.o -g -O2 -Wall -Wpointer-arith -Wformat-nonliteral -Wno-pointer-sign -Wno-unused -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-prototypes -Wdeclaration-after-statement -Wempty-body -feliminate-unused-debug-types -o - 116# jenkins 15161 100 12.5 10389596 10321284 ? R 11:40 28:17 /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/x86_64-linux/usr/libexec/arm-oe-linux-gnueabi/gcc/arm-oe-linux-gnueabi/4.9.2/cc1 -quiet -I . -I . -I ./common -I ./config -I ./../include/opcode -I ./../opcodes/.. -I ./../readline/.. -I ../bfd -I ./../bfd -I ./../include -I ../libdecnumber -I ./../libdecnumber -I ./gnulib/import -I build-gnulib/import -isysroot /home/jenkins/oe/world/shr-core/tmp-glibc/sysroots/qemuarm -MMD eval.d -MF .deps/eval.Tpo -MP -MT eval.o -D LOCALEDIR="/usr/local/share/locale" -D CRASH_MERGE -D HAVE_CONFIG_H -D TUI=1 eval.c -quiet -dumpbase eval.c -march=armv5te -mthumb -mthumb-interwork -mtls-dialect=gnu -auxbase-strip eval.o -g -O2 -Wall -Wpointer-arith -Wformat-nonliteral -Wno-pointer-sign -Wno-unused -Wunused-value -Wunused-function -Wno-switch -Wno-char-subscripts -Wmissing-prototypes -Wdeclaration-after-statement -Wempty-body -feliminate-unused-debug-types -o -
117ARM_INSTRUCTION_SET = "arm" 117ARM_INSTRUCTION_SET = "arm"
118 118
119# http://errors.yoctoproject.org/Errors/Details/186964/ 119# http://errors.yoctoproject.org/Errors/Details/186964/
120COMPATIBLE_HOST_libc-musl = 'null' 120COMPATIBLE_HOST:libc-musl = 'null'