summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-kernel/crash/crash_7.0.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-kernel/crash/crash_7.0.9.bb')
-rw-r--r--meta-oe/recipes-kernel/crash/crash_7.0.9.bb59
1 files changed, 59 insertions, 0 deletions
diff --git a/meta-oe/recipes-kernel/crash/crash_7.0.9.bb b/meta-oe/recipes-kernel/crash/crash_7.0.9.bb
new file mode 100644
index 000000000..8d6248109
--- /dev/null
+++ b/meta-oe/recipes-kernel/crash/crash_7.0.9.bb
@@ -0,0 +1,59 @@
1SUMMARY = "Kernel analysis utility for live systems, netdump, diskdump, kdump, LKCD or mcore dumpfiles"
2DESCRIPTION = "The core analysis suite is a self-contained tool that can be used to\
3investigate either live systems, kernel core dumps created from the\
4netdump, diskdump and kdump packages from Red Hat Linux, the mcore kernel patch\
5offered by Mission Critical Linux, or the LKCD kernel patch."
6
7HOMEPAGE = "http://people.redhat.com/anderson"
8SECTION = "devel"
9
10inherit gettext
11
12DEPENDS = "zlib readline"
13
14SRC_URI = "https://github.com/crash-utility/${BPN}/archive/${PV}.tar.gz \
15 file://7001force_define_architecture.patch \
16 file://7003cross_ranlib.patch \
17 file://0001-cross_add_configure_option.patch \
18 "
19
20SRC_URI[md5sum] = "d70ad2ed0f6d210ed11e88b8e977f5fd"
21SRC_URI[sha256sum] = "c6034c6eb6b52691c60d0b72dbdec58fac4c1b3ed1cd0697c209dc48d13a577e"
22
23LICENSE = "GPLv3"
24LIC_FILES_CHKSUM = "file://COPYING3;md5=d32239bcb673463ab874e80d47fae504"
25
26EXTRA_OEMAKE = 'RPMPKG="${PV}" \
27 GDB_TARGET="${TARGET_SYS}" \
28 GDB_HOST="${BUILD_SYS}" \
29 '
30do_configure() {
31 :
32}
33
34do_compile_prepend() {
35 case ${TARGET_ARCH} in
36 arm*) ARCH=ARM ;;
37 i*86*) ARCH=X86 ;;
38 powerpc*) ARCH=PPC ;;
39 x86_64*) ARCH=X86_64 ;;
40 esac
41
42 sed -i s/FORCE_DEFINE_ARCH/"${ARCH}"/g ${S}/configure.c
43 sed -i -e 's/#define TARGET_CFLAGS_ARM_ON_X86_64.*/#define TARGET_CFLAGS_ARM_ON_X86_64\t\"TARGET_CFLAGS=-D_FILE_OFFSET_BITS=64\"/g' ${S}/configure.c
44 sed -i 's/>/>/g' ${S}/Makefile
45}
46do_compile() {
47 oe_runmake ${EXTRA_OEMAKE}
48}
49
50do_install () {
51 install -d ${D}${bindir}
52 install -d ${D}/${mandir}/man8
53 install -d ${D}${includedir}/crash
54
55 oe_runmake DESTDIR=${D} install
56 install -m 0644 ${S}/crash.8 ${D}/${mandir}/man8/
57 install -m 0644 ${S}/defs.h ${D}${includedir}/crash
58}
59RDEPENDS_${PN} += "liblzma"