diff options
Diffstat (limited to 'meta-oe/recipes-graphics')
-rw-r--r-- | meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/0001-xinput_calibrator_pointercal.sh-specify-output-type-.patch | 56 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator-autostart.desktop | 8 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb (renamed from meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bb) | 17 |
3 files changed, 7 insertions, 74 deletions
diff --git a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/0001-xinput_calibrator_pointercal.sh-specify-output-type-.patch b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/0001-xinput_calibrator_pointercal.sh-specify-output-type-.patch deleted file mode 100644 index 8e6d9498e..000000000 --- a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/0001-xinput_calibrator_pointercal.sh-specify-output-type-.patch +++ /dev/null | |||
@@ -1,56 +0,0 @@ | |||
1 | From e73eb2c343006865ff3faf7777ab93ccfd1762d6 Mon Sep 17 00:00:00 2001 | ||
2 | From: Koen Kooi <koen@dominion.thruhere.net> | ||
3 | Date: Tue, 28 Feb 2012 14:09:08 +0100 | ||
4 | Subject: [PATCH] xinput_calibrator_pointercal.sh: specify output type since 'auto' doesn't always pick 'xinput' | ||
5 | |||
6 | Also deal with pointercal files that contain '# replace with valid machine specific pointercal.xinput' | ||
7 | |||
8 | Signed-off-by: Koen Kooi <koen@dominion.thruhere.net> | ||
9 | --- | ||
10 | |||
11 | Upstream-status: Submitted | ||
12 | |||
13 | scripts/xinput_calibrator_pointercal.sh | 22 +++++++++++++++------- | ||
14 | 1 files changed, 15 insertions(+), 7 deletions(-) | ||
15 | |||
16 | diff --git a/scripts/xinput_calibrator_pointercal.sh b/scripts/xinput_calibrator_pointercal.sh | ||
17 | index 579509c..fccb197 100755 | ||
18 | --- a/scripts/xinput_calibrator_pointercal.sh | ||
19 | +++ b/scripts/xinput_calibrator_pointercal.sh | ||
20 | @@ -6,18 +6,26 @@ | ||
21 | # | ||
22 | # original script: Martin Jansa <Martin.Jansa@gmail.com>, 2010-01-31 | ||
23 | # updated by Tias Guns <tias@ulyssis.org>, 2010-02-15 | ||
24 | +# updated by Koen Kooi <koen@dominion.thruhere.net>, 2012-02-28 | ||
25 | + | ||
26 | +PATH="/usr/bin:$PATH" | ||
27 | |||
28 | BINARY="xinput_calibrator" | ||
29 | CALFILE="/etc/pointercal.xinput" | ||
30 | LOGFILE="/var/log/xinput_calibrator.pointercal.log" | ||
31 | |||
32 | if [ -e $CALFILE ] ; then | ||
33 | - echo "Using calibration data stored in $CALFILE" | ||
34 | - . $CALFILE | ||
35 | -else | ||
36 | - CALDATA=`$BINARY -v | tee $LOGFILE | grep ' xinput set' | sed 's/^ //g; s/$/;/g'` | ||
37 | - if [ ! -z "$CALDATA" ] ; then | ||
38 | - echo $CALDATA > $CALFILE | ||
39 | - echo "Calibration data stored in $CALFILE (log in $LOGFILE)" | ||
40 | + if grep replace $CALFILE ; then | ||
41 | + echo "Empty calibration file found, removing it" | ||
42 | + rm $CALFILE | ||
43 | + else | ||
44 | + echo "Using calibration data stored in $CALFILE" | ||
45 | + . $CALFILE && exit 0 | ||
46 | fi | ||
47 | fi | ||
48 | + | ||
49 | +CALDATA=`$BINARY --output-type xinput -v | tee $LOGFILE | grep ' xinput set' | sed 's/^ //g; s/$/;/g'` | ||
50 | +if [ ! -z "$CALDATA" ] ; then | ||
51 | + echo $CALDATA > $CALFILE | ||
52 | + echo "Calibration data stored in $CALFILE (log in $LOGFILE)" | ||
53 | +fi | ||
54 | -- | ||
55 | 1.7.2.5 | ||
56 | |||
diff --git a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator-autostart.desktop b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator-autostart.desktop deleted file mode 100644 index 3f3d61327..000000000 --- a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator/xinput-calibrator-autostart.desktop +++ /dev/null | |||
@@ -1,8 +0,0 @@ | |||
1 | [Desktop Entry] | ||
2 | Name=Calibrate Touchscreen | ||
3 | Exec=xinput_calibrator_once.sh | ||
4 | Terminal=false | ||
5 | Type=Application | ||
6 | Icon=xinput_calibrator | ||
7 | StartupNotify=true | ||
8 | Categories=System;Settings; | ||
diff --git a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bb b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb index edc10bda4..c16a41247 100644 --- a/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_0.7.5.bb +++ b/meta-oe/recipes-graphics/xinput-calibrator/xinput-calibrator_git.bb | |||
@@ -1,21 +1,17 @@ | |||
1 | DESCRIPTION = "A generic touchscreen calibration program for X.Org" | 1 | DESCRIPTION = "A generic touchscreen calibration program for X.Org" |
2 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/xinput_calibrator" | 2 | HOMEPAGE = "http://www.freedesktop.org/wiki/Software/xinput_calibrator" |
3 | LICENSE = "MIT-X" | 3 | LICENSE = "MIT-X" |
4 | LIC_FILES_CHKSUM = "file://src/calibrator.cpp;endline=22;md5=998e238a7638a7446eaeb02398f691fc" | 4 | LIC_FILES_CHKSUM = "file://src/calibrator.cpp;endline=22;md5=1bcba08f67cdb56f34021557898e4b5a" |
5 | DEPENDS = "virtual/libx11 libxi" | 5 | DEPENDS = "virtual/libx11 libxi" |
6 | 6 | ||
7 | PR = "r8" | 7 | PV = "0.7.5+git${SRCPV}" |
8 | 8 | ||
9 | inherit autotools | 9 | inherit autotools |
10 | 10 | ||
11 | SRC_URI = "http://github.com/downloads/tias/xinput_calibrator/xinput_calibrator-${PV}.tar.gz \ | 11 | SRCREV = "c01c5af807cb4b0157b882ab07a893df9a810111" |
12 | file://0001-xinput_calibrator_pointercal.sh-specify-output-type-.patch \ | 12 | SRC_URI = "git://github.com/tias/xinput_calibrator.git;protocol=git" |
13 | file://xinput-calibrator-autostart.desktop \ | ||
14 | " | ||
15 | SRC_URI[md5sum] = "20da0a2055a5a75962add8c6b44f60fa" | ||
16 | SRC_URI[sha256sum] = "baa4ddca49ec94c27ba4c715bfa26692fec1132103e927213c3169e475d3d971" | ||
17 | 13 | ||
18 | S = "${WORKDIR}/xinput_calibrator-${PV}" | 14 | S = "${WORKDIR}/git" |
19 | 15 | ||
20 | # force native X11 ui as we don't have gtk+ in DEPENDS | 16 | # force native X11 ui as we don't have gtk+ in DEPENDS |
21 | EXTRA_OECONF += "--with-gui=x11" | 17 | EXTRA_OECONF += "--with-gui=x11" |
@@ -25,7 +21,8 @@ do_install_append() { | |||
25 | install -m 0755 scripts/xinput_calibrator_pointercal.sh ${D}${bindir}/xinput_calibrator_once.sh | 21 | install -m 0755 scripts/xinput_calibrator_pointercal.sh ${D}${bindir}/xinput_calibrator_once.sh |
26 | 22 | ||
27 | install -d ${D}${sysconfdir}/xdg/autostart | 23 | install -d ${D}${sysconfdir}/xdg/autostart |
28 | install -m 0644 ${WORKDIR}/xinput-calibrator-autostart.desktop ${D}${sysconfdir}/xdg/autostart | 24 | sed -i -e 's,^Exec=.*,Exec=/usr/bin/xinput_calibrator_once.sh,' scripts/xinput_calibrator.desktop |
25 | install -m 0644 scripts/xinput_calibrator.desktop ${D}${sysconfdir}/xdg/autostart | ||
29 | } | 26 | } |
30 | 27 | ||
31 | FILES_${PN} += "${sysconfdir}/xdg/autostart" | 28 | FILES_${PN} += "${sysconfdir}/xdg/autostart" |