summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/waffle/waffle_1.2.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/waffle/waffle_1.2.2.bb')
-rw-r--r--meta-oe/recipes-graphics/waffle/waffle_1.2.2.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/waffle/waffle_1.2.2.bb b/meta-oe/recipes-graphics/waffle/waffle_1.2.2.bb
new file mode 100644
index 000000000..4f80191fd
--- /dev/null
+++ b/meta-oe/recipes-graphics/waffle/waffle_1.2.2.bb
@@ -0,0 +1,34 @@
1SUMMARY = "cross-platform C library to defer selection of GL API and of window system"
2LICENSE = "BSD-2-Clause"
3LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=4c5154407c2490750dd461c50ad94797 \
4 file://include/waffle/waffle.h;endline=24;md5=61dbf8697f61c78645e75a93c585b1bf"
5
6SRC_URI = "http://people.freedesktop.org/~chadversary/waffle/files/release/${BPN}-${PV}/${BPN}-${PV}.tar.xz \
7 file://cflags.patch"
8
9SRC_URI[md5sum] = "fdd07cea7709422fbf72418ee63a285d"
10SRC_URI[sha256sum] = "7e342c859b58d4e051b347ef3d7740ed2f3b6c506b93daec272724afe7dd1311"
11
12inherit cmake
13
14# This should be overridden per-machine to reflect the capabilities of the GL
15# stack.
16PACKAGECONFIG ??= "glx"
17
18# I say virtual/libgl, actually wants gl.pc
19PACKAGECONFIG[glx] = "-Dwaffle_has_glx=1,,virtual/libgl libx11"
20
21# I say virtual/libgl, actually wants wayland-egl.pc, egl.pc, and the wayland
22# DISTRO_FEATURE.
23PACKAGECONFIG[wayland] = "-Dwaffle_has_wayland=1,,virtual/libgl wayland"
24
25# I say virtual/libgl, actually wants gbm.pc egl.pc
26PACKAGECONFIG[gbm] = "-Dwaffle_has_wayland=1,,virtual/libgl udev"
27
28# I say virtual/libgl, actually wants egl.pc
29PACKAGECONFIG[x11-egl] = "-Dwaffle_has_x11_egl=1,,virtual/libgl libxcb"
30
31# Take the flags added by PACKAGECONFIG and pass them to cmake.
32EXTRA_OECMAKE = "${EXTRA_OECONF}"
33
34FILES_${PN}-dev += "${datadir}/cmake/Modules/FindWaffle.cmake"