summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/waffle/files/cflags.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/waffle/files/cflags.patch')
-rw-r--r--meta-oe/recipes-graphics/waffle/files/cflags.patch27
1 files changed, 27 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/waffle/files/cflags.patch b/meta-oe/recipes-graphics/waffle/files/cflags.patch
new file mode 100644
index 000000000..381975674
--- /dev/null
+++ b/meta-oe/recipes-graphics/waffle/files/cflags.patch
@@ -0,0 +1,27 @@
1Upstream-Status: Backport
2Signed-off-by: Ross Burton <ross.burton@intel.com>
3
4From 2abec1cb3c17fa5ec8d945d79acd74a39c38293a Mon Sep 17 00:00:00 2001
5From: Ross Burton <ross.burton@intel.com>
6Date: Wed, 12 Dec 2012 12:57:18 +0000
7Subject: cmake: respect existing CMAKE_C_FLAGS
8
9When cross-compiling it's not unusual to need specific arguments passed to gcc
10such as --sysroot. Ensure that these are passed on from the toolchain file by
11appending to CMAKE_C_FLAGS instead of overwriting it.
12
13Signed-off-by: Ross Burton <ross.burton@intel.com>
14
15Index: waffle-1.2.2/CMakeLists.txt
16===================================================================
17--- waffle-1.2.2.orig/CMakeLists.txt 2012-11-28 00:43:40.000000000 +0000
18+++ waffle-1.2.2/CMakeLists.txt 2013-02-13 11:34:02.476188233 +0000
19@@ -212,7 +212,7 @@
20 # ------------------------------------------------------------------------------
21
22 # FIXME: Only enable c99 if compiler supports it.
23-set(CMAKE_C_FLAGS "--std=c99 -Wall -Werror=implicit-function-declaration")
24+set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} --std=c99 -Wall -Werror=implicit-function-declaration")
25 if("${CMAKE_SYSTEM_NAME}" STREQUAL "Linux")
26 # On MacOS, the SSE2 headers trigger this error.
27 set(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Werror=missing-prototypes")