summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/tigervnc/files
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/tigervnc/files')
-rw-r--r--meta-oe/recipes-graphics/tigervnc/files/0001-tigervnc-remove-includedir.patch50
-rw-r--r--meta-oe/recipes-graphics/tigervnc/files/0002-do-not-build-tests-sub-directory.patch29
-rw-r--r--meta-oe/recipes-graphics/tigervnc/files/0003-add-missing-dynamic-library-to-FLTK_LIBRARIES.patch28
-rw-r--r--meta-oe/recipes-graphics/tigervnc/files/0004-tigervnc-add-fPIC-option-to-COMPILE_FLAGS.patch62
4 files changed, 169 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/tigervnc/files/0001-tigervnc-remove-includedir.patch b/meta-oe/recipes-graphics/tigervnc/files/0001-tigervnc-remove-includedir.patch
new file mode 100644
index 000000000..12c437629
--- /dev/null
+++ b/meta-oe/recipes-graphics/tigervnc/files/0001-tigervnc-remove-includedir.patch
@@ -0,0 +1,50 @@
1From 4b423cd2e5e4296abca3be553bf64d8cc287180a Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Thu, 20 Jul 2017 17:09:05 +0800
4Subject: [PATCH 1/4] tigervnc: remove includedir
5
6Upstream-Status: Pending
7
8Signed-off-by: Chong Lu <Chong.Lu@windriver.com>
9
10It fixes host contamination
11
12Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
13---
14 unix/xserver/hw/vnc/Makefile.am | 6 +++---
15 1 file changed, 3 insertions(+), 3 deletions(-)
16
17diff --git a/unix/xserver/hw/vnc/Makefile.am b/unix/xserver/hw/vnc/Makefile.am
18index 0d6a4ac..854f078 100644
19--- a/unix/xserver/hw/vnc/Makefile.am
20+++ b/unix/xserver/hw/vnc/Makefile.am
21@@ -22,7 +22,7 @@ libvnccommon_la_SOURCES = $(HDRS) \
22
23 libvnccommon_la_CPPFLAGS = -DVENDOR_RELEASE="$(VENDOR_RELEASE)" \
24 -DVENDOR_STRING="\"$(VENDOR_STRING)\"" -I$(TIGERVNC_SRCDIR)/common -UHAVE_CONFIG_H \
25- -I$(TIGERVNC_SRCDIR)/unix/vncconfig $(XVNC_CPPFLAGS) ${XSERVERLIBS_CFLAGS} -I$(includedir) \
26+ -I$(TIGERVNC_SRCDIR)/unix/vncconfig $(XVNC_CPPFLAGS) ${XSERVERLIBS_CFLAGS} \
27 -I$(top_srcdir)/include
28
29 bin_PROGRAMS = Xvnc
30@@ -42,7 +42,7 @@ Xvnc_CPPFLAGS = $(XVNC_CPPFLAGS) -DTIGERVNC -DNO_MODULE_EXTS \
31 -UHAVE_CONFIG_H \
32 -DXFree86Server -DVENDOR_RELEASE="$(VENDOR_RELEASE)" \
33 -DVENDOR_STRING="\"$(VENDOR_STRING)\"" -I$(TIGERVNC_SRCDIR)/common \
34- -I$(top_srcdir)/include ${XSERVERLIBS_CFLAGS} -I$(includedir)
35+ -I$(top_srcdir)/include ${XSERVERLIBS_CFLAGS}
36
37 Xvnc_LDADD = $(XVNC_LIBS) libvnccommon.la $(COMMON_LIBS) \
38 $(XSERVER_LIBS) $(XSERVER_SYS_LIBS) $(XVNC_SYS_LIBS) -lX11
39@@ -62,7 +62,7 @@ libvnc_la_CPPFLAGS = $(XVNC_CPPFLAGS) -I$(TIGERVNC_SRCDIR)/common -UHAVE_CONFIG_
40 -I$(top_srcdir)/hw/xfree86/os-support \
41 -I$(top_srcdir)/hw/xfree86/os-support/bus \
42 -I$(top_srcdir)/include \
43- ${XSERVERLIBS_CFLAGS} -I$(includedir)
44+ ${XSERVERLIBS_CFLAGS}
45
46 libvnc_la_LDFLAGS = -module -avoid-version -Wl,-z,now
47
48--
492.7.4
50
diff --git a/meta-oe/recipes-graphics/tigervnc/files/0002-do-not-build-tests-sub-directory.patch b/meta-oe/recipes-graphics/tigervnc/files/0002-do-not-build-tests-sub-directory.patch
new file mode 100644
index 000000000..4e875ba82
--- /dev/null
+++ b/meta-oe/recipes-graphics/tigervnc/files/0002-do-not-build-tests-sub-directory.patch
@@ -0,0 +1,29 @@
1From c3460d63f0b6cd50b9a64265f420f0439e12a1d5 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Tue, 25 Apr 2017 01:36:44 -0400
4Subject: [PATCH 2/4] do not build tests sub directory
5
6Upstream-Status: Inappropriate [oe specific]
7
8Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
9---
10 CMakeLists.txt | 3 ---
11 1 file changed, 3 deletions(-)
12
13diff --git a/CMakeLists.txt b/CMakeLists.txt
14index 94ec2ef..fb72a00 100644
15--- a/CMakeLists.txt
16+++ b/CMakeLists.txt
17@@ -300,9 +300,6 @@ if(BUILD_VIEWER)
18 add_subdirectory(media)
19 endif()
20
21-add_subdirectory(tests)
22-
23-
24 include(cmake/BuildPackages.cmake)
25
26 # uninstall
27--
282.7.4
29
diff --git a/meta-oe/recipes-graphics/tigervnc/files/0003-add-missing-dynamic-library-to-FLTK_LIBRARIES.patch b/meta-oe/recipes-graphics/tigervnc/files/0003-add-missing-dynamic-library-to-FLTK_LIBRARIES.patch
new file mode 100644
index 000000000..cfb84ac14
--- /dev/null
+++ b/meta-oe/recipes-graphics/tigervnc/files/0003-add-missing-dynamic-library-to-FLTK_LIBRARIES.patch
@@ -0,0 +1,28 @@
1From 6369a5be2af2ed1fa443f40f48deaf318d22713e Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Thu, 20 Jul 2017 05:06:00 -0400
4Subject: [PATCH 3/4] add missing dynamic library to FLTK_LIBRARIES
5
6Upstream-Status: Pending
7
8Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
9---
10 CMakeLists.txt | 2 ++
11 1 file changed, 2 insertions(+)
12
13diff --git a/CMakeLists.txt b/CMakeLists.txt
14index fb72a00..5732dc8 100644
15--- a/CMakeLists.txt
16+++ b/CMakeLists.txt
17@@ -246,6 +246,8 @@ if(UNIX AND NOT APPLE)
18 endif()
19 endif()
20
21+set(FLTK_LIBRARIES ${FLTK_LIBRARIES} -lm -ldl -lpng -ljpeg)
22+
23 # Check for GNUTLS library
24 option(ENABLE_GNUTLS "Enable protocol encryption and advanced authentication" ON)
25 if(ENABLE_GNUTLS)
26--
272.7.4
28
diff --git a/meta-oe/recipes-graphics/tigervnc/files/0004-tigervnc-add-fPIC-option-to-COMPILE_FLAGS.patch b/meta-oe/recipes-graphics/tigervnc/files/0004-tigervnc-add-fPIC-option-to-COMPILE_FLAGS.patch
new file mode 100644
index 000000000..97b0a388a
--- /dev/null
+++ b/meta-oe/recipes-graphics/tigervnc/files/0004-tigervnc-add-fPIC-option-to-COMPILE_FLAGS.patch
@@ -0,0 +1,62 @@
1From 9563b69640227da2220ee0c39077afb736cc96d1 Mon Sep 17 00:00:00 2001
2From: Hongxu Jia <hongxu.jia@windriver.com>
3Date: Thu, 20 Jul 2017 17:12:17 +0800
4Subject: [PATCH 4/4] tigervnc: add fPIC option to COMPILE_FLAGS
5
6The static libraries in Xregion/network/rdr/rfb were linked by shared
7library libvnc.so, so we should add fPIC option to COMPILE_FLAGS to fix
8relocation issue.
9
10Upstream-Status: Pending
11
12Signed-off-by: Hongxu Jia <hongxu.jia@windriver.com>
13---
14 common/Xregion/CMakeLists.txt | 1 +
15 common/network/CMakeLists.txt | 1 +
16 common/rdr/CMakeLists.txt | 1 +
17 common/rfb/CMakeLists.txt | 1 +
18 4 files changed, 4 insertions(+)
19
20diff --git a/common/Xregion/CMakeLists.txt b/common/Xregion/CMakeLists.txt
21index 40ca97e..9411328 100644
22--- a/common/Xregion/CMakeLists.txt
23+++ b/common/Xregion/CMakeLists.txt
24@@ -3,4 +3,5 @@ add_library(Xregion STATIC
25
26 if(UNIX)
27 libtool_create_control_file(Xregion)
28+ set_target_properties(Xregion PROPERTIES COMPILE_FLAGS -fPIC)
29 endif()
30diff --git a/common/network/CMakeLists.txt b/common/network/CMakeLists.txt
31index b624c8e..6c06ec9 100644
32--- a/common/network/CMakeLists.txt
33+++ b/common/network/CMakeLists.txt
34@@ -9,4 +9,5 @@ endif()
35
36 if(UNIX)
37 libtool_create_control_file(network)
38+ set_target_properties(network PROPERTIES COMPILE_FLAGS -fPIC)
39 endif()
40diff --git a/common/rdr/CMakeLists.txt b/common/rdr/CMakeLists.txt
41index 989ba2f..20f6489 100644
42--- a/common/rdr/CMakeLists.txt
43+++ b/common/rdr/CMakeLists.txt
44@@ -27,4 +27,5 @@ target_link_libraries(rdr ${RDR_LIBRARIES})
45
46 if(UNIX)
47 libtool_create_control_file(rdr)
48+ set_target_properties(rdr PROPERTIES COMPILE_FLAGS -fPIC)
49 endif()
50diff --git a/common/rfb/CMakeLists.txt b/common/rfb/CMakeLists.txt
51index 5047e5e..88838ab 100644
52--- a/common/rfb/CMakeLists.txt
53+++ b/common/rfb/CMakeLists.txt
54@@ -98,4 +98,5 @@ target_link_libraries(rfb ${RFB_LIBRARIES})
55
56 if(UNIX)
57 libtool_create_control_file(rfb)
58+ set_target_properties(rfb PROPERTIES COMPILE_FLAGS -fPIC)
59 endif()
60--
612.7.4
62