summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/renderdoc/renderdoc_1.13.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/renderdoc/renderdoc_1.13.bb')
-rw-r--r--meta-oe/recipes-graphics/renderdoc/renderdoc_1.13.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/renderdoc/renderdoc_1.13.bb b/meta-oe/recipes-graphics/renderdoc/renderdoc_1.13.bb
new file mode 100644
index 000000000..fa74fb39e
--- /dev/null
+++ b/meta-oe/recipes-graphics/renderdoc/renderdoc_1.13.bb
@@ -0,0 +1,38 @@
1SUMMARY = "RenderDoc recipe providing renderdoccmd"
2DESCRIPTION = "RenderDoc is a frame-capture based graphics debugger"
3HOMEPAGE = "https://github.com/baldurk/renderdoc"
4LICENSE = "MIT"
5LIC_FILES_CHKSUM = "file://LICENSE.md;md5=5486c0df458c74c85828e0cdbffd499e"
6
7SRCREV = "cc05b288b6d1660ab04c6cf01173f1bb62e6f5dd"
8SRC_URI = " \
9 git://github.com/baldurk/${BPN}.git;protocol=http;branch=v1.x \
10 file://0001-renderdoc-use-xxd-instead-of-cross-compiling-shim-bi.patch \
11"
12S = "${WORKDIR}/git"
13
14DEPENDS += "virtual/libx11 virtual/libgl libxcb xcb-util-keysyms vim-native"
15
16RDEPENDS_${PN} = "libxcb xcb-util-keysyms"
17
18inherit cmake python3native features_check
19
20REQUIRED_DISTRO_FEATURES = "x11 opengl"
21
22python __anonymous () {
23 # only works on glibc systems
24 if d.getVar('TCLIBC') != "glibc":
25 raise bb.parse.SkipRecipe("incompatible with %s C library" % d.getVar('TCLIBC'))
26}
27
28COMPATIBLE_HOST = "(x86_64|i.86|arm|aarch64).*-linux"
29
30EXTRA_OECMAKE += "\
31 -DENABLE_QRENDERDOC=OFF \
32 -DENABLE_PYRENDERDOC=OFF \
33 -DENABLE_RENDERDOCCMD=ON \
34 -DCMAKE_BUILD_TYPE=Release \
35"
36
37FILES_${PN} += "${libdir}"
38FILES_${PN}-dev = "${includedir}"