diff options
Diffstat (limited to 'meta-oe/recipes-graphics/piglit/piglit_git.bb')
-rw-r--r-- | meta-oe/recipes-graphics/piglit/piglit_git.bb | 44 |
1 files changed, 44 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/piglit/piglit_git.bb b/meta-oe/recipes-graphics/piglit/piglit_git.bb new file mode 100644 index 0000000000..7c4f9a00b9 --- /dev/null +++ b/meta-oe/recipes-graphics/piglit/piglit_git.bb | |||
@@ -0,0 +1,44 @@ | |||
1 | SUMMARY = "OpenGL driver testing framework" | ||
2 | LICENSE = "MIT & LGPLv2+ & GPLv3 & GPLv2+ & BSD-3-Clause" | ||
3 | LIC_FILES_CHKSUM = "file://COPYING;md5=b2beded7103a3d8a442a2a0391d607b0" | ||
4 | |||
5 | SRC_URI = "git://anongit.freedesktop.org/piglit" | ||
6 | |||
7 | # From 2012/12/30. | ||
8 | SRCREV = "bbeff5d21b06d37338ad28e42d88f499bef13268" | ||
9 | # (when PV goes above 1.0 remove the trailing r) | ||
10 | PV = "1.0+gitr${SRCPV}" | ||
11 | |||
12 | S = "${WORKDIR}/git" | ||
13 | |||
14 | DEPENDS = "virtual/libx11 waffle virtual/libgl libglu python-mako-native python-numpy-native" | ||
15 | |||
16 | inherit cmake pythonnative | ||
17 | |||
18 | # CMake sets the rpath at build time with the source tree, and will reset it at | ||
19 | # install time. As we don't install this doesn't happen, so force the rpath to | ||
20 | # what we need. | ||
21 | EXTRA_OECMAKE = "-DCMAKE_BUILD_WITH_INSTALL_RPATH=1 -DCMAKE_INSTALL_RPATH=${libdir}/piglit/lib" | ||
22 | |||
23 | do_install() { | ||
24 | install -d ${D}${bindir} | ||
25 | install -m 0755 piglit-*.py ${D}${bindir} | ||
26 | |||
27 | install -d ${D}${libdir}/piglit/ | ||
28 | |||
29 | install -d ${D}${libdir}/piglit/bin | ||
30 | install -m 755 ${S}/bin/* ${D}${libdir}/piglit/bin | ||
31 | |||
32 | cp -a lib/ ${D}${libdir}/piglit/ | ||
33 | cp -a framework/ ${D}${libdir}/piglit/ | ||
34 | cp -a generated_tests/ ${D}${libdir}/piglit/ | ||
35 | cp -a tests/ ${D}${libdir}/piglit/ | ||
36 | cp -a templates/ ${D}${libdir}/piglit/ | ||
37 | |||
38 | sed -i -e 's|sys.path.append(.*)|sys.path.append("${libdir}/piglit")|' ${D}${bindir}/piglit-*.py | ||
39 | sed -i -e 's|^templatedir = .*$|templatedir = "${libdir}/piglit/templates"|' ${D}${bindir}/piglit-summary-html.py | ||
40 | } | ||
41 | |||
42 | FILES_${PN}-dbg += "${libdir}/piglit/*/.debug/" | ||
43 | |||
44 | RDEPENDS_${PN} = "python waffle python-json python-subprocess python-multiprocessing python-textutils python-netserver python-shell mesa-demos" | ||