diff options
Diffstat (limited to 'meta-oe/recipes-graphics/graphviz')
-rw-r--r-- | meta-oe/recipes-graphics/graphviz/graphviz/0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch | 33 | ||||
-rw-r--r-- | meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb | 19 |
2 files changed, 51 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/graphviz/graphviz/0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch b/meta-oe/recipes-graphics/graphviz/graphviz/0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch new file mode 100644 index 000000000..21bf1bcd5 --- /dev/null +++ b/meta-oe/recipes-graphics/graphviz/graphviz/0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch | |||
@@ -0,0 +1,33 @@ | |||
1 | From 564901ab78da2b2b1bed92351dc3c102dc0a8154 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Tue, 6 Aug 2019 17:51:39 -0700 | ||
4 | Subject: [PATCH] Set use_tcl to be empty string if tcl is disabled | ||
5 | |||
6 | Upstream-Status: Inappropriate [Cross-compile specific] | ||
7 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
8 | --- | ||
9 | configure.ac | 2 +- | ||
10 | 1 file changed, 1 insertion(+), 1 deletion(-) | ||
11 | |||
12 | --- a/configure.ac | ||
13 | +++ b/configure.ac | ||
14 | @@ -1676,7 +1676,7 @@ AC_ARG_ENABLE(tcl, | ||
15 | [], [enable_tcl=yes]) | ||
16 | |||
17 | if test "x$enable_tcl" != "xyes"; then | ||
18 | - use_tcl="No (disabled)" | ||
19 | + use_tcl="" | ||
20 | fi | ||
21 | |||
22 | if test "x$use_tcl" = "x"; then | ||
23 | --- a/Makefile.am | ||
24 | +++ b/Makefile.am | ||
25 | @@ -19,7 +19,7 @@ pkginclude_HEADERS = $(top_builddir)/gra | ||
26 | man_MANS = graphviz.7 | ||
27 | |||
28 | # $(subdirs) contains the list from: AC_CONFIG_SUBDIRS | ||
29 | -SUBDIRS = $(subdirs) lib plugin cmd tclpkg doc contrib share graphs rtest tests | ||
30 | +SUBDIRS = $(subdirs) lib plugin cmd doc contrib share graphs rtest tests | ||
31 | |||
32 | .PHONY: doxygen | ||
33 | doxygen: | ||
diff --git a/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb b/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb index fb8ea2a5b..176cf4498 100644 --- a/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb +++ b/meta-oe/recipes-graphics/graphviz/graphviz_2.40.1.bb | |||
@@ -29,7 +29,10 @@ SRC_URI = "https://gitlab.com/graphviz/graphviz/-/archive/stable_release_${PV}/g | |||
29 | file://0001-plugin-pango-Include-freetype-headers-explicitly.patch \ | 29 | file://0001-plugin-pango-Include-freetype-headers-explicitly.patch \ |
30 | " | 30 | " |
31 | # Use native mkdefs | 31 | # Use native mkdefs |
32 | SRC_URI_append_class-target = " file://0001-Use-native-mkdefs.patch" | 32 | SRC_URI_append_class-target = "\ |
33 | file://0001-Use-native-mkdefs.patch \ | ||
34 | file://0001-Set-use_tcl-to-be-empty-string-if-tcl-is-disabled.patch \ | ||
35 | " | ||
33 | SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072" | 36 | SRC_URI[md5sum] = "2acf30ca8e6cc8b001b0334db65fd072" |
34 | SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a" | 37 | SRC_URI[sha256sum] = "e6c3f8dbfde1c4523055403927bef29f97f9fc12715c1042b5dcf648a2c1c62a" |
35 | 38 | ||
@@ -40,6 +43,7 @@ EXTRA_OECONF_class-target = "\ | |||
40 | --with-expatlibdir=${STAGING_LIBDIR} \ | 43 | --with-expatlibdir=${STAGING_LIBDIR} \ |
41 | --without-included-ltdl \ | 44 | --without-included-ltdl \ |
42 | --disable-java \ | 45 | --disable-java \ |
46 | --disable-tcl \ | ||
43 | --disable-r \ | 47 | --disable-r \ |
44 | --disable-sharp \ | 48 | --disable-sharp \ |
45 | " | 49 | " |
@@ -55,6 +59,19 @@ do_install_append_class-native() { | |||
55 | install -m755 ${B}/lib/gvpr/mkdefs ${D}${bindir} | 59 | install -m755 ${B}/lib/gvpr/mkdefs ${D}${bindir} |
56 | } | 60 | } |
57 | 61 | ||
62 | PACKAGES =+ "${PN}-python ${PN}-perl ${PN}-demo" | ||
63 | |||
64 | FILES_${PN}-python += "${libdir}/python*/site-packages/ ${libdir}/graphviz/python/" | ||
65 | FILES_${PN}-perl += "${libdir}/perl5/*/vendor_perl/ ${libdir}/graphviz/perl/" | ||
66 | FILES_${PN}-demo += "${datadir}/graphviz/demo/" | ||
67 | |||
68 | RDEPENDS_${PN}-perl += "perl" | ||
69 | RDEPENDS_${PN}-python += "python" | ||
70 | RDEPENDS_${PN}-demo += "python perl" | ||
71 | |||
72 | INSANE_SKIP_${PN}-perl = "dev-so" | ||
73 | INSANE_SKIP_${PN}-python = "dev-so" | ||
74 | |||
58 | FILES_SOLIBSDEV_append = " ${libdir}/graphviz/lib*${SOLIBSDEV}" | 75 | FILES_SOLIBSDEV_append = " ${libdir}/graphviz/lib*${SOLIBSDEV}" |
59 | 76 | ||
60 | BBCLASSEXTEND = "native" | 77 | BBCLASSEXTEND = "native" |