summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/gimp/gimp_2.8.22.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/gimp/gimp_2.8.22.bb')
-rw-r--r--meta-oe/recipes-graphics/gimp/gimp_2.8.22.bb50
1 files changed, 50 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/gimp/gimp_2.8.22.bb b/meta-oe/recipes-graphics/gimp/gimp_2.8.22.bb
new file mode 100644
index 000000000..1ecd2b715
--- /dev/null
+++ b/meta-oe/recipes-graphics/gimp/gimp_2.8.22.bb
@@ -0,0 +1,50 @@
1SUMMARY = "The GIMP is the GNU Image Manipulation Program"
2HOMEPAGE = "http://www.gimp.org"
3SECTION = "x11/graphics"
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7DEPENDS = " \
8 gdk-pixbuf-native \
9 intltool-native \
10 libxslt-native \
11 gtk+ \
12 babl \
13 gegl \
14 libart-lgpl \
15 jpeg \
16 libpng \
17 libexif \
18 tiff \
19 lcms \
20 poppler \
21 jasper \
22 bzip2 \
23 libgudev \
24 libmng \
25"
26DEPENDS += "${@bb.utils.contains('DISTRO_FEATURES', 'x11', 'libxmu libxpm', '', d)}"
27
28inherit gnome gtk-doc
29
30SRC_URI = "http://ftp.gimp.org/pub/gimp/v2.8/gimp-${PV}.tar.bz2 \
31 file://0001-configure-ac-do-not-check-for-freetype-config.patch \
32 file://bump_Babl-GEGL_versions.patch \
33 file://0003-Fix-use-of-gegl-API.patch \
34 "
35SRC_URI[md5sum] = "7e4fd7a53b1d3c32dff642ab1a94b44d"
36SRC_URI[sha256sum] = "9187a35cc52b110d78124d7b27b68a68ade14a794c2721314bac6134d2a5638a"
37
38EXTRA_OECONF = "--disable-python \
39 --without-webkit \
40 --without-wmf"
41
42do_configure_append() {
43 find ${B} -name Makefile | xargs sed -i s:'-I$(includedir)':'-I.':g
44 find ${B} -name Makefile | xargs sed -i s:'-I/usr/include':'-I${STAGING_INCDIR}':g
45}
46
47CFLAGS += "-fPIC"
48
49FILES_${PN}-dbg += "${libdir}/gimp/2.0/*/.debug"
50FILES_${PN} += "${datadir}/appdata"