summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb')
-rw-r--r--meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb18
1 files changed, 17 insertions, 1 deletions
diff --git a/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb b/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb
index b50202d0a..53899f13c 100644
--- a/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb
+++ b/meta-oe/recipes-graphics/fontforge/fontforge_20150824.bb
@@ -9,7 +9,7 @@ LIC_FILES_CHKSUM = " \
9DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash" 9DEPENDS = "glib-2.0 pango giflib tiff libxml2 jpeg python libtool uthash"
10DEPENDS_append_class-target = " libxi" 10DEPENDS_append_class-target = " libxi"
11 11
12inherit autotools-bootstrap pkgconfig pythonnative distro_features_check 12inherit autotools pkgconfig pythonnative distro_features_check
13 13
14REQUIRED_DISTRO_FEATURES_append_class-target = " x11" 14REQUIRED_DISTRO_FEATURES_append_class-target = " x11"
15 15
@@ -24,8 +24,24 @@ do_configure_prepend() {
24 # uthash sources are expected in uthash/src 24 # uthash sources are expected in uthash/src
25 currdir=`pwd` 25 currdir=`pwd`
26 cd ${S} 26 cd ${S}
27
27 mkdir -p uthash/src 28 mkdir -p uthash/src
28 cp ${STAGING_INCDIR}/ut*.h uthash/src 29 cp ${STAGING_INCDIR}/ut*.h uthash/src
30
31 # avoid bootstrap cloning gnulib on every configure
32 cat >.gitmodules <<EOF
33[submodule "gnulib"]
34 path = gnulib
35 url = git://git.sv.gnu.org/gnulib
36EOF
37 cp -rf ${STAGING_DATADIR}/gnulib ${S}
38
39 # --force to avoid errors on reconfigure e.g if recipes changed we depend on
40 # | bootstrap: running: libtoolize --quiet
41 # | libtoolize: error: 'libltdl/COPYING.LIB' exists: use '--force' to overwrite
42 # | ...
43 ./bootstrap --force
44
29 cd $currdir 45 cd $currdir
30} 46}
31 47