summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/fbida
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/fbida')
-rw-r--r--meta-oe/recipes-graphics/fbida/fbida_2.14.bb (renamed from meta-oe/recipes-graphics/fbida/fbida_2.10.bb)16
-rw-r--r--meta-oe/recipes-graphics/fbida/files/cairo-weak-detect.patch17
-rw-r--r--meta-oe/recipes-graphics/fbida/files/fbida-gcc10.patch61
-rw-r--r--meta-oe/recipes-graphics/fbida/files/fix-preprocessor.patch20
4 files changed, 93 insertions, 21 deletions
diff --git a/meta-oe/recipes-graphics/fbida/fbida_2.10.bb b/meta-oe/recipes-graphics/fbida/fbida_2.14.bb
index 0bf48ace6..29d0f64ac 100644
--- a/meta-oe/recipes-graphics/fbida/fbida_2.10.bb
+++ b/meta-oe/recipes-graphics/fbida/fbida_2.14.bb
@@ -6,20 +6,18 @@ AUTHOR = "Gerd Hoffmann"
6SECTION = "utils" 6SECTION = "utils"
7 7
8LICENSE = "GPLv2" 8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=8ca43cbc842c2336e835926c2166c28b" 9LIC_FILES_CHKSUM = "file://COPYING;md5=e8feb78a32950a909621bbb51f634b39"
10 10
11DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif" 11DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif libdrm pixman poppler libepoxy cairo"
12 12
13SRC_URI = "https://www.kraxel.org/releases/fbida/fbida-${PV}.tar.gz \ 13SRC_URI = "https://www.kraxel.org/releases/fbida/fbida-${PV}.tar.gz \
14 file://0001-Avoid-using-host-path.patch \ 14 file://0001-Avoid-using-host-path.patch \
15 file://fix-preprocessor.patch \ 15 file://fix-preprocessor.patch \
16 file://support-jpeg-turbo.patch \ 16 file://support-jpeg-turbo.patch \
17 file://use-jpeg-turbo.patch \ 17 file://cairo-weak-detect.patch \
18 file://fbida-gcc10.patch \
18 " 19 "
19SRC_URI[md5sum] = "09460b964b58c2e39b665498eca29018" 20SRC_URI[sha256sum] = "95b7c01556cb6ef9819f358b314ddfeb8a4cbe862b521a3ed62f03d163154438"
20SRC_URI[sha256sum] = "7a5a3aac61b40a6a2bbf716d270a46e2f8e8d5c97e314e927d41398a4d0b6cb6"
21
22B = "${WORKDIR}/build"
23 21
24inherit pkgconfig 22inherit pkgconfig
25 23
@@ -33,6 +31,10 @@ PACKAGECONFIG[tiff] = ",,tiff"
33PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif" 31PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif"
34PACKAGECONFIG[webp] = ",,libwebp" 32PACKAGECONFIG[webp] = ",,libwebp"
35PACKAGECONFIG[lirc] = ",,lirc" 33PACKAGECONFIG[lirc] = ",,lirc"
34# This can only be enabled when cairo has egl enabled in its packageconfig support too
35PACKAGECONFIG[egl] = ",,"
36
37EXTRA_OEMAKE += ""${@bb.utils.contains('PACKAGECONFIG', 'egl', 'HAVE_CAIRO_GL=yes', 'HAVE_CAIRO_GL=no', d)}""
36 38
37do_compile() { 39do_compile() {
38 sed -i -e 's# fbgs# \$(srcdir)/fbgs#; s#-Ijpeg#-I\$(srcdir)/jpeg#; s# jpeg/# \$(srcdir)/jpeg/#' ${S}/GNUmakefile 40 sed -i -e 's# fbgs# \$(srcdir)/fbgs#; s#-Ijpeg#-I\$(srcdir)/jpeg#; s# jpeg/# \$(srcdir)/jpeg/#' ${S}/GNUmakefile
diff --git a/meta-oe/recipes-graphics/fbida/files/cairo-weak-detect.patch b/meta-oe/recipes-graphics/fbida/files/cairo-weak-detect.patch
new file mode 100644
index 000000000..c7c579cc4
--- /dev/null
+++ b/meta-oe/recipes-graphics/fbida/files/cairo-weak-detect.patch
@@ -0,0 +1,17 @@
1OE configures cairo to disable EGL support, however fbida expects cairo with egl support
2this patch therefore makes it possible to set HAVE_CAIRO_GL via recipe
3
4Upstream-Status: Inappropriate [OE-Specific]
5Signed-off-by: Khem Raj <raj.khem@gmail.com>
6
7--- a/GNUmakefile
8+++ b/GNUmakefile
9@@ -67,7 +67,7 @@ define make-config
10 LIB := $(LIB)
11 RESDIR := $(call ac_resdir)
12 HAVE_LINUX_FB_H := $(call ac_header,linux/fb.h)
13-HAVE_CAIRO_GL := $(call ac_pkg_config,cairo-gl)
14+HAVE_CAIRO_GL ?= $(call ac_pkg_config,cairo-gl)
15 HAVE_LIBPCD := $(call ac_lib,pcd_open,pcd)
16 HAVE_LIBGIF := $(call ac_lib,DGifOpenFileName,gif)
17 HAVE_LIBWEBP := $(call ac_pkg_config,libwebp)
diff --git a/meta-oe/recipes-graphics/fbida/files/fbida-gcc10.patch b/meta-oe/recipes-graphics/fbida/files/fbida-gcc10.patch
new file mode 100644
index 000000000..1104289f3
--- /dev/null
+++ b/meta-oe/recipes-graphics/fbida/files/fbida-gcc10.patch
@@ -0,0 +1,61 @@
1Fix build with gcc10
2
3Patch from https://src.fedoraproject.org/rpms/fbida/raw/master/f/fbida.gcc10.patch
4
5Upstream-Status: Pending
6Signed-off-by: Khem Raj <raj.khem@gmail.com>
7
8--- fbida-2.14/fbi.c.org 2020-03-15 17:02:17.944189632 +0100
9+++ fbida-2.14/fbi.c 2020-03-15 17:02:21.880223224 +0100
10@@ -100,7 +100,6 @@
11
12 /* graphics interface */
13 gfxstate *gfx;
14-int debug;
15
16 /* framebuffer */
17 char *fbdev = NULL;
18--- fbida-2.14/filter.c 2020-03-15 16:44:17.159855150 +0100
19+++ fbida-2.14/filter.c 2020-03-15 16:44:27.017941447 +0100
20@@ -6,8 +6,6 @@
21 #include "readers.h"
22 #include "filter.h"
23
24-int debug = 0;
25-
26 /* ----------------------------------------------------------------------- */
27
28 static void
29--- fbida-2.14/readers.c.org 2020-03-15 17:01:18.692683597 +0100
30+++ fbida-2.14/readers.c 2020-03-15 16:57:19.141632384 +0100
31@@ -6,6 +6,8 @@
32
33 #include "readers.h"
34
35+int debug=0;
36+
37 /* ----------------------------------------------------------------------- */
38
39 void load_bits_lsb(unsigned char *dst, unsigned char *src, int width,
40
41--- fbida-2.14/viewer.c.org 2020-03-15 17:05:02.991595832 +0100
42+++ fbida-2.14/viewer.c 2020-03-15 17:04:55.424531467 +0100
43@@ -40,7 +40,6 @@
44 #define PROCESS_LINES 16
45
46-int debug;
47 Cursor ptrs[POINTER_COUNT];
48
49 /* ----------------------------------------------------------------------- */
50
51--- fbida-2.14/idaconfig.h.org 2020-03-15 17:07:09.239668196 +0100
52+++ fbida-2.14/idaconfig.h 2020-03-15 17:07:21.248770061 +0100
53@@ -17,7 +17,7 @@
54
55 /* -------------------------------------------------------------------------- */
56
57-char *ida_lists;
58+extern char *ida_lists;
59
60 void ida_init_config(void);
61 void ida_read_config(void);
diff --git a/meta-oe/recipes-graphics/fbida/files/fix-preprocessor.patch b/meta-oe/recipes-graphics/fbida/files/fix-preprocessor.patch
index 909a0a6c0..cdeac996a 100644
--- a/meta-oe/recipes-graphics/fbida/files/fix-preprocessor.patch
+++ b/meta-oe/recipes-graphics/fbida/files/fix-preprocessor.patch
@@ -1,14 +1,6 @@
1Index: fbida-2.13/GNUmakefile 1--- a/scripts/jpeg-version.sh
2=================================================================== 2+++ b/scripts/jpeg-version.sh
3--- fbida-2.13.orig/GNUmakefile 3@@ -1,2 +1,2 @@
4+++ fbida-2.13/GNUmakefile 4 #!/bin/sh
5@@ -53,8 +53,7 @@ include $(srcdir)/mk/Autoconf.mk 5-echo JPEG_LIB_VERSION | cpp $CFLAGS -include jpeglib.h | tail -1
6 6+${CPP} -include jpeglib.h -dM -E -x c /dev/null | grep 'define JPEG_LIB_VERSION' | cut -f 3 -d' '
7 ac_jpeg_ver = $(shell \
8 $(call ac_init,for libjpeg version);\
9- $(call ac_s_cmd,echo JPEG_LIB_VERSION \
10- | cpp -include jpeglib.h | tail -n 1);\
11+ $(call ac_s_cmd,cpp -include jpeglib.h -dM -E -x c /dev/null | grep 'define JPEG_LIB_VERSION' | cut -f 3 -d' ');\
12 $(call ac_fini))
13
14 define make-config