summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-graphics/fbida/fbida_2.14.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-graphics/fbida/fbida_2.14.bb')
-rw-r--r--meta-oe/recipes-graphics/fbida/fbida_2.14.bb75
1 files changed, 75 insertions, 0 deletions
diff --git a/meta-oe/recipes-graphics/fbida/fbida_2.14.bb b/meta-oe/recipes-graphics/fbida/fbida_2.14.bb
new file mode 100644
index 000000000..29d0f64ac
--- /dev/null
+++ b/meta-oe/recipes-graphics/fbida/fbida_2.14.bb
@@ -0,0 +1,75 @@
1SUMMARY = "Framebuffer image and doc viewer tools"
2DESCRIPTION = "The fbida project contains a few applications for viewing and editing images, \
3 with the main focus being photos."
4HOMEPAGE = "http://linux.bytesex.org/fbida/"
5AUTHOR = "Gerd Hoffmann"
6SECTION = "utils"
7
8LICENSE = "GPLv2"
9LIC_FILES_CHKSUM = "file://COPYING;md5=e8feb78a32950a909621bbb51f634b39"
10
11DEPENDS = "virtual/libiconv jpeg fontconfig freetype libexif libdrm pixman poppler libepoxy cairo"
12
13SRC_URI = "https://www.kraxel.org/releases/fbida/fbida-${PV}.tar.gz \
14 file://0001-Avoid-using-host-path.patch \
15 file://fix-preprocessor.patch \
16 file://support-jpeg-turbo.patch \
17 file://cairo-weak-detect.patch \
18 file://fbida-gcc10.patch \
19 "
20SRC_URI[sha256sum] = "95b7c01556cb6ef9819f358b314ddfeb8a4cbe862b521a3ed62f03d163154438"
21
22inherit pkgconfig
23
24EXTRA_OEMAKE = "STRIP= 'srcdir=${S}' -f ${S}/GNUmakefile"
25
26PACKAGECONFIG ??= "gif png curl"
27PACKAGECONFIG[curl] = ",,curl"
28PACKAGECONFIG[gif] = ",,giflib"
29PACKAGECONFIG[png] = ",,libpng"
30PACKAGECONFIG[tiff] = ",,tiff"
31PACKAGECONFIG[motif] = ",,libx11 libxext libxpm libxt openmotif"
32PACKAGECONFIG[webp] = ",,libwebp"
33PACKAGECONFIG[lirc] = ",,lirc"
34# This can only be enabled when cairo has egl enabled in its packageconfig support too
35PACKAGECONFIG[egl] = ",,"
36
37EXTRA_OEMAKE += ""${@bb.utils.contains('PACKAGECONFIG', 'egl', 'HAVE_CAIRO_GL=yes', 'HAVE_CAIRO_GL=no', d)}""
38
39do_compile() {
40 sed -i -e 's# fbgs# \$(srcdir)/fbgs#; s#-Ijpeg#-I\$(srcdir)/jpeg#; s# jpeg/# \$(srcdir)/jpeg/#' ${S}/GNUmakefile
41 sed -i -e 's:/sbin/ldconfig:echo x:' ${S}/mk/Autoconf.mk
42 sed -i -e 's: cpp: ${CPP}:' ${S}/GNUmakefile
43
44 # Be sure to respect preferences (force to "no")
45 # Also avoid issues when ${BUILD_ARCH} == ${HOST_ARCH}
46 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'curl', d)}" ]; then
47 sed -i -e '/^HAVE_LIBCURL/s/:=.*$/:= no/' ${S}/GNUmakefile
48 fi
49 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'gif', d)}" ]; then
50 sed -i -e '/^HAVE_LIBGIF/s/:=.*$/:= no/' ${S}/GNUmakefile
51 fi
52 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'png', d)}" ]; then
53 sed -i -e '/^HAVE_LIBPNG/s/:=.*$/:= no/' ${S}/GNUmakefile
54 fi
55 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'tiff', d)}" ]; then
56 sed -i -e '/^HAVE_LIBTIFF/s/:=.*$/:= no/' ${S}/GNUmakefile
57 fi
58 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'motif', d)}" ]; then
59 sed -i -e '/^HAVE_MOTIF/s/:=.*$/:= no/' ${S}/GNUmakefile
60 fi
61 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'webp', d)}" ]; then
62 sed -i -e '/^HAVE_LIBWEBP/s/:=.*$/:= no/' ${S}/GNUmakefile
63 fi
64 if [ -z "${@bb.utils.filter('PACKAGECONFIG', 'lirc', d)}" ]; then
65 sed -i -e '/^HAVE_LIBLIRC/s/:=.*$/:= no/' ${S}/GNUmakefile
66 fi
67
68 oe_runmake
69}
70
71do_install() {
72 oe_runmake 'DESTDIR=${D}' install
73}
74
75RDEPENDS_${PN} = "ttf-dejavu-sans-mono bash"