diff options
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r-- | meta-oe/recipes-extended/acpica/acpitests/0001-Fixup-aapits-build.patch | 558 | ||||
-rw-r--r-- | meta-oe/recipes-extended/acpica/acpitests_20140114.bb | 32 |
2 files changed, 590 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/acpica/acpitests/0001-Fixup-aapits-build.patch b/meta-oe/recipes-extended/acpica/acpitests/0001-Fixup-aapits-build.patch new file mode 100644 index 000000000..6565a32ab --- /dev/null +++ b/meta-oe/recipes-extended/acpica/acpitests/0001-Fixup-aapits-build.patch | |||
@@ -0,0 +1,558 @@ | |||
1 | From d9743540b5399a14a7ca1ba708156bed956d9425 Mon Sep 17 00:00:00 2001 | ||
2 | From: Al Stone <ahs3@ahs3.net> | ||
3 | Date: Fri, 17 Jan 2014 12:51:13 +0100 | ||
4 | Subject: [PATCH] Fixup aapits build | ||
5 | |||
6 | From http://git.linaro.org/people/al.stone/acpica-tools.git | ||
7 | Upstream-status: Unknown | ||
8 | --- | ||
9 | tests/aapits/Makefile | 44 +++++++++++++++++++++++++++++++++++++++++--- | ||
10 | tests/aapits/atexec.c | 15 ++++++++++----- | ||
11 | tests/aapits/atinit.c | 10 +++++----- | ||
12 | tests/aapits/atmain.c | 6 +++--- | ||
13 | tests/aapits/atnamespace.c | 12 ++++++++---- | ||
14 | tests/aapits/atosxfctrl.c | 21 +++++++++++++++++---- | ||
15 | tests/aapits/atresource.c | 10 +++++----- | ||
16 | tests/aapits/osunixxf.c | 25 ++++++++++++++++++++++--- | ||
17 | 8 files changed, 111 insertions(+), 32 deletions(-) | ||
18 | |||
19 | diff --git a/tests/aapits/Makefile b/tests/aapits/Makefile | ||
20 | index b774c9c..9bf12b8 100644 | ||
21 | --- a/tests/aapits/Makefile | ||
22 | +++ b/tests/aapits/Makefile | ||
23 | @@ -20,37 +20,53 @@ SRCS= atexec.c atmain.c \ | ||
24 | ../../source/components/hardware/hwxface.c \ | ||
25 | ../../source/common/getopt.c \ | ||
26 | ../../source/components/debugger/dbcmds.c \ | ||
27 | + ../../source/components/debugger/dbconvert.c \ | ||
28 | ../../source/components/debugger/dbdisply.c \ | ||
29 | ../../source/components/debugger/dbexec.c \ | ||
30 | ../../source/components/debugger/dbfileio.c \ | ||
31 | ../../source/components/debugger/dbhistry.c \ | ||
32 | ../../source/components/debugger/dbinput.c \ | ||
33 | + ../../source/components/debugger/dbmethod.c \ | ||
34 | + ../../source/components/debugger/dbnames.c \ | ||
35 | ../../source/components/debugger/dbstats.c \ | ||
36 | + ../../source/components/debugger/dbtest.c \ | ||
37 | ../../source/components/debugger/dbutils.c \ | ||
38 | ../../source/components/debugger/dbxface.c \ | ||
39 | ../../source/components/disassembler/dmbuffer.c \ | ||
40 | + ../../source/components/disassembler/dmdeferred.c \ | ||
41 | ../../source/components/disassembler/dmnames.c \ | ||
42 | ../../source/components/disassembler/dmobject.c \ | ||
43 | ../../source/components/disassembler/dmopcode.c \ | ||
44 | ../../source/components/disassembler/dmresrc.c \ | ||
45 | ../../source/components/disassembler/dmresrcl.c \ | ||
46 | + ../../source/components/disassembler/dmresrcl2.c \ | ||
47 | ../../source/components/disassembler/dmresrcs.c \ | ||
48 | ../../source/components/disassembler/dmutils.c \ | ||
49 | ../../source/components/disassembler/dmwalk.c \ | ||
50 | ../../source/components/events/evevent.c \ | ||
51 | + ../../source/components/events/evglock.c \ | ||
52 | ../../source/components/events/evgpeblk.c \ | ||
53 | ../../source/components/events/evgpe.c \ | ||
54 | + ../../source/components/events/evgpeinit.c \ | ||
55 | + ../../source/components/events/evgpeutil.c \ | ||
56 | + ../../source/components/events/evhandler.c \ | ||
57 | ../../source/components/events/evmisc.c \ | ||
58 | ../../source/components/events/evregion.c \ | ||
59 | ../../source/components/events/evrgnini.c \ | ||
60 | ../../source/components/events/evsci.c \ | ||
61 | ../../source/components/events/evxface.c \ | ||
62 | ../../source/components/events/evxfevnt.c \ | ||
63 | + ../../source/components/events/evxfgpe.c \ | ||
64 | ../../source/components/events/evxfregn.c \ | ||
65 | ../../source/components/hardware/hwacpi.c \ | ||
66 | + ../../source/components/hardware/hwesleep.c \ | ||
67 | ../../source/components/hardware/hwgpe.c \ | ||
68 | + ../../source/components/hardware/hwpci.c \ | ||
69 | ../../source/components/hardware/hwregs.c \ | ||
70 | ../../source/components/hardware/hwsleep.c \ | ||
71 | + ../../source/components/hardware/hwxfsleep.c \ | ||
72 | + ../../source/components/dispatcher/dsargs.c \ | ||
73 | + ../../source/components/dispatcher/dscontrol.c \ | ||
74 | ../../source/components/dispatcher/dsfield.c \ | ||
75 | ../../source/components/dispatcher/dsinit.c \ | ||
76 | ../../source/components/dispatcher/dsmethod.c \ | ||
77 | @@ -60,11 +76,13 @@ SRCS= atexec.c atmain.c \ | ||
78 | ../../source/components/dispatcher/dsutils.c \ | ||
79 | ../../source/components/dispatcher/dswexec.c \ | ||
80 | ../../source/components/dispatcher/dswload.c \ | ||
81 | + ../../source/components/dispatcher/dswload2.c \ | ||
82 | ../../source/components/dispatcher/dswscope.c \ | ||
83 | ../../source/components/dispatcher/dswstate.c \ | ||
84 | ../../source/components/executer/exconfig.c \ | ||
85 | ../../source/components/executer/exconvrt.c \ | ||
86 | ../../source/components/executer/excreate.c \ | ||
87 | + ../../source/components/executer/exdebug.c \ | ||
88 | ../../source/components/executer/exdump.c \ | ||
89 | ../../source/components/executer/exfield.c \ | ||
90 | ../../source/components/executer/exfldio.c \ | ||
91 | @@ -87,7 +105,9 @@ SRCS= atexec.c atmain.c \ | ||
92 | ../../source/components/executer/exutils.c \ | ||
93 | ../../source/components/parser/psargs.c \ | ||
94 | ../../source/components/parser/psloop.c \ | ||
95 | + ../../source/components/parser/psobject.c \ | ||
96 | ../../source/components/parser/psopcode.c \ | ||
97 | + ../../source/components/parser/psopinfo.c \ | ||
98 | ../../source/components/parser/psparse.c \ | ||
99 | ../../source/components/parser/psscope.c \ | ||
100 | ../../source/components/parser/pstree.c \ | ||
101 | @@ -96,6 +116,8 @@ SRCS= atexec.c atmain.c \ | ||
102 | ../../source/components/parser/psxface.c \ | ||
103 | ../../source/components/namespace/nsaccess.c \ | ||
104 | ../../source/components/namespace/nsalloc.c \ | ||
105 | + ../../source/components/namespace/nsarguments.c \ | ||
106 | + ../../source/components/namespace/nsconvert.c \ | ||
107 | ../../source/components/namespace/nsdump.c \ | ||
108 | ../../source/components/namespace/nsdumpdv.c \ | ||
109 | ../../source/components/namespace/nseval.c \ | ||
110 | @@ -105,6 +127,7 @@ SRCS= atexec.c atmain.c \ | ||
111 | ../../source/components/namespace/nsobject.c \ | ||
112 | ../../source/components/namespace/nsparse.c \ | ||
113 | ../../source/components/namespace/nspredef.c \ | ||
114 | + ../../source/components/namespace/nsprepkg.c \ | ||
115 | ../../source/components/namespace/nsrepair.c \ | ||
116 | ../../source/components/namespace/nsrepair2.c \ | ||
117 | ../../source/components/namespace/nssearch.c \ | ||
118 | @@ -117,26 +140,35 @@ SRCS= atexec.c atmain.c \ | ||
119 | ../../source/components/resources/rscalc.c \ | ||
120 | ../../source/components/resources/rscreate.c \ | ||
121 | ../../source/components/resources/rsdump.c \ | ||
122 | + ../../source/components/resources/rsdumpinfo.c \ | ||
123 | + ../../source/components/resources/rsinfo.c \ | ||
124 | ../../source/components/resources/rsio.c \ | ||
125 | ../../source/components/resources/rsirq.c \ | ||
126 | ../../source/components/resources/rslist.c \ | ||
127 | ../../source/components/resources/rsmemory.c \ | ||
128 | ../../source/components/resources/rsmisc.c \ | ||
129 | + ../../source/components/resources/rsserial.c \ | ||
130 | ../../source/components/resources/rsutils.c \ | ||
131 | ../../source/components/resources/rsxface.c \ | ||
132 | - ../../source/components/resources/rsinfo.c \ | ||
133 | ../../source/components/tables/tbfadt.c \ | ||
134 | ../../source/components/tables/tbfind.c \ | ||
135 | ../../source/components/tables/tbinstal.c \ | ||
136 | + ../../source/components/tables/tbprint.c \ | ||
137 | ../../source/components/tables/tbutils.c \ | ||
138 | ../../source/components/tables/tbxface.c \ | ||
139 | + ../../source/components/tables/tbxfload.c \ | ||
140 | ../../source/components/tables/tbxfroot.c \ | ||
141 | + ../../source/components/utilities/utaddress.c \ | ||
142 | ../../source/components/utilities/utalloc.c \ | ||
143 | + ../../source/components/utilities/utbuffer.c \ | ||
144 | ../../source/components/utilities/utcache.c \ | ||
145 | ../../source/components/utilities/utcopy.c \ | ||
146 | ../../source/components/utilities/utdebug.c \ | ||
147 | + ../../source/components/utilities/utdecode.c \ | ||
148 | ../../source/components/utilities/utdelete.c \ | ||
149 | + ../../source/components/utilities/uterror.c \ | ||
150 | ../../source/components/utilities/uteval.c \ | ||
151 | + ../../source/components/utilities/utexcep.c \ | ||
152 | ../../source/components/utilities/utglobal.c \ | ||
153 | ../../source/components/utilities/utids.c \ | ||
154 | ../../source/components/utilities/utinit.c \ | ||
155 | @@ -145,17 +177,23 @@ SRCS= atexec.c atmain.c \ | ||
156 | ../../source/components/utilities/utmisc.c \ | ||
157 | ../../source/components/utilities/utmutex.c \ | ||
158 | ../../source/components/utilities/utobject.c \ | ||
159 | + ../../source/components/utilities/utosi.c \ | ||
160 | + ../../source/components/utilities/utownerid.c \ | ||
161 | + ../../source/components/utilities/utpredef.c \ | ||
162 | ../../source/components/utilities/utresrc.c \ | ||
163 | ../../source/components/utilities/utstate.c \ | ||
164 | + ../../source/components/utilities/utstring.c \ | ||
165 | ../../source/components/utilities/uttrack.c \ | ||
166 | - ../../source/components/utilities/utxface.c | ||
167 | + ../../source/components/utilities/utxface.c \ | ||
168 | + ../../source/components/utilities/utxferror.c \ | ||
169 | + ../../source/components/utilities/utxfinit.c | ||
170 | # ../../source/components/osunixxf.c | ||
171 | |||
172 | |||
173 | CFLAGS+= -Wall -g -D_LINUX -DNDEBUG -D_CONSOLE -DACPI_EXEC_APP -D_MULTI_THREADED -Wstrict-prototypes -I../../source/include | ||
174 | |||
175 | |||
176 | -acpiexec : $(patsubst %.c,%.o, $(SRCS)) | ||
177 | +$(PROG) : $(patsubst %.c,%.o, $(SRCS)) | ||
178 | $(CC) $(LDFLAGS) $(patsubst %.c,%.o, $(SRCS)) -o $(PROG) | ||
179 | |||
180 | CLEANFILES= $(PROG) | ||
181 | diff --git a/tests/aapits/atexec.c b/tests/aapits/atexec.c | ||
182 | index 0280557..1406c0f 100644 | ||
183 | --- a/tests/aapits/atexec.c | ||
184 | +++ b/tests/aapits/atexec.c | ||
185 | @@ -639,6 +639,7 @@ AtBuildLocalFADT2 ( | ||
186 | } | ||
187 | |||
188 | |||
189 | +#if ACPI_MACHINE_WIDTH == 32 | ||
190 | /******************************************************************************* | ||
191 | * | ||
192 | * FUNCTION: AtBuildLocalRSDT | ||
193 | @@ -757,6 +758,7 @@ AtBuildLocalRSDT ( | ||
194 | LocalRSDT->Header.Checksum = (UINT8)~LocalRSDT->Header.Checksum; | ||
195 | } | ||
196 | } | ||
197 | +#endif | ||
198 | |||
199 | |||
200 | /******************************************************************************* | ||
201 | @@ -1424,7 +1426,7 @@ AeRegionHandler ( | ||
202 | ACPI_WARNING ((AE_INFO, | ||
203 | "Request on [%4.4s] is beyond region limit Req-%X+%X, Base=%X, Len-%X\n", | ||
204 | (RegionObject->Region.Node)->Name.Ascii, (UINT32) Address, | ||
205 | - ByteWidth, (UINT32) BufferAddress, Length)); | ||
206 | + ByteWidth, (UINT32) BufferAddress, (UINT32) Length)); | ||
207 | |||
208 | return (AE_AML_REGION_LIMIT); | ||
209 | } | ||
210 | @@ -1792,7 +1794,9 @@ AtCheckInteger( | ||
211 | Path, Obj.Integer.Value, Value); | ||
212 | #else | ||
213 | printf ("API Error: Value of %s is 0x%llx instead of expected 0x%llx\n", | ||
214 | - Path, Obj.Integer.Value, Value); | ||
215 | + Path, | ||
216 | + (long long unsigned int) Obj.Integer.Value, | ||
217 | + (long long unsigned int) Value); | ||
218 | #endif | ||
219 | Status = AE_ERROR; | ||
220 | } | ||
221 | @@ -1871,7 +1875,7 @@ AtCheckString( | ||
222 | { | ||
223 | TestErrors++; | ||
224 | printf ("Test Error: cannot allocate buffer of %d bytes\n", | ||
225 | - Results.Length); | ||
226 | + (int) Results.Length); | ||
227 | return (AE_NO_MEMORY); | ||
228 | } | ||
229 | Results.Pointer = Object; | ||
230 | @@ -1952,7 +1956,8 @@ AtCheckBuffer( | ||
231 | { | ||
232 | printf ("AtCheckBuffer: unexpected length %d of Buffer vs" | ||
233 | " calculated %d bytes\n", | ||
234 | - Results.Length, ACPI_ROUND_UP_TO_NATIVE_WORD(sizeof (ACPI_OBJECT) + Length)); | ||
235 | + (int)Results.Length, | ||
236 | + (int)(ACPI_ROUND_UP_TO_NATIVE_WORD(sizeof (ACPI_OBJECT) + Length))); | ||
237 | } | ||
238 | |||
239 | /* Initialize the return buffer structure */ | ||
240 | @@ -1961,7 +1966,7 @@ AtCheckBuffer( | ||
241 | { | ||
242 | TestErrors++; | ||
243 | printf ("Test Error: cannot allocate buffer of %d bytes\n", | ||
244 | - Results.Length); | ||
245 | + (int) Results.Length); | ||
246 | return (AE_NO_MEMORY); | ||
247 | } | ||
248 | Results.Pointer = Object; | ||
249 | diff --git a/tests/aapits/atinit.c b/tests/aapits/atinit.c | ||
250 | index 5bb8ee3..2444225 100644 | ||
251 | --- a/tests/aapits/atinit.c | ||
252 | +++ b/tests/aapits/atinit.c | ||
253 | @@ -3024,7 +3024,7 @@ AtInitTest0041(void) | ||
254 | AapiErrors++; | ||
255 | printf ("API Error: AcpiGetSystemInfo() returned" | ||
256 | " Length %d, expected %d\n", | ||
257 | - OutBuffer.Length, sizeof (Info)); | ||
258 | + (int) OutBuffer.Length, (int) sizeof (Info)); | ||
259 | return (AE_ERROR); | ||
260 | } | ||
261 | |||
262 | @@ -3046,7 +3046,7 @@ AtInitTest0041(void) | ||
263 | AapiErrors++; | ||
264 | printf ("API Error: AcpiGetSystemInfo() returned" | ||
265 | " Length %d, expected %d\n", | ||
266 | - OutBuffer.Length, sizeof (Info)); | ||
267 | + (int) OutBuffer.Length, (int) sizeof (Info)); | ||
268 | return (AE_ERROR); | ||
269 | } | ||
270 | |||
271 | @@ -3066,7 +3066,7 @@ AtInitTest0041(void) | ||
272 | AapiErrors++; | ||
273 | printf ("API Error: AcpiGetSystemInfo() returned" | ||
274 | " Length %d, expected %d\n", | ||
275 | - OutBuffer.Length, sizeof (Info)); | ||
276 | + (int) OutBuffer.Length, (int) sizeof (Info)); | ||
277 | return (AE_ERROR); | ||
278 | } | ||
279 | else if (OutBuffer.Pointer != &Info) | ||
280 | @@ -3149,7 +3149,7 @@ AtInitTest0042(void) | ||
281 | AapiErrors++; | ||
282 | printf ("API Error: AcpiGetSystemInfo() returned" | ||
283 | " Length %d, expected %d\n", | ||
284 | - OutBuffer.Length, sizeof (Info)); | ||
285 | + (int) OutBuffer.Length, (int) sizeof (Info)); | ||
286 | return (AE_ERROR); | ||
287 | } | ||
288 | else if (OutBuffer.Pointer != &Info) | ||
289 | @@ -3214,7 +3214,7 @@ AtInitTest0043(void) | ||
290 | AapiErrors++; | ||
291 | printf ("API Error: AcpiGetSystemInfo() returned" | ||
292 | " Length %d, expected %d\n", | ||
293 | - OutBuffer.Length, sizeof (ACPI_SYSTEM_INFO)); | ||
294 | + (int) OutBuffer.Length, (int) sizeof (ACPI_SYSTEM_INFO)); | ||
295 | return (AE_ERROR); | ||
296 | } | ||
297 | else | ||
298 | diff --git a/tests/aapits/atmain.c b/tests/aapits/atmain.c | ||
299 | index c3f5de7..e83e524 100644 | ||
300 | --- a/tests/aapits/atmain.c | ||
301 | +++ b/tests/aapits/atmain.c | ||
302 | @@ -315,7 +315,7 @@ ExecuteTest ( | ||
303 | { | ||
304 | printf ("ACPICA API TS err: test num %ld of test case %ld" | ||
305 | " is not implemented\n", | ||
306 | - test_num, test_case); | ||
307 | + (long int) test_num, (long int) test_case); | ||
308 | return (AtRetNotImpl); | ||
309 | } | ||
310 | |||
311 | @@ -430,7 +430,7 @@ main( | ||
312 | if (test_case < 1 || test_case > AT_TEST_CASE_NUM) | ||
313 | { | ||
314 | printf ("ACPICA API TS err: test case %ld is out of range 1 - %d\n", | ||
315 | - test_case, AT_TEST_CASE_NUM); | ||
316 | + (long int) test_case, (int) AT_TEST_CASE_NUM); | ||
317 | return (AtRetBadParam); | ||
318 | } | ||
319 | |||
320 | @@ -438,7 +438,7 @@ main( | ||
321 | if (test_num < 0 || test_num > AtTestCase[test_case].TestsNum) | ||
322 | { | ||
323 | printf ("ACPICA API TS err: test num %ld is out of range 0 - %d\n", | ||
324 | - test_num, AtTestCase[test_case].TestsNum); | ||
325 | + (long int) test_num, AtTestCase[test_case].TestsNum); | ||
326 | return (AtRetBadParam); | ||
327 | } | ||
328 | |||
329 | diff --git a/tests/aapits/atnamespace.c b/tests/aapits/atnamespace.c | ||
330 | index 8a4ec65..76e3edb 100644 | ||
331 | --- a/tests/aapits/atnamespace.c | ||
332 | +++ b/tests/aapits/atnamespace.c | ||
333 | @@ -2535,7 +2535,8 @@ AtGetObjectInfoTypeCommon( | ||
334 | #else | ||
335 | printf ("API Error: Address of %s (0x%llX) != (0x%llX)\n", | ||
336 | PathNames[2 * i + 1], | ||
337 | - Info->Address, ExpectedInfo[i].Address); | ||
338 | + (long long unsigned int) Info->Address, | ||
339 | + (long long unsigned int) ExpectedInfo[i].Address); | ||
340 | #endif | ||
341 | #else | ||
342 | printf ("API Error: Address of %s (0x%X) != (0x%X)\n", | ||
343 | @@ -2908,7 +2909,8 @@ AtGetNextObjectTypeCommon( | ||
344 | TestErrors++; | ||
345 | printf ("AtGetNextObjectTypeCommon: different numbers of entities" | ||
346 | "in TypesNames (%d) and LevelTypes0000 (%d)\n", | ||
347 | - TypesCount, sizeof (LevelTypes0000) / sizeof (ACPI_OBJECT_TYPE)); | ||
348 | + TypesCount, | ||
349 | + (int) (sizeof (LevelTypes0000) / sizeof (ACPI_OBJECT_TYPE))); | ||
350 | return (AE_ERROR); | ||
351 | } | ||
352 | |||
353 | @@ -4192,7 +4194,9 @@ AtCheckHandlePathMapping( | ||
354 | Pathname, Obj.Integer.Value, Value); | ||
355 | #else | ||
356 | printf ("API Error: Value of %s is 0x%llx instead of expected 0x%llx\n", | ||
357 | - Pathname, Obj.Integer.Value, Value); | ||
358 | + Pathname, | ||
359 | + (long long unsigned int) Obj.Integer.Value, | ||
360 | + (long long unsigned int) Value); | ||
361 | #endif | ||
362 | Status = AE_ERROR; | ||
363 | } | ||
364 | @@ -5199,7 +5203,7 @@ AtGetNameExceptionTest( | ||
365 | { | ||
366 | AapiErrors++; | ||
367 | printf ("API Error: AcpiOsAllocate(%d) returned NULL\n", | ||
368 | - OutName.Length); | ||
369 | + (int) OutName.Length); | ||
370 | return (AE_ERROR); | ||
371 | } | ||
372 | } | ||
373 | diff --git a/tests/aapits/atosxfctrl.c b/tests/aapits/atosxfctrl.c | ||
374 | index 9680c4a..31d6971 100644 | ||
375 | --- a/tests/aapits/atosxfctrl.c | ||
376 | +++ b/tests/aapits/atosxfctrl.c | ||
377 | @@ -737,13 +737,15 @@ ACPI_OSXF_EMUL_REG | ||
378 | #if ACPI_MACHINE_WIDTH == 64 | ||
379 | #ifdef _MSC_VER | ||
380 | printf("OsxfCtrlFingReg: unexpected Width %d of Reg 0x%I64x\n", | ||
381 | + Width, Address); | ||
382 | #else | ||
383 | printf("OsxfCtrlFingReg: unexpected Width %d of Reg 0x%llx\n", | ||
384 | + Width, (long long unsigned int) Address); | ||
385 | #endif | ||
386 | #else | ||
387 | printf("OsxfCtrlFingReg: unexpected Width %d of Reg 0x%x\n", | ||
388 | -#endif | ||
389 | Width, Address); | ||
390 | +#endif | ||
391 | return (NULL); | ||
392 | } | ||
393 | |||
394 | @@ -764,15 +766,19 @@ ACPI_OSXF_EMUL_REG | ||
395 | #ifdef _MSC_VER | ||
396 | printf("OsxfCtrlFingReg: intersection Regs (0x%I64x: 0x%x)" | ||
397 | " and (0x%I64x: 0x%x)\n", | ||
398 | + Reg->Address, Reg->Width, Address, Width); | ||
399 | #else | ||
400 | printf("OsxfCtrlFingReg: intersection Regs (0x%llx: 0x%x)" | ||
401 | " and (0x%llx: 0x%x)\n", | ||
402 | + (long long unsigned int) Reg->Address, | ||
403 | + Reg->Width, | ||
404 | + (long long unsigned int) Address, Width); | ||
405 | #endif | ||
406 | #else | ||
407 | printf("OsxfCtrlFingReg: intersection Regs (0x%x: 0x%x)" | ||
408 | " and (0x%x: 0x%x)\n", | ||
409 | -#endif | ||
410 | Reg->Address, Reg->Width, Address, Width); | ||
411 | +#endif | ||
412 | return (NULL); | ||
413 | } | ||
414 | } | ||
415 | @@ -786,13 +792,15 @@ ACPI_OSXF_EMUL_REG | ||
416 | #if ACPI_MACHINE_WIDTH == 64 | ||
417 | #ifdef _MSC_VER | ||
418 | printf("OsxfCtrlFingReg: no memory for Reg (0x%I64x: 0x%x)\n", | ||
419 | + Reg->Address, Reg->Width); | ||
420 | #else | ||
421 | printf("OsxfCtrlFingReg: no memory for Reg (0x%llx: 0x%x)\n", | ||
422 | + (long long unsigned int) Reg->Address, Reg->Width); | ||
423 | #endif | ||
424 | #else | ||
425 | printf("OsxfCtrlFingReg: no memory for Reg (0x%x: 0x%x)\n", | ||
426 | -#endif | ||
427 | Reg->Address, Reg->Width); | ||
428 | +#endif | ||
429 | return (NULL); | ||
430 | } | ||
431 | Reg->Type = Type; | ||
432 | @@ -932,14 +940,19 @@ OsxfCtrlRegService(UINT32 ServiceFlag) | ||
433 | #if ACPI_MACHINE_WIDTH == 64 | ||
434 | #ifdef _MSC_VER | ||
435 | printf("%.2u (%s Address 0x%I64x: Width %.2u) r/w counts: %u/%u\n", | ||
436 | + i, (Reg->Type == EMUL_REG_SYS)? "SYS": "IO", | ||
437 | + Reg->Address, Reg->Width, Reg->ReadCount, Reg->WriteCount); | ||
438 | #else | ||
439 | printf("%.2u (%s Address 0x%llx: Width %.2u) r/w counts: %u/%u\n", | ||
440 | + i, (Reg->Type == EMUL_REG_SYS)? "SYS": "IO", | ||
441 | + (long long unsigned int) Reg->Address, | ||
442 | + Reg->Width, Reg->ReadCount, Reg->WriteCount); | ||
443 | #endif | ||
444 | #else | ||
445 | printf("%.2u (%s Address 0x%.4x: Width %.2u) r/w counts: %u/%u\n", | ||
446 | -#endif | ||
447 | i, (Reg->Type == EMUL_REG_SYS)? "SYS": "IO", | ||
448 | Reg->Address, Reg->Width, Reg->ReadCount, Reg->WriteCount); | ||
449 | +#endif | ||
450 | Reg = Reg->Next; | ||
451 | i++; | ||
452 | } | ||
453 | diff --git a/tests/aapits/atresource.c b/tests/aapits/atresource.c | ||
454 | index a570b73..72ade8b 100644 | ||
455 | --- a/tests/aapits/atresource.c | ||
456 | +++ b/tests/aapits/atresource.c | ||
457 | @@ -174,7 +174,7 @@ AtRsrcTest0000(void) | ||
458 | AapiErrors++; | ||
459 | printf ("API Error: AcpiGetCurrentResources(%s) returned Length %d," | ||
460 | " expected %d\n", | ||
461 | - Pathname, OutBuffer.Length, RT0000_DEV0_CRS_LEN); | ||
462 | + Pathname, (int) OutBuffer.Length, RT0000_DEV0_CRS_LEN); | ||
463 | return (AE_ERROR); | ||
464 | } | ||
465 | |||
466 | @@ -490,7 +490,7 @@ AtRsrcTest0005(void) | ||
467 | AapiErrors++; | ||
468 | printf ("API Error: AcpiGetCurrentResources(%s) returned Length %d," | ||
469 | " expected %d\n", | ||
470 | - Pathname, OutBuffer.Length, RT0000_DEV0_CRS_LEN); | ||
471 | + Pathname, (int) OutBuffer.Length, RT0000_DEV0_CRS_LEN); | ||
472 | return (AE_ERROR); | ||
473 | } | ||
474 | |||
475 | @@ -689,7 +689,7 @@ AtRsrcTest0007(void) | ||
476 | AapiErrors++; | ||
477 | printf ("Api Error: Resource->Length (%d) != %d\n", | ||
478 | CurrentResource->Length, | ||
479 | - ACPI_ROUND_UP_TO_NATIVE_WORD (ACPI_RS_SIZE (ACPI_RESOURCE_IRQ))); | ||
480 | + (int) (ACPI_ROUND_UP_TO_NATIVE_WORD (ACPI_RS_SIZE (ACPI_RESOURCE_IRQ)))); | ||
481 | } | ||
482 | |||
483 | if (CurrentResource->Data.Irq.Triggering != 0) /* Level-Triggered */ | ||
484 | @@ -981,7 +981,7 @@ AtRsrcTest0012(void) | ||
485 | AapiErrors++; | ||
486 | printf ("API Error: AcpiGetPossibleResources(%s) returned Length %d," | ||
487 | " expected %d\n", | ||
488 | - Pathname, OutBuffer.Length, RT0000_DEV0_CRS_LEN); | ||
489 | + Pathname, (int) OutBuffer.Length, RT0000_DEV0_CRS_LEN); | ||
490 | return (AE_ERROR); | ||
491 | } | ||
492 | |||
493 | @@ -1923,7 +1923,7 @@ AtRsrcTest0026(void) | ||
494 | AapiErrors++; | ||
495 | printf ("API Error: AcpiGetIrqRoutingTable(%s) returned Length %d," | ||
496 | " expected %d\n", | ||
497 | - Pathname, OutBuffer.Length, 0xA48); | ||
498 | + Pathname, (int) OutBuffer.Length, 0xA48); | ||
499 | return (AE_ERROR); | ||
500 | } | ||
501 | |||
502 | diff --git a/tests/aapits/osunixxf.c b/tests/aapits/osunixxf.c | ||
503 | index 9f908fb..1fbdb70 100644 | ||
504 | --- a/tests/aapits/osunixxf.c | ||
505 | +++ b/tests/aapits/osunixxf.c | ||
506 | @@ -384,7 +384,6 @@ AcpiOsActualVprintf ( | ||
507 | const char *Fmt, | ||
508 | va_list Args) | ||
509 | { | ||
510 | - INT32 Count = 0; | ||
511 | UINT8 Flags; | ||
512 | |||
513 | |||
514 | @@ -397,7 +396,7 @@ AcpiOsActualVprintf ( | ||
515 | { | ||
516 | /* Output file is open, send the output there */ | ||
517 | |||
518 | - Count = vfprintf (AcpiGbl_DebugFile, Fmt, Args); | ||
519 | + vfprintf (AcpiGbl_DebugFile, Fmt, Args); | ||
520 | } | ||
521 | else | ||
522 | { | ||
523 | @@ -409,7 +408,7 @@ AcpiOsActualVprintf ( | ||
524 | |||
525 | if (Flags & ACPI_DB_CONSOLE_OUTPUT) | ||
526 | { | ||
527 | - Count = vfprintf (AcpiGbl_OutputFile, Fmt, Args); | ||
528 | + vfprintf (AcpiGbl_OutputFile, Fmt, Args); | ||
529 | } | ||
530 | |||
531 | return; | ||
532 | @@ -1166,3 +1165,23 @@ AcpiOsActualSignal ( | ||
533 | |||
534 | return (AE_OK); | ||
535 | } | ||
536 | + | ||
537 | +/****************************************************************************** | ||
538 | + * | ||
539 | + * FUNCTION: AcpiOsWaitEventsComplete | ||
540 | + * | ||
541 | + * PARAMETERS: None | ||
542 | + * | ||
543 | + * RETURN: None | ||
544 | + * | ||
545 | + * DESCRIPTION: Wait for all asynchronous events to complete. This | ||
546 | + * implementation does nothing. | ||
547 | + * | ||
548 | + *****************************************************************************/ | ||
549 | + | ||
550 | +void | ||
551 | +AcpiOsWaitEventsComplete ( | ||
552 | + void) | ||
553 | +{ | ||
554 | + return; | ||
555 | +} | ||
556 | -- | ||
557 | 1.8.4.2 | ||
558 | |||
diff --git a/meta-oe/recipes-extended/acpica/acpitests_20140114.bb b/meta-oe/recipes-extended/acpica/acpitests_20140114.bb new file mode 100644 index 000000000..d84ac64a6 --- /dev/null +++ b/meta-oe/recipes-extended/acpica/acpitests_20140114.bb | |||
@@ -0,0 +1,32 @@ | |||
1 | SUMMARY = "Test suite used to validate ACPICA." | ||
2 | HOMEPAGE = "http://www.acpica.org/" | ||
3 | |||
4 | LICENSE = "Intel" | ||
5 | LIC_FILES_CHKSUM = "file://tests/aapits/atexec.c;beginline=1;endline=115;md5=e92bcdfcd01d117d1bda3e814bb2030a" | ||
6 | |||
7 | DEPENDS = "bison flex" | ||
8 | |||
9 | SRC_URI = "https://acpica.org/sites/acpica/files/acpitests-unix-${PV}.tar.gz \ | ||
10 | https://acpica.org/sites/acpica/files/acpica-unix2-${PV}.tar.gz \ | ||
11 | file://0001-Fixup-aapits-build.patch \ | ||
12 | " | ||
13 | SRC_URI[md5sum] = "c72b61e092d2b25726dfff6e455116c9" | ||
14 | SRC_URI[sha256sum] = "368f69296edef5138fd33affa2d50bdcdd1dfd2f6919ba782f8ecf03971a3a2c" | ||
15 | |||
16 | S = "${WORKDIR}/acpitests-unix-${PV}" | ||
17 | |||
18 | EXTRA_OEMAKE = "CC=${TARGET_PREFIX}gcc 'OPT_CFLAGS=-Wall'" | ||
19 | |||
20 | # The Makefiles expect a specific layout | ||
21 | do_compile() { | ||
22 | cp -af ${WORKDIR}/acpica-unix2-${PV}/source ${S} | ||
23 | cd tests/aapits | ||
24 | oe_runmake | ||
25 | } | ||
26 | |||
27 | do_install() { | ||
28 | install -d ${D}${bindir} | ||
29 | install -m0755 tests/aapits/bin/aapits ${D}${bindir} | ||
30 | } | ||
31 | |||
32 | COMPATIBLE_HOST = "(i.86|x86_64|arm|aarch64).*-linux" | ||