diff options
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r-- | meta-oe/recipes-extended/nicstat/nicstat/0001-nicstat.c-Do-not-define-uint64_t-and-uint32_t.patch | 37 | ||||
-rw-r--r-- | meta-oe/recipes-extended/nicstat/nicstat_1.95.bb | 4 |
2 files changed, 40 insertions, 1 deletions
diff --git a/meta-oe/recipes-extended/nicstat/nicstat/0001-nicstat.c-Do-not-define-uint64_t-and-uint32_t.patch b/meta-oe/recipes-extended/nicstat/nicstat/0001-nicstat.c-Do-not-define-uint64_t-and-uint32_t.patch new file mode 100644 index 000000000..a208f97eb --- /dev/null +++ b/meta-oe/recipes-extended/nicstat/nicstat/0001-nicstat.c-Do-not-define-uint64_t-and-uint32_t.patch | |||
@@ -0,0 +1,37 @@ | |||
1 | From 52590fbf735cef3fec85a042458aa89a02c52b57 Mon Sep 17 00:00:00 2001 | ||
2 | From: Khem Raj <raj.khem@gmail.com> | ||
3 | Date: Sat, 15 Jul 2017 11:33:12 -0700 | ||
4 | Subject: [PATCH] nicstat.c: Do not define uint64_t and uint32_t | ||
5 | |||
6 | Use the defines from platform | ||
7 | |||
8 | Signed-off-by: Khem Raj <raj.khem@gmail.com> | ||
9 | |||
10 | --- | ||
11 | nicstat.c | 3 +-- | ||
12 | 1 file changed, 1 insertion(+), 2 deletions(-) | ||
13 | |||
14 | diff --git a/nicstat.c b/nicstat.c | ||
15 | index 83ad557..2a6e0c1 100644 | ||
16 | --- a/nicstat.c | ||
17 | +++ b/nicstat.c | ||
18 | @@ -32,6 +32,7 @@ | ||
19 | |||
20 | #include <stdio.h> | ||
21 | #include <stdlib.h> | ||
22 | +#include <stdint.h> | ||
23 | #include <unistd.h> | ||
24 | #include <string.h> | ||
25 | #include <ctype.h> | ||
26 | @@ -88,8 +89,6 @@ | ||
27 | #define PROC_NET_BUFSIZ (128 * 1024) | ||
28 | #define PROC_UPTIME "/proc/uptime" | ||
29 | /* Needs to be fixed if not built under ILP32 */ | ||
30 | -typedef unsigned long long uint64_t; | ||
31 | -typedef unsigned int uint32_t; | ||
32 | extern char *optarg; | ||
33 | extern int optind, opterr, optopt; | ||
34 | #endif /* OS_LINUX */ | ||
35 | -- | ||
36 | 2.13.3 | ||
37 | |||
diff --git a/meta-oe/recipes-extended/nicstat/nicstat_1.95.bb b/meta-oe/recipes-extended/nicstat/nicstat_1.95.bb index 5126a31cd..3875f0f60 100644 --- a/meta-oe/recipes-extended/nicstat/nicstat_1.95.bb +++ b/meta-oe/recipes-extended/nicstat/nicstat_1.95.bb | |||
@@ -5,7 +5,9 @@ HOMEPAGE = "http://nicstat.sourceforge.net" | |||
5 | LICENSE = "Artistic-2.0" | 5 | LICENSE = "Artistic-2.0" |
6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b4a94da2a1f918b217ef5156634fc9e0" | 6 | LIC_FILES_CHKSUM = "file://LICENSE.txt;md5=b4a94da2a1f918b217ef5156634fc9e0" |
7 | 7 | ||
8 | SRC_URI = "http://softlayer-sng.dl.sourceforge.net/project/${BPN}/${BP}.tar.gz" | 8 | SRC_URI = "http://softlayer-sng.dl.sourceforge.net/project/${BPN}/${BP}.tar.gz \ |
9 | file://0001-nicstat.c-Do-not-define-uint64_t-and-uint32_t.patch \ | ||
10 | " | ||
9 | SRC_URI[md5sum] = "9a0b87bbc670c1e738e5b40c7afd184d" | 11 | SRC_URI[md5sum] = "9a0b87bbc670c1e738e5b40c7afd184d" |
10 | SRC_URI[sha256sum] = "c4cc33f8838f4523f27c3d7584eedbe59f4c587f0821612f5ac2201adc18b367" | 12 | SRC_URI[sha256sum] = "c4cc33f8838f4523f27c3d7584eedbe59f4c587f0821612f5ac2201adc18b367" |
11 | 13 | ||