summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r--meta-oe/recipes-extended/polkit/polkit-0.104/0001-PolkitUnixSession-Set-error-if-we-cannot-find-a-sess.patch70
-rw-r--r--meta-oe/recipes-extended/polkit/polkit-0.104/0002-PolkitUnixSession-Actually-return-TRUE-if-a-session-.patch46
-rw-r--r--meta-oe/recipes-extended/polkit/polkit-0.104/obsolete_automake_macros.patch23
-rw-r--r--meta-oe/recipes-extended/polkit/polkit/polkit-1_pam.patch (renamed from meta-oe/recipes-extended/polkit/polkit-0.104/polkit-1_pam.patch)0
-rw-r--r--meta-oe/recipes-extended/polkit/polkit_0.111.bb (renamed from meta-oe/recipes-extended/polkit/polkit_0.104.bb)51
5 files changed, 34 insertions, 156 deletions
diff --git a/meta-oe/recipes-extended/polkit/polkit-0.104/0001-PolkitUnixSession-Set-error-if-we-cannot-find-a-sess.patch b/meta-oe/recipes-extended/polkit/polkit-0.104/0001-PolkitUnixSession-Set-error-if-we-cannot-find-a-sess.patch
deleted file mode 100644
index c021bfb96..000000000
--- a/meta-oe/recipes-extended/polkit/polkit-0.104/0001-PolkitUnixSession-Set-error-if-we-cannot-find-a-sess.patch
+++ /dev/null
@@ -1,70 +0,0 @@
1From c46d2d13eac240d2a609b2dd8fc617ea18a78bfa Mon Sep 17 00:00:00 2001
2From: David Zeuthen <davidz@redhat.com>
3Date: Mon, 6 Feb 2012 11:24:53 -0500
4Subject: [PATCH 1/2] PolkitUnixSession: Set error if we cannot find a session for the given pid
5
6Also, don't treat the integer returned by sd_pid_get_session() as a
7boolean because that's just confusing. Also, don't confuse memory
8supposed to be freed by g_free() and free(3) with each other. See
9
10 https://bugzilla.redhat.com/show_bug.cgi?id=787222
11
12for more details.
13
14Signed-off-by: David Zeuthen <davidz@redhat.com>
15---
16
17Upstream-Status: Accepted
18
19 src/polkit/polkitunixsession-systemd.c | 21 ++++++++++++++++-----
20 1 files changed, 16 insertions(+), 5 deletions(-)
21
22diff --git a/src/polkit/polkitunixsession-systemd.c b/src/polkit/polkitunixsession-systemd.c
23index e7e913f..94a7ee4 100644
24--- a/src/polkit/polkitunixsession-systemd.c
25+++ b/src/polkit/polkitunixsession-systemd.c
26@@ -23,6 +23,7 @@
27 # include "config.h"
28 #endif
29
30+#include <stdlib.h>
31 #include <string.h>
32 #include "polkitunixsession.h"
33 #include "polkitsubject.h"
34@@ -450,9 +451,8 @@ polkit_unix_session_initable_init (GInitable *initable,
35 GError **error)
36 {
37 PolkitUnixSession *session = POLKIT_UNIX_SESSION (initable);
38- gboolean ret;
39-
40- ret = FALSE;
41+ gboolean ret = FALSE;
42+ char *s;
43
44 if (session->session_id != NULL)
45 {
46@@ -461,8 +461,19 @@ polkit_unix_session_initable_init (GInitable *initable,
47 goto out;
48 }
49
50- if (!sd_pid_get_session (session->pid, &session->session_id))
51- ret = TRUE;
52+ if (sd_pid_get_session (session->pid, &s) == 0)
53+ {
54+ session->session_id = g_strdup (s);
55+ free (s);
56+ ret = TRUE;
57+ goto out;
58+ }
59+
60+ g_set_error (error,
61+ POLKIT_ERROR,
62+ POLKIT_ERROR_FAILED,
63+ "No session for pid %d",
64+ (gint) session->pid);
65
66 out:
67 return ret;
68--
691.7.2.5
70
diff --git a/meta-oe/recipes-extended/polkit/polkit-0.104/0002-PolkitUnixSession-Actually-return-TRUE-if-a-session-.patch b/meta-oe/recipes-extended/polkit/polkit-0.104/0002-PolkitUnixSession-Actually-return-TRUE-if-a-session-.patch
deleted file mode 100644
index 49f8ce2a0..000000000
--- a/meta-oe/recipes-extended/polkit/polkit-0.104/0002-PolkitUnixSession-Actually-return-TRUE-if-a-session-.patch
+++ /dev/null
@@ -1,46 +0,0 @@
1From 8fb8b406bab50c5ef8c5d4f743e3f13924bd5f73 Mon Sep 17 00:00:00 2001
2From: David Zeuthen <davidz@redhat.com>
3Date: Mon, 6 Feb 2012 11:26:06 -0500
4Subject: [PATCH 2/2] PolkitUnixSession: Actually return TRUE if a session exists
5
6Also, don't treat the integer returned by sd_session_get_uid() as a
7boolean because that's just confusing.
8
9Signed-off-by: David Zeuthen <davidz@redhat.com>
10---
11
12Upstream-Status: Accepted
13
14 src/polkit/polkitunixsession-systemd.c | 12 +++++-------
15 1 files changed, 5 insertions(+), 7 deletions(-)
16
17diff --git a/src/polkit/polkitunixsession-systemd.c b/src/polkit/polkitunixsession-systemd.c
18index 94a7ee4..8a8bf65 100644
19--- a/src/polkit/polkitunixsession-systemd.c
20+++ b/src/polkit/polkitunixsession-systemd.c
21@@ -361,17 +361,15 @@ polkit_unix_session_to_string (PolkitSubject *subject)
22
23 static gboolean
24 polkit_unix_session_exists_sync (PolkitSubject *subject,
25- GCancellable *cancellable,
26- GError **error)
27+ GCancellable *cancellable,
28+ GError **error)
29 {
30 PolkitUnixSession *session = POLKIT_UNIX_SESSION (subject);
31- gboolean ret;
32+ gboolean ret = FALSE;
33 uid_t uid;
34
35- ret = FALSE;
36-
37- if (!sd_session_get_uid (session->session_id, &uid))
38- ret = FALSE;
39+ if (sd_session_get_uid (session->session_id, &uid) == 0)
40+ ret = TRUE;
41
42 return ret;
43 }
44--
451.7.2.5
46
diff --git a/meta-oe/recipes-extended/polkit/polkit-0.104/obsolete_automake_macros.patch b/meta-oe/recipes-extended/polkit/polkit-0.104/obsolete_automake_macros.patch
deleted file mode 100644
index 5a6046cc3..000000000
--- a/meta-oe/recipes-extended/polkit/polkit-0.104/obsolete_automake_macros.patch
+++ /dev/null
@@ -1,23 +0,0 @@
1Upstream-Status: Submitted [https://bugs.freedesktop.org/show_bug.cgi?id=59091]
2
3Signed-off-by: Marko Lindqvist <cazfi74@gmail.com>
4diff -Nurd polkit-0.104/configure.ac polkit-0.104/configure.ac
5--- polkit-0.104/configure.ac 2012-01-03 18:25:49.000000000 +0200
6+++ polkit-0.104/configure.ac 2013-01-07 03:13:31.862125625 +0200
7@@ -3,7 +3,7 @@
8 AC_PREREQ(2.59c)
9 AC_INIT(polkit, 0.104, http://lists.freedesktop.org/mailman/listinfo/polkit-devel)
10 AM_INIT_AUTOMAKE(polkit, 0.104)
11-AM_CONFIG_HEADER(config.h)
12+AC_CONFIG_HEADERS(config.h)
13 AM_MAINTAINER_MODE
14
15 m4_ifdef([AM_SILENT_RULES], [AM_SILENT_RULES([yes])])
16@@ -24,7 +24,6 @@
17
18 AC_ISC_POSIX
19 AC_PROG_CC
20-AM_PROG_CC_STDC
21 AC_HEADER_STDC
22 AM_PROG_LIBTOOL
23 AC_PROG_MAKE_SET
diff --git a/meta-oe/recipes-extended/polkit/polkit-0.104/polkit-1_pam.patch b/meta-oe/recipes-extended/polkit/polkit/polkit-1_pam.patch
index 74647efce..74647efce 100644
--- a/meta-oe/recipes-extended/polkit/polkit-0.104/polkit-1_pam.patch
+++ b/meta-oe/recipes-extended/polkit/polkit/polkit-1_pam.patch
diff --git a/meta-oe/recipes-extended/polkit/polkit_0.104.bb b/meta-oe/recipes-extended/polkit/polkit_0.111.bb
index 8a18692fd..33101cf7b 100644
--- a/meta-oe/recipes-extended/polkit/polkit_0.104.bb
+++ b/meta-oe/recipes-extended/polkit/polkit_0.111.bb
@@ -5,39 +5,56 @@ LICENSE = "LGPLv2+"
5LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \ 5LIC_FILES_CHKSUM = "file://COPYING;md5=155db86cdbafa7532b41f390409283eb \
6 file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4" 6 file://src/polkit/polkit.h;beginline=1;endline=20;md5=0a8630b0133176d0504c87a0ded39db4"
7 7
8DEPENDS = "expat glib-2.0 intltool-native gobject-introspection-stub" 8DEPENDS = "expat glib-2.0 intltool-native gobject-introspection-stub mozjs"
9
10inherit autotools gtk-doc pkgconfig useradd systemd
9 11
10PACKAGECONFIG = "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \ 12PACKAGECONFIG = "${@base_contains('DISTRO_FEATURES', 'pam', 'pam', '', d)} \
11 ${@base_contains('DISTRO_FEATURES','systemd','systemd','consolekit',d)}" 13 ${@base_contains('DISTRO_FEATURES','systemd','systemd','consolekit',d)}"
12 14
13PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam" 15PACKAGECONFIG[pam] = "--with-authfw=pam,--with-authfw=shadow,libpam,libpam"
14PACKAGECONFIG[systemd] = "--enable-systemd,--disable-systemd,systemd" 16PACKAGECONFIG[systemd] = "--enable-libsystemd-login=yes --with-systemdsystemunitdir=${systemd_unitdir}/system/,--enable-libsystemd-login=no --with-systemdsystemunitdir=,systemd"
15# there is no --enable/--disable option for consolekit and it's not picked by shlibs, so add it to RDEPENDS 17# there is no --enable/--disable option for consolekit and it's not picked by shlibs, so add it to RDEPENDS
16PACKAGECONFIG[consolekit] = ",,,consolekit" 18PACKAGECONFIG[consolekit] = ",,,consolekit"
17 19
18PR = "r12"
19
20PAM_SRC_URI = "file://polkit-1_pam.patch" 20PAM_SRC_URI = "file://polkit-1_pam.patch"
21SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \ 21SRC_URI = "http://www.freedesktop.org/software/polkit/releases/polkit-${PV}.tar.gz \
22 ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \ 22 ${@base_contains('DISTRO_FEATURES', 'pam', '${PAM_SRC_URI}', '', d)} \
23 file://0001-PolkitUnixSession-Set-error-if-we-cannot-find-a-sess.patch \
24 file://0002-PolkitUnixSession-Actually-return-TRUE-if-a-session-.patch \
25 file://obsolete_automake_macros.patch \
26" 23"
27 24
28SRC_URI[md5sum] = "e380b4c6fb1e7bccf854e92edc0a8ce1" 25SRC_URI[md5sum] = "81b116edf986d8e13502929a171f4e0d"
29SRC_URI[sha256sum] = "6b0a13d8381e4a7b7e37c18a54595191b50757e0fcd186cd9918e9ad0f18c7f9" 26SRC_URI[sha256sum] = "02ae544547211b687818c97bcbf19bf6b8b5be7fda93000525a8765c7bed1ea1"
30 27
31EXTRA_OECONF = "--with-os-type=moblin --disable-man-pages --disable-introspection" 28EXTRA_OECONF = "--with-os-type=moblin --disable-man-pages --disable-introspection"
32 29
33inherit autotools gtk-doc pkgconfig
34
35do_install_append() { 30do_install_append() {
36 rm -f ${D}${libdir}/${BPN}-1/extensions/*.a 31 # see configure.log for more details
32 chown root:root ${D}${libdir}/${BPN}-1/polkit-agent-helper-1
33 chmod 4755 ${D}${libdir}/${BPN}-1/polkit-agent-helper-1
34
35 chown root:root ${D}${bindir}/pkexec
36 chmod 4755 ${D}${bindir}/pkexec
37
38 chown polkitd:polkitd ${D}${sysconfdir}/${BPN}-1/rules.d
39 chmod 700 ${D}${sysconfdir}/${BPN}-1/rules.d
40
41 chown polkitd:polkitd ${D}${datadir}/${BPN}-1/rules.d
42 chmod 700 ${D}${datadir}/${BPN}-1/rules.d
37} 43}
38 44
39FILES_${PN} += "${libdir}/${BPN}-1/extensions/*.so \ 45PACKAGES =+ "${PN}-examples"
40 ${datadir}/${BPN}-1/actions/* \ 46
41 ${datadir}/dbus-1/system-services/*" 47FILES_${PN} += " \
42FILES_${PN}-dbg += "${libdir}/${BPN}-1/extensions/.debug/*.so" 48 ${libdir}/${BPN}-1 \
43FILES_${PN}-dev += "${libdir}/${BPN}-1/extensions/*.la " 49 ${datadir}/dbus-1 \
50 ${datadir}/${BPN}-1 \
51"
52FILES_${PN}-dbg += "${libdir}/${BPN}-1/.debug"
53
54FILES_${PN}-examples = "${bindir}/*example*"
55
56USERADD_PACKAGES = "${PN}"
57USERADD_PARAM_${PN} = "--system --no-create-home --user-group --home-dir ${sysconfdir}/${BPN}-1 polkitd"
58
59SYSTEMD_SERVICE_${PN} = "${BPN}.service"
60SYSTEMD_AUTO_ENABLE = "disable"