diff options
Diffstat (limited to 'meta-oe/recipes-extended')
-rw-r--r-- | meta-oe/recipes-extended/dlm/dlm/respect-ldflags-also-from-bin_ldflags.patch | 36 | ||||
-rw-r--r-- | meta-oe/recipes-extended/dlm/dlm_4.0.2.bb | 51 |
2 files changed, 0 insertions, 87 deletions
diff --git a/meta-oe/recipes-extended/dlm/dlm/respect-ldflags-also-from-bin_ldflags.patch b/meta-oe/recipes-extended/dlm/dlm/respect-ldflags-also-from-bin_ldflags.patch deleted file mode 100644 index 69b2f903c..000000000 --- a/meta-oe/recipes-extended/dlm/dlm/respect-ldflags-also-from-bin_ldflags.patch +++ /dev/null | |||
@@ -1,36 +0,0 @@ | |||
1 | diff -uNr dlm-4.0.2.orig/dlm_controld/Makefile dlm-4.0.2/dlm_controld/Makefile | ||
2 | --- dlm-4.0.2.orig/dlm_controld/Makefile 2017-04-04 10:49:23.661320260 +0200 | ||
3 | +++ dlm-4.0.2/dlm_controld/Makefile 2017-04-04 10:50:36.121326429 +0200 | ||
4 | @@ -55,7 +55,7 @@ | ||
5 | BIN_CFLAGS += -fPIE -DPIE | ||
6 | BIN_CFLAGS += -I../include -I../libdlm | ||
7 | |||
8 | -BIN_LDFLAGS += -Wl,-z,now -Wl,-z,relro -pie | ||
9 | +BIN_LDFLAGS += $(LDFLAGS) -Wl,-z,now -Wl,-z,relro -pie | ||
10 | BIN_LDFLAGS += -lpthread -lrt -lcpg -lcmap -lcfg -lquorum | ||
11 | |||
12 | LIB_CFLAGS += $(BIN_CFLAGS) | ||
13 | diff -uNr dlm-4.0.2.orig/dlm_tool/Makefile dlm-4.0.2/dlm_tool/Makefile | ||
14 | --- dlm-4.0.2.orig/dlm_tool/Makefile 2013-07-31 17:50:26.000000000 +0200 | ||
15 | +++ dlm-4.0.2/dlm_tool/Makefile 2017-04-04 10:50:44.617327153 +0200 | ||
16 | @@ -32,7 +32,7 @@ | ||
17 | BIN_CFLAGS += -fPIE -DPIE | ||
18 | BIN_CFLAGS += -I../include -I../libdlm -I../dlm_controld | ||
19 | |||
20 | -BIN_LDFLAGS += -Wl,-z,now -Wl,-z,relro -pie | ||
21 | +BIN_LDFLAGS += $(LDFLAGS) -Wl,-z,now -Wl,-z,relro -pie | ||
22 | BIN_LDFLAGS += -L../libdlm -L../dlm_controld | ||
23 | BIN_LDFLAGS += -lpthread -ldlm -ldlmcontrol | ||
24 | |||
25 | diff -uNr dlm-4.0.2.orig/dlm_controld/Makefile dlm-4.0.2/dlm_controld/Makefile | ||
26 | --- dlm-4.0.2.orig/dlm_controld/Makefile 2017-04-04 11:02:58.578389641 +0200 | ||
27 | +++ dlm-4.0.2/dlm_controld/Makefile 2017-04-04 11:07:55.672414935 +0200 | ||
28 | @@ -59,7 +59,7 @@ | ||
29 | BIN_LDFLAGS += -lpthread -lrt -lcpg -lcmap -lcfg -lquorum | ||
30 | |||
31 | LIB_CFLAGS += $(BIN_CFLAGS) | ||
32 | -LIB_LDFLAGS += -Wl,-z,relro -pie | ||
33 | +LIB_LDFLAGS += $(LDFLAGS) -Wl,-z,relro -pie | ||
34 | |||
35 | ifeq ($(USE_SD_NOTIFY),yes) | ||
36 | BIN_CFLAGS += $(shell pkg-config --cflags libsystemd-daemon) \ | ||
diff --git a/meta-oe/recipes-extended/dlm/dlm_4.0.2.bb b/meta-oe/recipes-extended/dlm/dlm_4.0.2.bb deleted file mode 100644 index 31e411e86..000000000 --- a/meta-oe/recipes-extended/dlm/dlm_4.0.2.bb +++ /dev/null | |||
@@ -1,51 +0,0 @@ | |||
1 | DESCRIPTION = "dlm control daemon and tool" | ||
2 | |||
3 | SECTION = "utils" | ||
4 | HOMEPAGE = "https://fedorahosted.org/cluster/wiki/HomePage" | ||
5 | |||
6 | REQUIRED_DISTRO_FEATURES = "systemd" | ||
7 | |||
8 | SRC_URI = "https://git.fedorahosted.org/cgit/dlm.git/snapshot/${BP}.tar.xz \ | ||
9 | file://respect-ldflags-also-from-bin_ldflags.patch \ | ||
10 | " | ||
11 | |||
12 | SRC_URI[md5sum] = "efc2ee6093aa6aa0a88aaad83e998a3f" | ||
13 | SRC_URI[sha256sum] = "b89bc557aaffbab0ac005398025f247718a5589cff6574d902eaffe2b20e683e" | ||
14 | |||
15 | LICENSE = "LGPLv2+ & GPLv2 & GPLv2+" | ||
16 | LIC_FILES_CHKSUM = "file://README.license;md5=8f0bbcdd678df1bce9863492b6c8832d" | ||
17 | |||
18 | DEPENDS = "corosync systemd" | ||
19 | |||
20 | inherit pkgconfig systemd distro_features_check | ||
21 | |||
22 | SYSTEMD_SERVICE_${PN} = "dlm.service" | ||
23 | SYSTEMD_AUTO_ENABLE = "enable" | ||
24 | |||
25 | export EXTRA_OEMAKE = "" | ||
26 | |||
27 | do_compile_prepend() { | ||
28 | sed -i "s/libsystemd-daemon/libsystemd/g" ${S}/dlm_controld/Makefile | ||
29 | } | ||
30 | |||
31 | do_compile () { | ||
32 | oe_runmake 'CC=${CC}' | ||
33 | } | ||
34 | |||
35 | do_install_append (){ | ||
36 | install -d ${D}${sysconfdir}/sysconfig/ | ||
37 | install -d ${D}${sysconfdir}/init.d/ | ||
38 | install -m 0644 ${S}/init/dlm.sysconfig ${D}${sysconfdir}/sysconfig/dlm | ||
39 | install -m 0644 ${S}/init/dlm.init ${D}${sysconfdir}/init.d/dlm | ||
40 | |||
41 | # install systemd unit files | ||
42 | if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then | ||
43 | install -d ${D}${systemd_unitdir}/system | ||
44 | install -m 0644 ${S}/init/dlm.service ${D}${systemd_unitdir}/system | ||
45 | fi | ||
46 | } | ||
47 | |||
48 | do_install() { | ||
49 | oe_runmake install DESTDIR=${D} LIBDIR=${libdir} | ||
50 | } | ||
51 | |||