summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/upm/upm_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/upm/upm_git.bb')
-rw-r--r--meta-oe/recipes-extended/upm/upm_git.bb45
1 files changed, 45 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/upm/upm_git.bb b/meta-oe/recipes-extended/upm/upm_git.bb
new file mode 100644
index 000000000..38065ce53
--- /dev/null
+++ b/meta-oe/recipes-extended/upm/upm_git.bb
@@ -0,0 +1,45 @@
1SUMMARY = "Sensor/Actuator repository for Mraa"
2HOMEPAGE = "https://github.com/intel-iot-devkit/upm"
3SECTION = "libs"
4
5LICENSE = "MIT"
6LIC_FILES_CHKSUM = "file://LICENSE;md5=66493d54e65bfc12c7983ff2e884f37f"
7
8DEPENDS = "libjpeg-turbo mraa"
9
10SRCREV = "106b6c706268522ab0168a4ddb19e89ce832e084"
11PV = "1.3.0-git${SRCPV}"
12
13SRC_URI = " \
14 git://github.com/intel-iot-devkit/${BPN}.git;protocol=http \
15 file://ads1x15-fixed-case-logic-in-getThresh-function.patch \
16"
17
18S = "${WORKDIR}/git"
19
20# Depends on mraa which only supports x86 and ARM for now
21COMPATIBLE_HOST = "(x86_64.*|i.86.*|aarch64.*|arm.*)-linux"
22
23inherit distutils3-base cmake
24
25
26# override this in local.conf to get needed bindings.
27# BINDINGS_pn-upm="python"
28# will result in only the python bindings being built/packaged.
29BINDINGS ??= "python ${@ 'nodejs' if oe.types.boolean(d.getVar('HAVE_NODEJS') or '0') else '' }"
30
31PACKAGECONFIG ??= "${@bb.utils.contains('PACKAGES', 'node-${PN}', 'nodejs', '', d)} \
32 ${@bb.utils.contains('PACKAGES', '${PYTHON_PN}-${PN}', 'python', '', d)}"
33
34PACKAGECONFIG[python] = "-DBUILDSWIGPYTHON=ON, -DBUILDSWIGPYTHON=OFF, swig-native ${PYTHON_PN},"
35PACKAGECONFIG[nodejs] = "-DBUILDSWIGNODE=ON, -DBUILDSWIGNODE=OFF, swig-native nodejs-native,"
36
37FILES_${PYTHON_PN}-${PN} = "${PYTHON_SITEPACKAGES_DIR}"
38RDEPENDS_${PYTHON_PN}-${PN} += "${PYTHON_PN}"
39
40FILES_node-${PN} = "${prefix}/lib/node_modules/"
41RDEPENDS_node-${PN} += "nodejs"
42
43### Include desired language bindings ###
44PACKAGES =+ "${@bb.utils.contains('BINDINGS', 'nodejs', 'node-${PN}', '', d)}"
45PACKAGES =+ "${@bb.utils.contains('BINDINGS', 'python', '${PYTHON_PN}-${PN}', '', d)}"