summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb')
-rw-r--r--meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb47
1 files changed, 47 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb b/meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb
new file mode 100644
index 000000000..24df750e0
--- /dev/null
+++ b/meta-oe/recipes-extended/triggerhappy/triggerhappy_git.bb
@@ -0,0 +1,47 @@
1SUMMARY = "A lightweight hotkey daemon"
2HOMEPAGE = "https://github.com/wertarbyte/triggerhappy"
3
4LICENSE = "GPLv3"
5LIC_FILES_CHKSUM = "file://COPYING;md5=d32239bcb673463ab874e80d47fae504"
6
7# matches debian/0.5.0-1 tag
8SRCREV = "44a173195986d0d853316cb02a58785ded66c12b"
9PV = "0.5.0+git${SRCPV}"
10SRC_URI = "git://github.com/wertarbyte/${BPN}.git;branch=debian"
11
12S = "${WORKDIR}/git"
13
14inherit autotools-brokensep pkgconfig update-rc.d systemd
15
16PACKAGECONFIG = "${@bb.utils.contains('DISTRO_FEATURES','systemd','systemd','',d)}"
17PACKAGECONFIG[systemd] = ",,systemd"
18
19INITSCRIPT_NAME = "triggerhappy"
20INITSCRIPT_PARAMS = "defaults"
21SYSTEMD_SERVICE_${PN} = "triggerhappy.service triggerhappy.socket"
22
23FILES_${PN} = "\
24 ${sbindir}/thd \
25 ${sbindir}/th-cmd \
26 ${sysconfdir}/triggerhappy/triggers.d \
27 ${nonarch_base_libdir}/udev/rules.d/80-triggerhappy.rules \
28 ${sysconfdir}/init.d/triggerhappy \
29 ${systemd_unitdir}/system \
30"
31CONFFILES_${PN} = "${sysconfdir}/udev/rules.d/80-triggerhappy.rules"
32
33do_install_append() {
34 install -d ${D}${sysconfdir}/triggerhappy/triggers.d
35
36 install -d ${D}${nonarch_base_libdir}/udev/rules.d
37 install -m 0644 ${S}/udev/triggerhappy-udev.rules ${D}${nonarch_base_libdir}/udev/rules.d/80-triggerhappy.rules
38
39 install -d ${D}${sysconfdir}/init.d
40 install -m 0755 ${S}/debian/init.d ${D}${sysconfdir}/init.d/triggerhappy
41
42 if ${@bb.utils.contains('DISTRO_FEATURES','systemd','true','false',d)}; then
43 install -d ${D}/${systemd_unitdir}/system
44 install -m 0644 ${S}/systemd/triggerhappy.socket ${D}${systemd_unitdir}/system
45 install -m 0644 ${S}/systemd/triggerhappy.service ${D}${systemd_unitdir}/system
46 fi
47}