summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/tiptop/tiptop_2.3.1.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/tiptop/tiptop_2.3.1.bb')
-rw-r--r--meta-oe/recipes-extended/tiptop/tiptop_2.3.1.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/tiptop/tiptop_2.3.1.bb b/meta-oe/recipes-extended/tiptop/tiptop_2.3.1.bb
new file mode 100644
index 000000000..0a00a366e
--- /dev/null
+++ b/meta-oe/recipes-extended/tiptop/tiptop_2.3.1.bb
@@ -0,0 +1,26 @@
1SUMMARY = "Hardware performance monitoring counters"
2HOMEPAGE = "http://tiptop.gforge.inria.fr/"
3LICENSE = "GPLv2"
4LIC_FILES_CHKSUM = "file://COPYING;md5=b234ee4d69f5fce4486a80fdaf4a4263"
5DEPENDS = "ncurses libxml2"
6
7SRC_URI = "http://tiptop.gforge.inria.fr/releases/${BP}.tar.gz"
8SRC_URI[md5sum] = "46ca0fdf0236f02dd2b96d347626d2a2"
9SRC_URI[sha256sum] = "51c4449c95bba34f16b429729c2f58431490665d8093efaa8643b2e1d1084182"
10
11inherit autotools-brokensep
12EXTRA_OECONF = "CFLAGS="$CFLAGS -I${STAGING_INCDIR}/libxml2""
13COMPATIBLE_HOST = "(i.86|x86_64|arm|powerpc).*-linux"
14
15do_configure_prepend () {
16 # Two bugs in configure.ac when cross-compiling.
17 # 1. The path of libxml2. Specify it in EXTRA_OECONF.
18 # 2. hw's value on other platforms. Replace it if the target is
19 # not i*86/x86_64.
20 if ( echo "${TARGET_ARCH}" | grep -q -e 'i.86' -e 'x86_64' ); then
21 sed -i 's= -I/usr/include/libxml2==' ${S}/configure.ac
22 else
23 sed -i 's/hw=`uname -m`/hw="unknown"/' ${S}/configure.ac
24 sed -i 's= -I/usr/include/libxml2==' ${S}/configure.ac
25 fi
26}