diff options
Diffstat (limited to 'meta-oe/recipes-extended/tipcutils/tipcutils_git.bb')
-rw-r--r-- | meta-oe/recipes-extended/tipcutils/tipcutils_git.bb | 49 |
1 files changed, 49 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/tipcutils/tipcutils_git.bb b/meta-oe/recipes-extended/tipcutils/tipcutils_git.bb new file mode 100644 index 0000000000..b7157b4325 --- /dev/null +++ b/meta-oe/recipes-extended/tipcutils/tipcutils_git.bb | |||
@@ -0,0 +1,49 @@ | |||
1 | SUMMARY = "Transparent Inter-Process Communication protocol" | ||
2 | LICENSE = "GPLv2" | ||
3 | LIC_FILES_CHKSUM = "file://tipclog/tipc.h;endline=35;md5=985b6ea8735818511d276c1b466cce98" | ||
4 | |||
5 | SRC_URI = "git://git.code.sf.net/p/tipc/tipcutils \ | ||
6 | file://0001-include-sys-select.h-for-FD_-definitions.patch \ | ||
7 | file://0002-replace-non-standard-uint-with-unsigned-int.patch \ | ||
8 | " | ||
9 | SRCREV = "7ab2211b87414ba240b0b2e4af219c1057c9cf9a" | ||
10 | PV = "2.2.0+git${SRCPV}" | ||
11 | |||
12 | DEPENDS="virtual/kernel" | ||
13 | |||
14 | PACKAGE_ARCH = "${MACHINE_ARCH}" | ||
15 | |||
16 | inherit autotools pkgconfig | ||
17 | |||
18 | DEPENDS += "libdaemon" | ||
19 | |||
20 | S = "${WORKDIR}/git" | ||
21 | |||
22 | do_configure_prepend() { | ||
23 | ( cd ${S}; ${S}/bootstrap ) | ||
24 | } | ||
25 | |||
26 | do_install_append() { | ||
27 | demos="benchmark hello_world topology_subscr_demo connection_demo \ | ||
28 | multicast_demo stream_demo" | ||
29 | for i in $demos;do | ||
30 | install -d ${D}/opt/tipcutils/demos/$i | ||
31 | install ${B}/demos/$i/client_tipc ${D}/opt/tipcutils/demos/$i/ | ||
32 | install ${B}/demos/$i/server_tipc ${D}/opt/tipcutils/demos/$i/ | ||
33 | done | ||
34 | install -d ${D}/opt/tipcutils/demos/inventory_sim | ||
35 | install ${B}/demos/inventory_sim/inventory_sim ${D}/opt/tipcutils/demos/inventory_sim/ | ||
36 | |||
37 | install -d ${D}/opt/tipcutils/ptts | ||
38 | install ${B}/ptts/tipcTS ${D}/opt/tipcutils/ptts/ | ||
39 | install ${B}/ptts/tipcTC ${D}/opt/tipcutils/ptts/ | ||
40 | |||
41 | install -d ${D}${sysconfdir} | ||
42 | cp -R --no-dereference --preserve=mode,links -v ${S}/scripts/etc/* ${D}${sysconfdir}/ | ||
43 | chown -R root:root ${D}${sysconfdir} | ||
44 | } | ||
45 | |||
46 | PACKAGES += "${PN}-demos" | ||
47 | FILES_${PN}-dbg += "/opt/tipcutils/demos/*/.debug /opt/tipcutils/ptts/.debug" | ||
48 | FILES_${PN}-demos = "/opt/tipcutils/*" | ||
49 | |||