summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/subsurface/subsurface_git.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/subsurface/subsurface_git.bb')
-rw-r--r--meta-oe/recipes-extended/subsurface/subsurface_git.bb25
1 files changed, 7 insertions, 18 deletions
diff --git a/meta-oe/recipes-extended/subsurface/subsurface_git.bb b/meta-oe/recipes-extended/subsurface/subsurface_git.bb
index fc50eb680..1edb19e35 100644
--- a/meta-oe/recipes-extended/subsurface/subsurface_git.bb
+++ b/meta-oe/recipes-extended/subsurface/subsurface_git.bb
@@ -4,29 +4,18 @@ LIC_FILES_CHKSUM = "file://gpl-2.0.txt;md5=b234ee4d69f5fce4486a80fdaf4a4263"
4 4
5DEPENDS = "libdivecomputer gtk+ libxml2 glib-2.0 gconf" 5DEPENDS = "libdivecomputer gtk+ libxml2 glib-2.0 gconf"
6 6
7inherit gtk-icon-cache 7PNBLACKLIST[subsurface] = "Needs to be upgraded for compatibility with new libdivecomputer"
8
9inherit gtk-icon-cache cmake
8 10
9inherit gitpkgv 11inherit gitpkgv
10PKGV = "${GITPKGVTAG}" 12PKGV = "${GITPKGVTAG}"
11PV = "1.1" 13PV = "4.2"
12 14
13SRCREV = "bd275d73ac06823619230915a3aa29deddc996fb" 15SRCREV = "f61ee20ba356ecfc4c5b247f548f52d588179c94"
14SRC_URI = "git://subsurface.hohndel.org/subsurface.git \ 16SRC_URI = "git://subsurface.hohndel.org/subsurface.git"
15 file://pkgconfig.patch \
16 file://libm.patch"
17S = "${WORKDIR}/git" 17S = "${WORKDIR}/git"
18 18
19EXTRA_OEMAKE = "CC='${CC}' \ 19#FILES_${PN} += "${datadir}/icons/hicolor/scalable/apps/subsurface.svg"
20 libdc-usr=${STAGING_INCDIR}/libdivecomputer/* \
21 LIBDIVECOMPUTERINCLUDES=${STAGING_INCDIR}/libdivecomputer \
22 LIBDIVECOMPUTERARCHIVE=${STAGING_LIBDIR}/libdivecomputer.a \
23"
24
25do_install() {
26 oe_runmake install DESTDIR=${D}
27 rm ${D}${datadir}/icons/hicolor/icon-theme.cache
28}
29
30FILES_${PN} += "${datadir}/icons/hicolor/scalable/apps/subsurface.svg"
31RRECOMMENDS_${PN}_append_libc-glibc = " glibc-gconv-iso8859-15" 20RRECOMMENDS_${PN}_append_libc-glibc = " glibc-gconv-iso8859-15"
32 21