summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/sip/sip-native_4.14.2.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/sip/sip-native_4.14.2.bb')
-rw-r--r--meta-oe/recipes-extended/sip/sip-native_4.14.2.bb35
1 files changed, 0 insertions, 35 deletions
diff --git a/meta-oe/recipes-extended/sip/sip-native_4.14.2.bb b/meta-oe/recipes-extended/sip/sip-native_4.14.2.bb
deleted file mode 100644
index 602dc250f..000000000
--- a/meta-oe/recipes-extended/sip/sip-native_4.14.2.bb
+++ /dev/null
@@ -1,35 +0,0 @@
1SUMMARY = "SIP is a C++/Python Wrapper Generator"
2AUTHOR = "Phil Thompson"
3HOMEPAGE = "http://www.riverbankcomputing.co.uk/sip"
4SECTION = "devel"
5LICENSE = "GPLv2+"
6LIC_FILES_CHKSUM = "file://sipgen.sbf;endline=15;md5=61b2ce7ddd624968411804d2fa9d776c"
7
8# riverbankcomputing is upstream, but keeps only latest version, sf usually have few older
9#SRC_URI = "http://www.riverbankcomputing.com/static/Downloads/sip4/sip-${PV}.tar.gz"
10SRC_URI = "${SOURCEFORGE_MIRROR}/project/pyqt/sip/sip-${PV}/sip-${PV}.tar.gz"
11SRC_URI[md5sum] = "b93442e745b3be2fad89de0686a76ce9"
12SRC_URI[sha256sum] = "1a9d3bf26c821f369c175f8e68946b79bc994da4f96e8f5ecff06e6ee7ac0528"
13S = "${WORKDIR}/sip-${PV}/sipgen"
14
15inherit qmake2 native python-dir
16
17EXTRA_QMAKEVARS_POST += "DESTDIR=${S} CONFIG=console"
18
19export BUILD_SYS
20export HOST_SYS
21export STAGING_LIBDIR
22export STAGING_INCDIR
23
24do_configure_prepend() {
25 cat sipgen.sbf | sed s,target,TARGET, | sed s,sources,SOURCES, | sed s,headers,HEADERS, > sipgen.pro
26}
27do_install() {
28 install -d ${D}${bindir}
29 install -m 0755 sip ${D}${bindir}/sip
30 # python-pyqt expects sip4
31 ln -sf sip ${D}${bindir}/sip4
32 cd ${WORKDIR}/sip-${PV} && python configure.py
33 install -d ${D}${PYTHON_SITEPACKAGES_DIR}
34 install -m 0755 sip*.py ${D}${PYTHON_SITEPACKAGES_DIR}
35}