summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb')
-rw-r--r--meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb16
1 files changed, 8 insertions, 8 deletions
diff --git a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
index 9a3a66c2a..7e00f150d 100644
--- a/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
+++ b/meta-oe/recipes-extended/sblim-sfcb/sblim-sfcb_1.4.9.bb
@@ -36,10 +36,10 @@ inherit autotools
36inherit systemd 36inherit systemd
37 37
38SYSTEMD_PACKAGES = "${PN}" 38SYSTEMD_PACKAGES = "${PN}"
39SYSTEMD_SERVICE_${PN} = "sblim-sfcb.service" 39SYSTEMD_SERVICE:${PN} = "sblim-sfcb.service"
40SYSTEMD_AUTO_ENABLE = "enable" 40SYSTEMD_AUTO_ENABLE = "enable"
41 41
42LDFLAGS_append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}" 42LDFLAGS:append = "${@bb.utils.contains('DISTRO_FEATURES', 'ld-is-gold', ' -fuse-ld=bfd ', '', d)}"
43 43
44EXTRA_OECONF = '--enable-debug \ 44EXTRA_OECONF = '--enable-debug \
45 --enable-ssl \ 45 --enable-ssl \
@@ -50,7 +50,7 @@ EXTRA_OECONF = '--enable-debug \
50# make all with -j option is unsafe. 50# make all with -j option is unsafe.
51PARALLEL_MAKE = "" 51PARALLEL_MAKE = ""
52 52
53INSANE_SKIP_${PN} = "dev-so" 53INSANE_SKIP:${PN} = "dev-so"
54CONFIG_SITE = "${WORKDIR}/config-site.${P}" 54CONFIG_SITE = "${WORKDIR}/config-site.${P}"
55 55
56do_install() { 56do_install() {
@@ -68,16 +68,16 @@ do_install() {
68 rm -rf ${D}${libdir}/sfcb/*.la 68 rm -rf ${D}${libdir}/sfcb/*.la
69} 69}
70 70
71pkg_postinst_${PN} () { 71pkg_postinst:${PN} () {
72 $INTERCEPT_DIR/postinst_intercept delay_to_first_boot ${PKG} mlprefix=${MLPREFIX} 72 $INTERCEPT_DIR/postinst_intercept delay_to_first_boot ${PKG} mlprefix=${MLPREFIX}
73} 73}
74 74
75pkg_postinst_ontarget_${PN} () { 75pkg_postinst_ontarget:${PN} () {
76 ${datadir}/sfcb/genSslCert.sh ${sysconfdir}/sfcb 76 ${datadir}/sfcb/genSslCert.sh ${sysconfdir}/sfcb
77 ${bindir}/sfcbrepos -f 77 ${bindir}/sfcbrepos -f
78} 78}
79 79
80FILES_${PN} += "${libdir}/sfcb ${datadir}/sfcb" 80FILES:${PN} += "${libdir}/sfcb ${datadir}/sfcb"
81FILES_${PN}-dbg += "${libdir}/sfcb/.debug" 81FILES:${PN}-dbg += "${libdir}/sfcb/.debug"
82 82
83RDEPENDS_${PN} = "perl bash" 83RDEPENDS:${PN} = "perl bash"