summaryrefslogtreecommitdiffstats
path: root/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch
diff options
context:
space:
mode:
Diffstat (limited to 'meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch')
-rw-r--r--meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch32
1 files changed, 32 insertions, 0 deletions
diff --git a/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch b/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch
new file mode 100644
index 000000000..04af15dd8
--- /dev/null
+++ b/meta-oe/recipes-extended/redis/redis/0001-src-Do-not-reset-FINAL_LIBS.patch
@@ -0,0 +1,32 @@
1From 97584e1eb78dc18599534b47b6670c20c63f5ee2 Mon Sep 17 00:00:00 2001
2From: Khem Raj <raj.khem@gmail.com>
3Date: Tue, 10 Sep 2019 20:04:26 -0700
4Subject: [PATCH] src: Do not reset FINAL_LIBS
5
6This helps case where additional libraries are needed to be passed from
7environment to get it going
8
9e.g. -latomic is needed on clang/x86 to provide for 64bit atomics
10
11Upstream-Status: Pending
12Signed-off-by: Khem Raj <raj.khem@gmail.com>
13---
14 src/Makefile | 2 +-
15 1 file changed, 1 insertion(+), 1 deletion(-)
16
17diff --git a/src/Makefile b/src/Makefile
18index 7f7c625..c71dd3b 100644
19--- a/src/Makefile
20+++ b/src/Makefile
21@@ -66,7 +66,7 @@ endif
22
23 FINAL_CFLAGS=$(STD) $(WARN) $(OPT) $(DEBUG) $(CFLAGS) $(REDIS_CFLAGS)
24 FINAL_LDFLAGS=$(LDFLAGS) $(REDIS_LDFLAGS) $(DEBUG)
25-FINAL_LIBS=-lm
26+FINAL_LIBS+=-lm
27 DEBUG=-g -ggdb
28
29 ifeq ($(uname_S),SunOS)
30--
312.23.0
32